Jump to content
3DCoat Forums

Missing colour layers on importing multiple objects

Recommended Posts

  • Member

Hi @digman and the forum

I do have a problem with the colour layers when importing objects into 3DCoat.

I do have 3 different objects, completely textured. Each object has some layers. All the layers between the different models do have different names and all the layers are ordered correctly. All the models had been imported first from Sketchup as .OBJ files and coloured in 3DCoat. The object are imported by "Models per Pixel Painting". The filetypes are 3DCoat, .3b files. I still do have about 16GB of free memory on my boot drive.

After importing the models, to combine them to a single model, many of the layers disappear, even so the model parts are still textured correctly. Sometimes it even happens, that a layer completely disappears and the part of the model is not textured anymore. I also tried to add the layers to a folder before import, but this doesn´t help either. 

In "Picture8", 9 and 10 you can see the different objects with its layers.

In "Picture11", where 2 of the objects are imported, you allready can see, that some layers are missing, the grouping of the layers are broken, even so the objects are still painted correctly. And "Picture12" shows all 3 objects imported with more layers missing ....

When disabling the fender "Kotfluegel", f.e. you can see that also the window colour is gone and some other colours from all over the model.

I tried to import the different objects in different order, but same effect.

When I import more objects, some of the layers are completely gone and the model looses the according texture.

I also tried to find a solution in the forum, but couldn´t. There are many similar problems listed, but no solution for me.

If anyone could help me, I would highly appreciate your comments.

Thank you very much and best regards


PS: After a long night watching the Super Bowl till 5 o´clock in the morning. But this is not the reason for the problem, it also happened yesterday :-)






Edited by Stefka
Link to comment
Share on other sites

  • Member

Hi @Carlosan

I´m using 3DCoat 2023.41. Win 10 Home. 8 GB Ram.
Diffent texture resolutions from 256 x 256 up to 2048  x 2048. All together 5 textures.

All these different textures are packes to a new texture with 4096 x 4096. 

Technique of moving textures from original to new texture is done within UV room by "Move Sele".

The different textures are not packed by "PackUV2". The different textures are manually moved in blocks on the new UV map. This is done because of future editability for internal reasons.

In case you need any further informations please let me know.

Best regards


Link to comment
Share on other sites

  • Member

Hi @Carlosan

Merging the layers would be my last solution, because this reduces my capabilities to rework the model in the future.

I also can´t understand why my system should not be capable to handle the model. A 2 x 2 k texture has 4 MB. Lets pretend my model has an all over of 30 layers its a 120 MB of storage capacity. So 8 GB of internal memory should be enough to handle this. Beside this I can handle a model with 30 layers very well. 

More over, not only part of the layers themself are missing, but also the structure of the layers, means the foldersystem is mixed up. 

I can´t imagine that this is a problem of my computer. 

I think, if it would be a problem of my computer, than f.e. parts of layers would be missing or the colours would be mixed up. To me it looks like a pure handling problem of the layersystem.

Best regards



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...