Jump to content
3DCoat Forums
  • 0

Trying to make a Interior


Klaptrap85
 Share

Question

  • Member

I'm trying to make an interior room.  What I want to do is make something like a skybox, but with a floor (half-sphere with a bottom) 

 

I'm having this problem.  

it's the baking in the retopo room.  I understand how it works normally.  But What I don't understand is how to make it work when flipping the normals in the retopo room.  This is what I do.

1.Model the half sphere in the sculpt room

2. Retopo  it, bake it, and paint it for the test model

3. Once the text model looks okay, delete the test model, including everything in the paint room.

4.Retopo it again, but with flipped. with the exact same settings.

5.  But now when I try to paint on it, nothing is there, and I can't paint on it.  It also has it's layer in the texture preview

The thing about step 4 though is that I can't get the outer shell to show outside of model without the shell being extremely warped.  How would I go about making and painting this room?

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 1
  • Reputable Contributor

I am only offering another a workflow solution. Elemno gave one.

Edit: removed a sentence. 

A Workflow solution: No flipping required but a little more work.

Create the sculpt sphere.

Use cut and clone tool to cut half away of the sphere. Rotate the cut and clone object 180 degrees, Transform/ move to the inside of the top half of the sphere.

Slightly scale down the cut and clone object.

Hold down the Ctrl key and press the Enter Key to cut away the inside of the top half using the cut and clone object. Leave some thickness on the top half sphere.

Run Autopo on the entire half sphere. 

Delete the outer polygons as they are not needed.  Do this first before deleting. Under the View menu select backface culling so you do not select any interior polygons.

Look at my scan settings. You have to manually put in the minus sign baked scan settings In the Show Outer Shell as this is now a one sided interior retopo mesh. 

Bake to the paint room

 Under the View Menu in the Paint room now de-select Backface culling. easier to view on the eyes the interior of sphere. The paint on the outside is not really there it just appears to be as back face culling has been de-selected.

First picture shows the interior of the baked half sphere. The outside appears as backface culling is off so it is easier to look at. 

Second picture is my bake scan settings. 

Last image is the exported texture map. I just used this unwrapping for testing, You can choose your own.

I am not saying use the solution, but it is an option. 

 

dome.jpg

retopo.jpg

final4.png

Link to comment
Share on other sites

  • 0
  • Member
1 hour ago, Elemeno said:

those textures are projected from the inside, when you take it into a game engine , scale it you will have a full skybox on my video you will see it only project the inside but im looking from the outside

  I will try it after I get home.  Thanks.

 

1 hour ago, digman said:

I am only offering another a workflow solution. Elemno gave one.

I do not know how well 3DC bakes to the paint room flip faces as it is temporary in memory, not a permanent flip. Your quess is good as mine.

A Workflow solution: No flipping required but a little more work.

Create the sculpt sphere.

Use cut and clone tool to cut half away of the sphere. Rotate the cut and clone object 180 degrees, Transform/ move to the inside of the top half of the sphere.

Slightly scale down the cut and clone object.

Hold down the Ctrl key and press the Enter Key to cut away the inside of the top half using the cut and clone object. Leave some thickness on the top sphere.

Run Autopo on the entire half sphere. 

Delete the outer polygons as they are not needed.  Do this first before deleting. Under the View menu select backface culling so you do not select any interior polygons.

Look at my scan settings. You have to manually put in the minus sign baked scan settings In the Show Outer Shell as this is now a one sided interior retopo mesh. 

Bake to the paint room

 Under the View Menu in the Paint room now de-select Backface culling. easier to view on the eyes the interior of sphere. The paint on the outside is not really there it just appears to be as back face culling has been de-selected.

First picture shows the interior of the baked half sphere. The outside appears as backface culling is off so it is easier to look at. 

Second picture is my bake scan settings. 

Last image is the exported texture map. I just used this unwrapping for testing, You can choose your own.

I am not saying use the solution, but it is an option. 

 

dome.jpg

retopo.jpg

final4.png

Thanks for this.  I learned a little more features because of it.  Will have to try it after I get home.

 

If I somehow come up with some other method, I'll  post it here later on.  

 

Link to comment
Share on other sites

  • 0
  • Member

So....All this time.... all I had to do....was check.... Invert Normals... in the "Import Object for Per Pixel Painting" window...

 

That makes alot of sense XD.

 

Thanks guys!  could not have found this out without ya.

Edited by Klaptrap85
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...