Jump to content
3DCoat Forums

[Solved] Normalmap error importing to blender


Go to solution Solved by Sui,

Recommended Posts

  • Advanced Member

I need to change this to a more urgent topic because it actually prevents me from further work with texturing in Blender. I Autopoed  some objects, auto-unwrapped their UVs and exported them along with baked normal maps to Blender and Substance Painter. All parameters and presets were set to Blender or OpenGL. However strangely, after applying the correspondent Normalmaps the objects appeared to have a lot of artifacts and seams in Blender than in SP. Details were also less clear than in SP. This stopped me from any further works in Blender.

For your information, if I set the bake and export settings to Substance Painter instead, it also renders incorrectly in SP.image.thumb.png.32efc823c7b532927a1474e840fe4651.pngimage.thumb.png.5d687b3ccafa7925831ade42a7cee549.png

Link to comment
Share on other sites

  • Advanced Member

No. Otherwise it would have show up in SP. Besides this is not the first time this isuss has happened. I worked in SP before but need to transfer to Blender this time.

If I set export preset to Blender, it works well in SP(other options dont). I've tried other export options, but it seems the normalmaps just dont work in Blender.

Link to comment
Share on other sites

  • Advanced Member

I am not sure you mean the usual bake process before any maps can be exported in SP or editing the maps from Coat, so I'll give answers for both. 

If I import to SP a model from Coat or Blender and bake maps in SP, they will be fine. I'll only need to flip the normal maps due to issue with SP's export settings.

 

If I import the model and maps from Coat, they will also be fine in SP, but not in Blender. (If I then edit and export the maps from SP, they have a possibility to be right in Blender. I'll show the result in the following images.) But for this case, they DONT look well even after I edit and export from SP. 

Those shots show, in Blender, the same model I sculpted, autopoed and baked in Coat before, exactly the same process like this time. The first one is the normalmaps directly from 3dcoat; the second the normalmaps from 3dcoat after editing in SP; the third is the second one with other textures on. 

You can notice that in Blender every normalmap from Coat shows incorrectly. They show right in SP(the flaw is hardly noticed). They MAY show right after SP. I dont know why they do not work out this time.

image.png.415da71b4eb5c34e8e99381195286e7a.pngimage.png.a1608ec57b51700218e9b21e8b831678.pngimage.png.8142488d2ad5f2a54b47d143de1ffe9f.png

Link to comment
Share on other sites

  • Advanced Member

The 3B file is way too large to upload because I am using VPN. The file I share contains both normal maps from SP and Coat.

As for the steps, I used Instant Mesh to do autopo to decease the poly count to around one fortieth. Then I auto unwrapped the UV sets, auto mapping and auto check for overlaps. I then baked and exported the low meshes and normal maps from Paint Room, with all presets set to Blender Cycles.

The meshes and maps were then imported to SP. I baked maps in SP except for the normalmaps.

Link to comment
Share on other sites

Try triangulating the model BEFORE baking.

And use this preset (experimental) for the export step (preset location is C:\Users\<username>\Documents\3DCoat\data\ToolsPresets\ExtTools)
Blender & SPainter.xml

Should you triangulate meshes before exporting to substance?
Yes. Different 3d engines will triangulate quads in different order, and with different rules about which way it splits them (ie. which two corners to use).

This can result is slightly different lighting as the normals will interpolate in different ways.
It can also affect the way textures are applies on trapezoids and other quads as shown here- although that can be a problem anyway as the texture will be strangely mapped.

It's not a major problem normally, although I have had issues with a few props looking very funky, but there's no downside to triangulating things before the texturing so why not do it ?

Link to comment
Share on other sites

  • 2 weeks later...
  • Advanced Member
  • Solution

Sweet God above, I finally found the reason. Blender turned all my maps to SRGB instead of Non-Color after upgrade, and that caused normal maps appearing strange. After switching back the setting they render well as should be. Thx.

  • Like 1
Link to comment
Share on other sites

  • Carlosan changed the title to [Solved] Normalmap error importing to blender

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...