Jump to content
3DCoat Forums

[Bug] Exporting Textures with correct Alpha


Recommended Posts

  • Member

Hello, I want to Export Albedo textures through Export/ColorAlbedoMap Without Padding. (Edit-Preferences-Padding->Never)

I want to export textures with full transparent Alpha background in the blank space without UV information, Instead everytime I export the color Albedo textures, they are exported with a somewhat gray alpha value in those blank spaces, not being fully transparent. I tried .png .tga and .tiff and it's the same result.

How can I export a clean texture with 100% opacity in the unused sections?

Thanks!

Texture1.png

PNGProof1.png

PNGProof2.png

TGAProof1.png

TGAProof2.png

Link to comment
Share on other sites

Hi

Hide Layer0 to save transparency

If you erase the paint, things still bake just fine. However, the transparent areas created will be baked as alpha/trans.

Also, if you hide Layer 0, it bakes fine and entirely with alpha/trans, whereas any other layer doesn't contain color data.

*Layer0: avoid painting it for any purpose but transparency.

 

Link to comment
Share on other sites

  • Member

I'm using the latest build 2024.20 I downgradde to 2024.17

And the problem persists.

Also yeahit's hidden but your export is correct, your alpha is black and white, mine is grey and white.

(Also why your channel is named "Alpha" and mine is named "Alpha 1"?)

Thanks!
 

Alphacorrect.png

Export 2024_17.png

Export 2024_17_2.png

Link to comment
Share on other sites

  • Member
Posted (edited)

It's just a cube with Uvs, it happens with all the projects I work on 3DCoat

Maybe I need to chek something on preferences? it seems weird because I don't even know why that gray value is showing in the alpha, don't know where is coming from, could it be residue from the padding?

Edit: I mainly work on 3Dcoat for Unlit Handpainted Textures, just want the albedo texture, I don't need Roughness, Depth etc.

Cube.3b

Edited by DiJa
clarification
Link to comment
Share on other sites

  • Member
Posted (edited)

Hello Carlosan, Uninstalled and Reinstalled 3DCoat, reset all settings, hotkeys, windows, prefs

Problem persist.

I haven't changed anything from the original install, just some hotkeys and screen position, background color to 50% gray, I just use the perpixel painting ulitlity as I stated I just use 3Dcoat for handpaint.

I see you get the export as it should be.

The only workaround I found is using Sync Layer with external editor, and I save it with Photoshop instead of exporting with 3DCoat, which is ok but it slows the process and requires me to have PS.

 

My settings if it helps:

I'm using a cintiq 21 UX 2nd Gen and a Wacom Intuos Pro

64GB

Intel i7-9700K @3.7GHz 12 cores 

Nvidia RTX 3070

workaround.png

Edited by DiJa
Link to comment
Share on other sites

Found it, thanks for point it up

Edit-Preferences-Padding->Never

It add extra level of gray to the alpha

*you can add Gimp as external 2d app on Preferences

Link to comment
Share on other sites

  • Carlosan changed the title to [Bug] Exporting Textures with correct Alpha

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...