Jump to content
3DCoat Forums

Blender Applink


haikalle
 Share

Recommended Posts

  • Advanced Member
5 hours ago, Carlosan said:

Gob addon was moved to upper middle viewport.  What do you think about to move yours to that location ? (without overlapping both, of course)

io.jpg

What is the Gob addonon? Is it a replaceent or update of the Blender Addon?

Link to comment
Share on other sites

  • Advanced Member

I rather have the applink where it is now.

On most projects I won't be using the add-on during all stages of the process, and sometimes it won't be used at all. Having a button visible at all times I think it clutters the interface and adds some substantial visual noise. On the other side, opening the tab to the occasional (albeit frequent) transmission of assets between both programs isn't that clunky. I hardly see any organised work needing a frantic constant exchange, even while rapid changes in the process requires frequent back and forth. We work and polish using both programs, but the bulk of the work isn't in the exchange, but inside applications. Maybe other workflows could benefit from the suggested placement above. I couldn't tell.

What about making it optional? Would that be feasible?

Link to comment
Share on other sites

  • Advanced Member

I prefer the Blender applink on the Blender N panel as well.

Link to comment
Share on other sites

  • 2 weeks later...
  • Member

Is there anything update on this?

Please let me know if it reproduces or does not.

 

On 4/27/2020 at 11:27 PM, roentgen said:

thanks @haikalle

I attach the file.

`__staffB` is an object was created by AppLink. UV-sets of this are consolidated to one, and can see/edit on 3d-coat.

'staffB' is an original of '__staffB', has UV-sets can not see/edit on 3d-coat.

 

 

staff_b.blend

Link to comment
Share on other sites

  • Member

I decided to give this applink another try with newest addon zip (what I found from this threat) and I can get models to 3DCoat but not back there (there is not any message / Blender doesn't response anyhow). 

I also noticed that there is many tutorials that doesn't count anymore with applink (buttons have been taken off ect.)? Is there still coming updates to this applink and when we get updated tutorial? 

Link to comment
Share on other sites

  • Applink Developer

@platyros Do you have latest 3d-coat version? There has been some issues with applink lately. Micro-verts are not working at the moment and also there is some scaling issue. 

But Per-Pixel mode should work OK. I think that I need some extra work with applink before updating tutorials.

Right now applink is in very unstable state...sorry about it.

Edited by haikalle
Link to comment
Share on other sites

  • Applink Developer

One reason why it's unstable state is that I made a big changes for the code. The code started to become harder and harder to read so I need to rearrange code better. 

This task is not finished yet. My time is limited at the moment so progress is slow but I will let you know here when it's good time to test applink again.

Edited by haikalle
  • Thanks 1
Link to comment
Share on other sites

  • Carlosan changed the title to Blender 2.83 Applink
  • 5 weeks later...
  • Advanced Member

The applink work for me to send objects from blender to coat but not from 3dcoat to blender. I use the latest blender build and latest 3dcoat stable build.  4.9.49 .

I setup my exchange folder and exported inside it my fbx file from coat but blender does not update nor making the shader links with textures.

I also use the 3dc  preset with blender applink.

Anyone know why this is happening?

Link to comment
Share on other sites

  • Reputable Contributor
On 7/5/2020 at 7:50 AM, micro26 said:

The applink work for me to send objects from blender to coat but not from 3dcoat to blender. I use the latest blender build and latest 3dcoat stable build.  4.9.49 .

I setup my exchange folder and exported inside it my fbx file from coat but blender does not update nor making the shader links with textures.

I also use the 3dc  preset with blender applink.

Anyone know why this is happening?

You might try this trick to get it working. I noticed on a few occasions that it helped.:

1) Go to your MYDOCS/APPLINKS/3DCOAT/EXCHANGE folder and delete or move to a separate location, the BLENDER folder. 

For some strange reason, the contents of that folder mess up the Applink once in a while.

2) Test a simple export of the default Cube in Blender, to 3DCoat and back

Link to comment
Share on other sites

  • Reputable Contributor
12 hours ago, haikalle said:

ok. let's make blender applink great again. here is update. but it's early beta. Please report bugs reports only now. Know issue:

-Scaling issue when using voxels

-Microverts mode dosen't work

coat3d.zip

Funny choice of words. :D

Thanks for the assist. :good:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...