Jump to content
3D Coat Forums
vfxdomain

modo AppLink

Recommended Posts

Here is the updated video for the new Modo Applink. It's definitely one of the better Applinks, now. Thanks again, Robert, for your help on this.

 

  • Like 2

Share this post


Link to post
Share on other sites

The normals sent over from 3dcoat are off in modo. I've tried messing around with different normal map export options but can't seem to get it right?

Share this post


Link to post
Share on other sites
@AbnRanger
Thank you for creating a new video about the Modo Applink! Your tutorials are done so thoroughly and illustrative!
 
 
@mues
2 hours ago, mues said:

The normals sent over from 3dcoat are off in modo. I've tried messing around with different normal map export options but can't seem to get it right?

Thanks for the feedback! I’d like to reproduce the issue you are experiencing to see what could possibly be done to fix it.

How/When does it occur in a way that I can best see the difference between both programs after transfer? (preferably with steps to reproduce)
 
Btw. I did notice that jagged artifacts in textures render out more explicit in Modo than in 3D-Coat, but these were cases with artifacts caused by painting on (jagged) uv seams.

Share this post


Link to post
Share on other sites
3 hours ago, mues said:

The normals sent over from 3dcoat are off in modo. I've tried messing around with different normal map export options but can't seem to get it right?

I find that if I invert the green in the normal map, with Modo's render, it works properly, but Vray doesn't work with RT GPU for some reason.

Share this post


Link to post
Share on other sites

Hey, thanks for replying :)

I basically; sculpted in 3dcoat - did an autotopo - baked sculpt onto retopo with auto uv. Then used the 'send to modo'. Normals are off, (can see the seams), I tried to invert the green, still weird. 

image.thumb.png.97f3c201ea22a286b62c7070cebd39c9.png

Note- it does work to export the normal map separately from 3dcoat and bring that into modo. But it would be nice if the link one worked for me :)

I had fiddled a bit with the normal map settings, which didn't seem to work. (same problem with the default and tweaked normal prefs)

image.thumb.png.865a6a492c7768a239c96a8c83ce2ba8.png

Share this post


Link to post
Share on other sites

Okay I see and here are a few hints:

Green channel (some background information)
Just read that Modo by default interprets normal maps in the OpenGL way instead of the DirectX way and these two interpret the green channel contrary (because the y axis in UV space is inverted).
So inverting the green channel in Modo is one option - thanks for the hint!
The other option is to invert the green channel when exporting from within 3D-Coat. This can be done by setting the "Normal Maps Export" in the Preferences to "Maya, Blender".

So "Maya, Blender" corresponds to the "OpenGL" way normal map
and "3DS-Max, LW" seems to be like a "DirectX" normal map

By the way I have to agree with Gary (https://3dcoat.com/forum/index.php?/topic/20056-why-so-many-normal-map-options/ ) stating that the option to invert the green channel in 3D-Coat might be more accessible with a separate checkbox (or by naming the dropdown options like "OpenGL" and "DirectX") instead of binding the preference to Software names. The software specific stuff should only be saved in within the chosen options of the "Normal Map Sofware Presets".

Padding
Unchecking "Denormalized TB" seems to create a padding once, which had a positive effect here (though does not completely solve the issue).
Also make sure "Create Padding" is checked in the export dialog.

UV Map
I believe the issue is partly caused by the jagged UV map 3D-Coat's auto unwrapper is creating. On your model the critical areas probably are placed on that kind of UV seams, too.
Modo seems to be pretty merciless rendering jagged UVs, but I’d be interested to know if this is just a question of correct settings on the mesh or texture maps. 
Currently I didn’t get better results by manually exporting/importing the normal map. Let me know if there’s anything particular to take into consideration.

I do notice though that the critical areas are already visible in 3D-Coat (at least in my test case), but harder to see.
So ultimately a nice UV map might solve this, but more tips and hints on a smoother normal map exchange are very welcome! 
 

Edited by Robert N

Share this post


Link to post
Share on other sites
48 minutes ago, Robert N said:

Okay I see and here are a few hints:

Green channel (some background information)
Just read that Modo by default interprets normal maps in the OpenGL way instead of the DirectX way and these two interpret the green channel contrary (because the y axis in UV space is inverted).
So inverting the green channel in Modo is one option - thanks for the hint!
The other option is to invert the green channel when exporting from within 3D-Coat. This can be done by setting the "Normal Maps Export" in the Preferences to "Maya, Blender".

So "Maya, Blender" corresponds to the "OpenGL" way normal map
and "3DS-Max, LW" seems to be like a "DirectX" normal map

By the way I have to agree with Gary (https://3dcoat.com/forum/index.php?/topic/20056-why-so-many-normal-map-options/ ) stating that the option to invert the green channel in 3D-Coat might be more accessible with a separate checkbox (or by naming the dropdown options like "OpenGL" and "DirectX") instead of binding the preference to Software names. The software specific stuff should only be saved in within the chosen options of the "Normal Map Sofware Presets".

Padding
Unchecking "Denormalized TB" seems to create a padding once, which had a positive effect here (though does not completely solve the issue).
Also make sure "Create Padding" is checked in the export dialog.

UV Map
I believe the issue is partly caused by the jagged UV map 3D-Coat's auto unwrapper is creating. On your model the critical areas probably are placed on that kind of UV seams, too.
Modo seems to be pretty merciless rendering jagged UVs, but I’d be interested to know if this is just a question of correct settings on the mesh or texture maps. 
Currently I didn’t get better results by manually exporting/importing the normal map. Let me know if there’s anything particular to take into consideration.

I do notice though that the critical areas are already visible in 3D-Coat (at least in my test case), but harder to see.
So ultimately a nice UV map might solve this, but more tips and hints on a smoother normal map exchange are very welcome! 
 

Thanks for the added info. Could you append the Applink Manual by pasting this information into it?

Share this post


Link to post
Share on other sites
1 hour ago, AbnRanger said:

Thanks for the added info. Could you append the Applink Manual by pasting this information into it?

Definitely, I'll summarize it for the Manual!

  • Like 1

Share this post


Link to post
Share on other sites

Oh, It was actually pretty simple..

The maps from 3dcoat needed to have the colorspace changed + invert green. exporting manually and dragging in gave me a prompt to adjust color correction (which i had forgotten about before). 

BTW thanks for this great applink!

Share this post


Link to post
Share on other sites
1 hour ago, mues said:

Oh, It was actually pretty simple..

The maps from 3dcoat needed to have the colorspace changed + invert green. exporting manually and dragging in gave me a prompt to adjust color correction (which i had forgotten about before). 

BTW thanks for this great applink!

Can't you switch how Modo interprets the green?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×