Jump to content
3DCoat Forums
Sign in to follow this  
moska

.obj from Silo into PPP

Recommended Posts

1.tiff2.tiff3.tiff

Hi

i post this here because its probably just a Silo problem, but may be someone here with more experience could advise me.

in picture 1 you can see a normal .obj loaded in 3dcoat for PPP

but if that .obj comes from Silo 2.2 mac build, i notice the strange shading you can see in pictures 2 and 3.

i hope any of you could see whats going on,cause silo could be a great tool for creation but as im using it ive noticing this strange shading in .objs, wich persists if i export it back from 3dcoat.

maybe someone knows whats about, cause for me its just :(

Share this post


Link to post
Share on other sites

Hi. It would be easier to find what's going on if we had access to the obj. First thing that comes to my mind when i see strange shading is bad normals orientation. I wish there was a way to visualize and change them in DCoat retopo room.

EDIT : BTW you should post images as .jpg, tiff images don't show in my browser so i had to download them.

Share this post


Link to post
Share on other sites

Yep. Normals are pointing inward wich means what you see from outside is the back of the faces. I'm not sure 3DCoat can paint on those back faces and some rendering applications can't use them anyway. I reversed them to test and the outside can be worked, but of course the back faces are now towards the inside and you won't be able to paint inside.

If you just plan to use the inside, just don't worry of the black outside. If however you want to use both you really want to give some thickness to your walls so you have faces pointing inside in the inside, faces pointing outside on the outside and back faces in the thickness of the wall.

Share this post


Link to post
Share on other sites

thankx Bob

but sorry if i didnt explain earlier that this is an interior ,the exterior wil be another mesh,so normals are fine to me .no point painting both sides anyway.

its for unity3d.i even split this mesh into smaller pieces to switch on and off and be able to paint inside easier.so the black faces outside look good to me,they are reversed.the point is the shading on it (clear gradients)and the shading on the inside(instead of regular grey,gradients of dark)

this is visible in the first pictures i posted,1 and 2 are diferent cause you can see that slight shading in 2.

in 3 theres also that shading i mean but you can see that wall wich is black cause its reversed to the camera,but the shading is visible by the gradient on the surfaces:dark on facing thecamera,clear grey in the ones back to the camera.

hope you understand.

by loading the mesh in PPP you can see this easier too.

anyway heres another pic

thanks again

i think this is hapening with silo meshes only

but can have to do on how 3dcoat presents meshes too

i dont know about it but theres some diferent shadings metods writen on the obj file and the softwares,things like phong ,flat constraint ,who knows?

post-2406-1298064199432_thumb.jpg

Share this post


Link to post
Share on other sites

Wrong normals, lot of non manifolds. Impossible to work on this. Its not a silos fault. You probably need walls with some thickness. Except this what I'm posting works for your needs. Some cleaning with blender. But it wont work either.

Share this post


Link to post
Share on other sites

thankx for your time Mik

sorry for desagree.the normals are fine cause they are for the faces on the interior rooms.

i have a separate mech for the house exterior,roof ,etc.

theres no manifolds also,cause those faces are not conected to each other.

so you have been inverting normals ,right?thats not what i need here.

any one could just save any obj in silo and see these strange shading in 3dcoat,compared with obj from other aplications at least in mac,where i am.

thanks for trying ;)

Share this post


Link to post
Share on other sites

So, if interior matters, where is the problem with shading? I missed something, but i really don't see a problem.

As for the 3dc renderer, have in mind that a single sided surface wont cast shadows there. It doesn't work like this.

Blender still shows non manifolds. And its right.

One sided meshes have to be 'waterproof' to be 3dc friendly. Blender has double sided shading 'on' by default. Uncheck it and similar results to 3dc then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×