Jump to content
3DCoat Forums


Reputable Contributor
  • Posts

  • Joined

  • Last visited

Community Answers

  1. Fluffy's post in [Solved] Something's off with the Extruder brush was marked as the answer   
    It seems like using the Stamp tool at really large sizes on a curved surface can lead to protruding edges if the projected edge of the brush alpha falls too far from the surface you're applying it to.  In order to avoid disconnected/protruding edges try swapping the Pick Trajectory setting to Pick Average Vertex Position and setting the Position Sampling value to 200%.

  2. Fluffy's post in PBR roughness metal workflow was marked as the answer   
    At first glance it seems like it should be inverted, but if you pop the Layers window out from its docked position and increase the width of the window you can see the full title of that setting isn't Roughness...

    ...it's actually Roughness Opacity and in that context it works exactly as you would expect it to, i.e. it controls the opacity of the roughness channel of the layer rather than the roughness value itself.
  3. Fluffy's post in [Solved] decals was marked as the answer   
    The reason your decals/brushes look faded is because when you import a texture to 3D Coat as a brush if the texture has no alpha channel 3D Coat will try to generate one based on the combined luminance of the existing red, green and blue channels (which it will then also uses for the depth map, etc).
    This means that if you import a colour texture rather than a black and white image, the alpha channel that's generated will vary in opacity based on the brightness of the image which is why the red pixels in your texture are showing up as semi-transparent (because they aren't white).  If you hover your mouse over a brush you can see each of the channels/maps that are associated with that brush, here's an example brush I just made (using 8-bits per channel, 24-bit .BMP file format)...

    and here's the same brush but with an alpha channel added to the texture (also 8-bits per channel but using 32-bit .TGA file format)...

    As you can see the Alpha of the brush created using the texture without an alpha channel is grey rather than white, so whenever you use it the results will appear faded whereas the brush created using a texture with an alpha channel appears completely opaque when used...

    So, in order to create opaque 3D Coat brushes using colour textures you have to include an alpha channel.
    As for creating alpha channels in Corel Painter I only have a license for Painter 2018 but assuming they haven't made any dramatic changes you can save to PNG complete with alpha channel by simply hiding your canvas layer so you have a transparent background...

    then choosing Save As from the file menu, selecting the .PNG file format from the drop down menu and making sure you enable the Save Alpha checkbox...

    after which you can import the texture as a brush in 3D Coat and the transparency of the layer you exported should appear as the alpha channel of the new brush...

  4. Fluffy's post in [Solved] How do i make the Grid Bigger "For more Points" was marked as the answer   
    The default grid (with Grid Density set to High) equates to the following settings using Customize Grid

    Grid Step is the size in units of each grid division, while Division Number is the number of Divisions in each quadrant of the grid.  So if you want to effectively extend the default high density grid while keeping the same unit size and subdivisions just use the above settings but increase the Division Number accordingly.
  5. Fluffy's post in [Solved] polygons missing in 3Dcoat per pixel import from blender obj/fbx was marked as the answer   
    It's hard to tell from just those two images but your missing polygon problem could just be down to single-sided polygons.  The easiest way to check if that's the case is to try turning off Backface Culling in the View menu.

    As for the issue with brush strokes, etc. appearing in multiple random places one possible explanation is overlapping UV islands which you should be able to see if you turn on the Wireframe option in the Texture Editor window.

    If you're unsure if the model has been unwrapped correctly in Blender you could always unwrap it again in 3D Coat to see if that fixes the issue.  You can either adjust the UVs on the paint model directly in the UV room or use the Take mesh from Paint room option in the Mesh menu of the Retopo room to import the model there

    and the Update Paint Mesh with Retopo Mesh option in the Bake menu to apply the changes to the model in the Paint room when you're done UV unwrapping.

    (Using the UV room works best if your model already has textures applied since changes to the UVs there also affect the textures whereas if you make the changes in the Retopo room and then update the model in the Paint room only the UVs will be affected)
  • Create New...