Jump to content
3DCoat Forums

Fluffy

Reputable Contributor
  • Posts

    73
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Fluffy's Achievements

  1. Yes, using the Loft tool and the same process I outlined in this post... To recap, just select the edge you want to loft and choose Create from selected edges from the Curves menu then select the newly created curve and your original curve and activate the Loft Surface tool in the Add Geometry panel... ... then just set your V Spans, check your normals are pointing the right way and hit Apply Mesh.
  2. Okay, I followed the steps you took in that part of the video and I found that if you increase the layer resolution and then revert using the Undo option once then Delete Hidden doesn't have any effect and increasing the layer resolution will result in the voxels being unhidden just as you described. After a little more testing I noticed that there seems to be a few inconsistencies with using the Undo option in conjunction with Separate Hidden Volumes (for example, if you use the Undo feature directly after selecting Separate Hidden Volumes you'll find that it reverts the creation of the voxels but doesn't remove the newly created empty layer). With this in mind I went back and tested your exact process again and discovered that if, after increasing the resolution of the sculpt object, you hit Undo twice before selecting Delete Hidden the hidden voxels will be deleted and you can increase the layer resolution without the hidden/deleted voxels reappearing. It seems like the issue is also somehow related to using Undo to revert changes to the object resolution. The last thing I tried involved the following steps: Create a voxel object. Hide part of the object with VoxHide. Select Separate Hidden Volumes from Geometry menu to create new Sculpt Object. Select original voxel object and increase resolution (hidden volumes become visible). Revert changes with Undo. Select Delete Hidden from Geometry menu. Increase resolution of original voxel object ("deleted" volumes become visible). Select Undo option 3 times. Select Delete Hidden from Geometry menu. Increase resolution of original voxel object (volume created successfully). Result: It seems like you need to use the Undo option twice to fully revert the changes to layer resolution and, based on the number of times Undo was used in step 8, the issue "stacks" so that each time you only select Undo once in order to try a different approach it will require an additional Undo in order to revert to a point where Delete Hidden works correctly. In short, the best solution for now seems to be ensuring that you always select Delete Hidden from the Geometry menu before attempting to increase the layer resolution. ETA: An alternative solution is to duplicate the original Sculpt Object, increase the resolution of the newly created copy and just delete the original, since duplicating an object doesn't duplicate hidden voxels (Note: apparently this method is still affected by the same issue with Undo i.e. if you increase the layer resolution and then hit Undo once before duplicating the layer the hidden voxels will also be duplicated but if you hit Undo twice after increasing the resolution then duplicating the layer removes the hidden voxels as expected).
  3. Seeing the same behaviour in 3D Coat 2022.57, it also happens if you use the Unhide All option. VoxHide1.mp4 Tested this several times and I'm not seeing the same behaviour. After separating the hidden parts and selecting the original sculpt layer using Delete Hidden prior to Unhide All seems to fix the issue. VoxHide2.mp4 It appears that the Separate Hidden Parts option doesn't actually remove the hidden voxels when it creates the new objects and I don't believe hidden voxels persist between saving/reloading so this would probably be considered expected behaviour. It's either a bug or a misnamed feature since currently Separate Hidden Volumes seems to function as "Clone Hidden Volumes". ETA: Just noticed @Carlosans added comment concerning Separate Hidden Volumes copying rather than removing voxels, perhaps just changing the wording of the tooltip for the feature from "Creates a new Sculpt Object from hidden parts of volumes" to "Clones hidden parts of volumes to create a new Sculpt Object" would help to avoid confusion in future?
  4. !00% this! ^^^ @NLPLP Using Curves would be a much better solution, especially paired with the Coat tool (which can be accessed by right-clicking a curve and choosing Fill with Mesh Layer) which not only allows you to assign custom contours for your extruded edge... ... you can modify the shape at any time after creating it (until you intentionally detach the curve from the object)...
  5. This is just a hunch but are you rotating the camera by holding down the ALT key? One of the new features in 3D Coat is the ability to rotate splines by holding down the ALT key which automatically detaches the spline from the surface while the ALT key is pressed. Instead of using the ALT key to navigate try left-clicking and dragging in the border area of the viewport and see if the spline remains attached to the surface.
  6. It seems like using the Stamp tool at really large sizes on a curved surface can lead to protruding edges if the projected edge of the brush alpha falls too far from the surface you're applying it to. In order to avoid disconnected/protruding edges try swapping the Pick Trajectory setting to Pick Average Vertex Position and setting the Position Sampling value to 200%.
  7. Try working in select edges rather than select vertices and selecting just the edges that you want to rearrange into a circle (you won't see any preview as you would when aligning to a plane so you'll need to hit Apply to see the results). I just tried Faces, Vertices and Edges but could only get it to work with edges selected.
  8. Without knowing a bit more about the steps you're taking that cause this issue it's going to be difficult to reliably reproduce the results you're getting, however I've personally found that one of the most common causes of hidden polygroups getting deformed in a way similar to what you're describing occurs when a collection of connected polygons are split across multiple layers (especially when the Auto Snap or Conform Retopo Mesh options are enabled). Since selecting faces of an object and moving them to a different polygroup doesn't separate them from the remaining faces it can occasionally lead to those hidden but still connected faces being affected by operations performed on any other polygroup that contains polygons connected to the hidden faces/groups. In order to ensure that doesn't happen you can select the faces you wish to move to a new polygroup and choose the Separate option in the Selected section of the Tools panel which will, as the name suggests, separate the selected faces from the rest of the poly object before moving them to a new polygroup. If you need to merge the separated faces with the rest of the object again later you can simply select the necessary faces, move them back to their original layer and use the Weld Vertices tool (also located in the Selected section of the Tools panel) to merge the vertices along the edges.
  9. For me it's located in the Add Geometry panel in both rooms (but you should also be able to find the Smart Extrude tool in the Tools Palette in either room by pressing spacebar or opening it via the Windows>Panels menu). It may be that it's just not immediately visible in the left panel since some tools are grouped together differently in different rooms. In the Modeling room the Smart Extrude tool is grouped with the Spine Tool and InSet tools, while in the Retopo room it's grouped with the other extrusion tools (Free Extrude, Normal Extrude, Extrude Faces & Extrude Vertices)... If you don't see it displayed in the left panel then try looking for one of the other tools in the same group and hovering your mouse over it. If you still can't find it try right-clicking any of the tools in that section and selecting the Show All Tools in Section option just in case it's gotten hidden somehow.
  10. Try the Shell tool. First select the faces you want to "solidify" then activate the Shell tool... then use the buttons in the Tool Options window or the arrow gizmo to set the amount of extrusion... Which version are you using? I have 2022.57 and the Smart Extrude tool is available in both the Modeling and Retop rooms.
  11. That's good news. The current tools do take a little effort to work out but once you get the hang of them they're extremely useful. I'm a lot more familiar with using the Sculpt room to block things out first so I'm still getting to grips with some of the newer low poly modelling tools but so far I'm enjoying them a lot!
  12. I'm not that familiar with the Loft tool but I think I managed to figure out the process that Oleg is illustrating in the screenshot (it became a little clearer once I realised the selected edge shown was obscuring the third curve used in the loft operation). It's worth noting that the order in which the two profile curves appear in the Tool Options window can have an effect on the resulting mesh. The number of knots in the first curve in the list (in conjunction with the value set for U Spans) determines the number of polygons created and the order in which the curves appear determining the direction of the vertex normals on the resulting mesh. Additionally if the curve which defines the edge you intend to create appears first in the list then the result when you hit apply may not align correctly with your existing mesh (without going into too much detail it seems to have something to do with how vertex normals effect the way in which 3D Coat generates the lofted surface). Adding the Cross Section curve created in Step 3 appears to solve the issue regardless of the order the Profile curves are listed in however it can sometimes flip the vertex normals of the resulting mesh so it's a good idea to enable the Draw Normal option and then you can toggle the Reverse Normal setting if needed. As I said I'm not that familiar with the Loft tool but this seems like a fairly reliable way to retrieve the desired result, however I personally prefer the Smart Retopo tool which can achieve very similar results using less curves. All you need to do is create a curve for the edge you wish to generate and then activate the Smart Retopo tool, set the Mode to Quadrangulation, press the Add Profile button and select the curve and then set the required number of U Spans. You may need to quickly tweak the position of each end of the curve to make sure it snaps to the correct vertices on the existing mesh but once both ends are correctly positioned you should see something like this... (at first you should only see the green border, but if you hit the Apply button it will preview the results and hitting the Apply button a second time will generate the mesh). As you can see the Smart Retopo tool is capable of filling irregular shapes which could potentially be problematic and/or time consuming using the Loft tool, but I'd still recommend learning how to use both. As with most things in 3D Coat there are multiple ways to achieve the same results and which method works best very much depends on your personal preference and overall workflow, hopefully the above information will help you figure out which approach works best for you.
  13. In addition to what @Carlosanposted above which works with Use Current Alpha enabled, you can also use the Presets panel to store the current settings for a specific tool (including any alpha shape you create using the Edit brush shape window). Just right click in the Presets window and choose Add Preset. You can choose which particular settings are stored by enabling or disabling them via the What to Store? menu If you want to make any alterations to the preset after you've created it you can right-click it and choose Update Preset (you can also rename the preset, add your own description for the mouseover popup window and add the preset to one of the numbered slots in the Quick Panel via the same menu).
  14. Without more of an idea of which brushes you're using and the type of result you're trying to achieve it's a little hard to know where to start (how to use brushes/alphas in 3D Coat is a pretty broad subject and would probably take a while to get through). Tools like Grow in the Voxel Tools panel incorporate smoothing automatically and will give you very smooth, organic results without any need to tweak the settings, but if you're working with the tools in the Clay Engine panel here's a couple of settings that may help... Using the Base Clay tool as an example, if you look at the Tool Options you'll see a checkbox for Use Current Alpha and next to it a gear icon. While the Use Current Alpha option is disabled you can use the gear icon to access the Edit Brush Shape options window where you can modify the brush shape for the current tool. Alternatively with the Use Current Alpha option enabled you can select any brush/alpha from the Brushes panel and additionally you can further vary the edge blending by changing the Falloff value. Here's a screenshot with the various settings and the resulting brush strokes...
  15. At first glance it seems like it should be inverted, but if you pop the Layers window out from its docked position and increase the width of the window you can see the full title of that setting isn't Roughness... ...it's actually Roughness Opacity and in that context it works exactly as you would expect it to, i.e. it controls the opacity of the roughness channel of the layer rather than the roughness value itself.
×
×
  • Create New...