Jump to content
3DCoat Forums
ghib

[Solved] Smart Materials - Layer with no Color? (V4.5.02)

Recommended Posts

Hello all, loving 3DCoat's new Smart (PBR) Materials but we have stumbled across a scenario where we needed to make a new Layer that would change the Depth, Roughness, Metalness only but not add any Colour.   Is this possible.

 

If not I think we'll need to add a suggestion to include an opacity slider (parameter) to the colour slot.

 

thanks.

Share this post


Link to post
Share on other sites

I have seen a couple of tutorials about the new PBR material system in 3d coat. I think the one I saw was done by Javis Jones.    I created a stone wall texture, which I was pleased with (for a first go at it).   I would like to learn more about using PBR.

Share this post


Link to post
Share on other sites

ajz3d, thank you so much for this response.  Yes this is what we were looking for (maybe got confused that there wasn't an actual slider like there is for Depth)  In fact maybe having a percentage slider would be a useful thing per layer parameter so you can adjust how much the colour will be affected.

 

anyway this solves our problem so thanks again.

Share this post


Link to post
Share on other sites

Ok we have just tried this on multiple versions (mine being V4.5.02)

 

Unchecking these boxes does not actually switch them off but merely hides them from the user.  Any idea why you would want to do this?  It makes more sense that if you turn them off you don't not want these parameters to affect the layer.

Share this post


Link to post
Share on other sites

Yeah, I just noticed this too. I think those checkboxes were supposed to turn off those channels, but for some reason they don't. I think it's worth reporting as a bug. Unless of course current behaviour is intentional, but it wouldn't make any sense.

Share this post


Link to post
Share on other sites

haha, no that's perfect, and thanks for reporting the bug.  This will make the Smart Materials more powerful I think.  Also having sliders for each individual channel would be preferable as an addendum to this bug report.  This way you can have a modifier for each channel to fine tune.

Share this post


Link to post
Share on other sites

I might have some good news. This thing was really getting on my nerves, so I gave it another try and I may have found a workaround.

Here's an 8px2 texture: transparent_8px.zip. It's a TIFF with an alpha channel (I had to throw it into a ZIP file, because this forum's software doesn't allow for uploading TIFFs for some reason). Try feeding this texture to those channels, that you want to eliminate in a given Smart Material layer. Blending mode shouldn't matter, but just to be on the safe side keep those channels in Replace mode.

Let me know if it worked for you. I only gave it a few minutes of testing, but it seems to have solved the problem.

 

  • Like 1

Share this post


Link to post
Share on other sites

Brilliant, that worked a treat :)

 

It's a bit of a hack until Andrew gets round to this but works perfectly.

 

//admin edit

Andrew    (administrator)
2015-07-06 04:44
    fixed in 4.5.05

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×