Jump to content
3DCoat Forums
Sign in to follow this  
wolfiboy

[Solved] Correcting visible seams

Recommended Posts

Hi!

I'm working with 3D-Coat 4.8.15 and when I'm applying a smart material in UV-projection I get some unwanted seams in the texture. I tried to delete the seams in the UV-section and build new ones, but with the same result. This does not happen when I change the material to e.g. cube mapping, but then it is not applied correctly. For the material I used a tiled texture from textures.com and I don't think it's a problem on the texture-side.
What I noticed: When I look on the UV-Map in the UV-section you can see, that near the problematic seams the color changes to blue on the UV-Preview. Does this has something to do with the problem?

Thanks for your help.

3DCoat_Seams.JPG

3DCoat_Seams_UV.JPG

Share this post


Link to post
Share on other sites

Can you share the file and the smart material? I just find it easier to test normal map problems by having the file if possible. Pm with a link if you want the file to stay private.

Export the smart material as an 3DC extension. Make sure the Smart Material is selected then right click on the on the Smart Material. Select "share item. 

Send the original image as well. I have an Textures.com account, so I do not think there would a problem in sharing the file or give me a link to it... 

-------------------------------------------------------------------------

 Curious since you are using UV projection, why not have the curved wall one uv island if possible. Maybe lose a little uv space but avoids some uv-projection problems. I still want to look at your file and figure out the problem though.

Share this post


Link to post
Share on other sites

I will add some things. 

Though a  tileable image in uv projection mode you lose the tileable effect when splitting the curve wall as you have done. The pattern will not match at the seams. Some textures are more obvious and others are not so.

Also I do not know the scale of your model but the lock depth is really deep. That is intensifying the normal map to large extent.  Yes you have knocked it back some using 10% depth in the depth channel of the smart material.  

Do you have "show displace mesh" under the View Menu selected. If can cause seam issues if the normal map depth is pushed too far.

 

 

Share this post


Link to post
Share on other sites

Hello digman and thank you!

Well, I think I don't need to attach my object because I made a test with a simple box and I get the same result (see attachment): First I used Auto-Mapping and then I changed the UV a little bit to have some seams on one area. Back in the paint-room I selcted the first wood-material. I opened the smart material editor and changed the mapping to UV. To be sure it's not a normal-map error I disabled depth and only enabled color. Now when I put the material preview over the seam or when I paint over it the same effect happens.
When I use cubic-mapping it's okay (see second attachment).

Does this mean UV-Mapping is not possible? Or what did I wrong?

Or maybe I have a wrong understanding of UV-mapping?
For example I would need this kind of mapping to draw a wall-structure over an opening in a wall like a window or a niche. When I use the other mappings like cube or spherical I will get some distortion in the texture.

But anyhow, I will send you the modell of the arch and the material by a PM for forther analyses.

Thank you!

3dc_Seams_Box.JPG

3dc_Seams_Box_ok.JPG

Share this post


Link to post
Share on other sites

Hi

Please check your preferences.

Are you using RT Padding > Take interpolated color as default ?

TakeInterpolated.jpg

Share this post


Link to post
Share on other sites

It is more of a miss-understanding of UV Projecttion in what you are doing in the case of your building. I am keeping it simple here with not all parameters discussed. 

The image is seamless, tileable but not at the edges of the UV islands because the vertices of the object have specific coordinates in the UV set between "0" and "1'. Also is their U (X) and V (Y),  the winding order plus rotations.

You can scale the image up or decrease it and the uv islands will never have a seam on the inside of the islands because the image is tileable.

Cube mapping or triplanar mapping really does even need a UV set. Uses a different set of coordinates than the coordinates of the uv space.

In your case of the building when using cube mapping you have some stretching of the texture in parts due to having some normals tension and lack of of a few extra edges to soften the normals. 

Correct those and you could use cube mapping.

In the first picture, I redid the uv seams in a better layout for UV projection. I had a few seams to fix where I could not avoid putting a seam that would show. These can be painted out using a little hand painted cube mapping over them.

The second picture is a not a screenshot but I just put it together to help understand what I said in the information given. This uv island layout was to show why you have seams at the uv island edges because of the specific coordinates in the uv space. This is not the layout I used,  remember the picture is just for show, as I use screencaps and used a paint program to put together.

3rd picture shows cube mapping after adding some extra edges to soften the normals to remove the stretching in a few areas.

new23.JPG

Uv Projection.png

cube mapping.PNG

Share this post


Link to post
Share on other sites

Hi guys,

thank you for your help!

@Carlosan: Yes, the default is as you recommend.

@digman: I subdivided the model to get more polygones with about the same size. And yes, cube mapping works better now.

So the solution is: When you use cube mapping the model should not have to big differences in the size of the polygones, or the distribution should be more smooth. My model was construted on a boolean basis, so the distribution of polygon-sizes is not quite texturing-friendly.
And UV-mapping with smart materials is just as painting on the UV-map. Of course rotation and seams will occur.

My problem is solved, thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×