Jump to content
3D Coat Forums
wonderland78

The holes in the voxel mesh bug

Recommended Posts

For a while now, I'll dip my toes into 3d coat as it's a very powerful tool, but is without exaggeration, the most buggy piece of software I've ever used in my 20 years of using graphic software.

The biggest gripe I have is when holes appear in the voxel mesh at random. And it's not fixable, you just have to start from your last save point.

I'll try the software out every now and then to see if newer versions have fixed the bug but each time it's still there.

Does anyone know if this issue has been fully addressed and fixed in the most current versions?

Share this post


Link to post
Share on other sites

Do you mean holes inside voxel mesh?  Try right click on voxel layer and use "fill voids" and "close invisible hulls"

Capture.JPG

Share this post


Link to post
Share on other sites
14 hours ago, wonderland78 said:

For a while now, I'll dip my toes into 3d coat as it's a very powerful tool, but is without exaggeration, the most buggy piece of software I've ever used in my 20 years of using graphic software.

The biggest gripe I have is when holes appear in the voxel mesh at random. And it's not fixable, you just have to start from your last save point.

I'll try the software out every now and then to see if newer versions have fixed the bug but each time it's still there.

Does anyone know if this issue has been fully addressed and fixed in the most current versions?

Do you mean small surface indentations? I notice that, too, from time to time. That seems to be something rather recent, because it's only been in the past few months or so, that I've noticed it. In terms of bugs, it's kind of cyclical with me. I can go extended periods with it being relatively stable, and then suddenly have bugs, seemingly all the time. Some of it may have to do with the SL (sculpt layers) version. Try the non-SL versions and see if it happens. If you can get it to repeat, send Andrew a report (support@3dcoat.com). 

If you could see the bug fix list for most major 3D applications, then you would see a lot problems you were never aware even existed. In 3DCoat, it's usually because the problems are happening in areas you happen to be using. If Andrew doesn't know about it, he cannot fix it. 

Share this post


Link to post
Share on other sites

I just talked with Andrew about the small bumps or indents when importing into Voxel Mode. He said it only happens when the mesh is Open, and voxels do not like open meshes. They are volumetric and as such, need some kind of "container" to fill. So, a model needs to be closed and have some thickness. If you have an open mesh, import it into Surface mode....which doesn't care if there is thickness or not. But, later on, if you want to switch to voxel mode, you will see a dialog with an option to close holes, by default. He said he would add a "Close Holes" option for import dialog.

 

https://youtu.be/Dtzu0UvVKGw

  • Like 1

Share this post


Link to post
Share on other sites

Sorry for late reply, notifications went into junk.

I didn't see the fill voids option, I'll check that out, but I doubt that's it. It's not related to importing objects, it's just that I'll notice perfectly square holes missing and any attempt to manually fill them will just make more randomly appear. At that point the whole scene is just unusable and I have to revert.

Share this post


Link to post
Share on other sites

What version of 3DC are you using.  Are you in Voxel or Surface mode.

Which tool or brushes did you use or is it just random. 

If in Surface mode did you try any of these tools to fix the problem. Picture supplied. 

Can you upload a picture of the problem.

If you have a 3DC file that has the problem, share it if you can.

fixes.jpg

Share this post


Link to post
Share on other sites
6 hours ago, wonderland78 said:

Sorry for late reply, notifications went into junk.

I didn't see the fill voids option, I'll check that out, but I doubt that's it. It's not related to importing objects, it's just that I'll notice perfectly square holes missing and any attempt to manually fill them will just make more randomly appear. At that point the whole scene is just unusable and I have to revert.

Fill voids option is in voxel mode.  So your problem is in surface mode.

Share this post


Link to post
Share on other sites

When that happens, save the file (separately) and go to the HELP Menu, where there is a link for you to send it to support. When it completes, email (support@3DCoat.com) to let Andrew know you just sent it and the severity of it. Adding a screen grab/shot would be very helpful, plus what build and OS you are using and details to repeat.

That will help everybody. It's when users just get frustrated and don't report it, that a problem continues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×