Jump to content
3DCoat Forums
alan f

Retopo mesh/Reference mesh change color?

Recommended Posts

thanks stusutcliffe,

 

A co-worker helped me out with that one. The one I haven't figured out yet is changing the color for the reference mesh.

Share this post


Link to post
Share on other sites

To change the reference mesh color:

 

Step 1: Go to the Sculpt Room.

GoToSculptRoom.JPG

 

2. Pick a different shader with a color that you prefer.

PickADifferentShader.JPG

 

3. Or if none of the default shaders are ok, then you can create a new shader with any color you like. Simply right-click on any shader and choose "Construct New Shader".

RightClickAndChooseConstructNewShader.jp

 

4. Give the new shader a name.

GiveTheNewShaderAName.JPG

 

5. Change the colors to whatever you want.

ChangeSettings.JPG

 

6. Now you have a new shader in the Shader Panel.

NewShaderWasCreated.JPG

 

7. Apply the shader to your reference mesh and return to the Retopo Room.

GoBackToRetopoRoom.JPG

 

8. Just for clarification, all you really need to access is the Shader Panel (which is available from the Windows menu). The Sculpt Room has the Shader Panel open by default, so it is slightly easier to just go there for quick access (instead of opening the Shader Panel in the Retopo Room).

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Timmy,

 

I'm in retopo mode but when I go to sculpt mode my reference mesh disappears. When I try to open the shader panel from retopo mode it doesn't allow me to select a shader.

How do I make the reference mesh appear again in Sculpt mode?

Share this post


Link to post
Share on other sites

Thanks Timmy,

 

I'm in retopo mode but when I go to sculpt mode my reference mesh disappears. When I try to open the shader panel from retopo mode it doesn't allow me to select a shader.

How do I make the reference mesh appear again in Sculpt mode?

 

Hi alan f,

 

There is a better way to import your model instead of using the "perform retopo" option on the intro menu. I have experienced bugs with several of those options, and also some of those options limit the funcionality of 3D-Coat, so I don't use them.

 

 

Step 1: When first opening 3D-Coat, and you see that initial intro menu, just close it.

JustCloseThis.JPG

 

Step 2:

1) Go to the Sculpt Room.

2) Select the Import Tool.

3) Turn on "Import without Voxelization".

4) Select your mesh with the file browser.

5) A preview of your mesh will be generated. If you can't see the mesh, most likely you will need to scale it up with the Transform Gizmo. As you scale it up you will see the "Estimated Poly Count" go up (shown in the middle of the Tool Options panel), but that number doesn't mean anything if you are importing without voxelization. Therefore in this case you can safely ignore the "Estimated Poly Count".

6) Once your mesh fits into the viewport nicely, then click on Apply and your mesh will finally be imported into 3D-Coat. The import preview however still remains, so you need to switch to a different tool to get rid of the preview.

ImportOptions.JPG

 

Step 3: Choose any other tool to get rid of the import preview.

SelectAnyOtherTool.JPG

 

Step 4: Now you can finally see your reference mesh in both the Sculpt Room and the Retopo Room. If your mesh does NOT have any vertex color data associated with it (known as "polypaint" in Zbrush), then you can now change the color of your reference mesh by changing its shader.

 

Step 5: If however there is in fact vertex color data on your mesh, then changing the shader will have no effect. You will need to go to the Paint Room, turn off visibility of the vertex color (by clicking on the "eye" icon next to the vertex color layer), which will make the shader visible underneath. Then you will finally be able to change the look of the shader in the Retopo Room.

TurnOffVertexPaintLayer.JPG

  • Like 1

Share this post


Link to post
Share on other sites

Same solution as my earlier idea. Only the + - keys don't work on these meshes in paint room. Retopo inside of  mouth  .. only I can't make the lower mouth disappear with the eye tool, + - simply doesn't work in this mode. :(

And the default reference mesh shader for retopo doesn't show enough detail to see the ref mesh surface properly..  Why?

Edited by mercy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×