Jump to content
3DCoat Forums
NKLV

[Solved] Alpha Selection And Transparency Issues

Recommended Posts

Hi there, as of version 4.8+ i've had a very annoying issue that has made me go back to 4.7, as you can see transparency selection Only respects "Brush strokes transparency" not material transparency:

2018-04-05_213922.thumb.png.0cd5c58c5eb810524f5515caadd34746.png

Weirdly enough this works as it should in 4.7 or something, this is very important to the way i use the software as i use it to create "Speckle" or "Noise" to add rust, dirt and saves a lot of time. greatly improving my painting time.

Is there any features added that i need to activate to be able to use this software the way i did before? any major changes? or is it a bug that is being worked on?, Thank you.

Share this post


Link to post
Share on other sites

Do you mean, like have having a Png image in your smart material that has transparency... Yes there was a few problems like or similar to it. 

4.8.14C corrects the problems. 

As long as your Png image has transparency it is supported in the smart material and applied correctly.

Example. Paint your base layers and then paint in the creases with your dirt and grunge.

Image not shown for quality but to show the Png image with transparency.  Painted over a model that has no paint layers to so you can see that there are areas in the applied paint that are transparent.

FYI. I used no conditional maps in the smart material,  just painted to demo what I was talking about. 

Hope this helps and I read your post correctly.

 

trans2.JPG

Edited by digman

Share this post


Link to post
Share on other sites

I don't believe that its tied to the Alpha channel inside PNG files, here's an example of how im used to work with CTRL+LMB on a layer this is the result i expected:

2018-04-05_213923.thumb.jpg.c74aac575a44df64868e03f339622f6f.jpg

I followed the exact same steps as i did in 4.8.10, but this Screenshot is from 4.7.06 and it works as intended, im unsure if this is an issue already noted or in the way to fixed, thanks for your replies.

Share this post


Link to post
Share on other sites

You may need to write out your specific steps or a short video to help me understand your workflow. Be specific in details.

Ctrl-LMB acts just like the eraser tool. Apply paint, then without switching to the eraser tool, you can erase.

I just need more detail information. I see your preview options panel is open, so you have to be using a smart material or a stencil. 

I have a few thoughts on what you are doing but I rather wait for detailed information.

Edited by digman

Share this post


Link to post
Share on other sites

I cant replicate this issue with v4.8.15  3DCoat 64-bit

could you try it please ?

Share this post


Link to post
Share on other sites

Yeah, i can confirm this issue is gone by 4.8.15, the problem seems to only exist on 4.7.36+ all the way up to 4.8.10,  i'm just gonna keep working on 4.7.09 for a while, ill retry the newer versions later on, thanks for your replies.

Share this post


Link to post
Share on other sites

×