Jump to content
3DCoat Forums
Sign in to follow this  
tokikake

sculpt with surface mode and export with keep UV

Recommended Posts

Hi I now get new VDM(vector displacement map) generator, which can generate VDM from selected high sculpt mesh, and sub-D mesh (which already UV un-wrap) in other 3d aprication.

I only need to it work, 

1. high-resolution mesh with UV.  = meshA,    

2.  sculpt meshA = meshB (but keep vertex order and count as same as meshA)

Then  hope to sculpt in  3d coat sculpt room, with surface mode. (so  at least not change vertex count and not change vertex order, after import mesh in sculpt room)

Do someone teach me, clear work-flow to it work?

The complex thing for me,, sculpt mesh in 3d coat sculpt room with surface mode, then export mesh from 3d coat it not have UV.  (of course) . I can import mesh with UV for Retopo room, but it can not use my sculpt mesh (can not directly return sculpt mesh to Retopo room as high-reso mesh I suppose)

I believe there should be good workflow, (and it may not so complex), but hope to know the clear work-flow. so I can generate VDM as 3d coat scupt delta, for rig- mesh in another aprication, as VDM.

Share this post


Link to post
Share on other sites

The problem is,,

1 I import mesh in retopo room with UV

2 Retopomesh > Sculptmesh

3. only sculpt with surface mode.

4. export sculpt mesh with out change resolution. (not decimate)  as mesh sculpted

5. export non sculpt mesh from retopo room as mesh base

the improt mesh sculpted and mesh base not keep same vertex order. I could confirm it. 

So is there any way, import mesh (in another aprciation) >> sculpt >> export mesh with  keep vertex order, as same as before?

 

 

Edited by tokikake

Share this post


Link to post
Share on other sites

Hi

Check use Source Positions to keep the origin vertex positions.

 

Vertex.jpg

Share this post


Link to post
Share on other sites
16 hours ago, Carlosan said:

Hi

Check use Source Positions to keep the origin vertex positions.

 

Vertex.jpg

I do not know when I use the option..

I directly import mesh without voxelazation in sculpt room as obj, and export it again as obj, but  when triangulate mesh, (for sculpt),  3d coat seems change vertex order. I can confrim it with shape key (I set option for import export always keep vertex order as blender export-import option) , it break mesh.  If I only use retopo room, or texture paint room, it never happen.

but I need to sculpt in sculpt room . (so even though I could import export from retopo room, it not matter,  I sculpt mesh and export it , it need to keep vertex order, as same as exported obj to 3d coat. (so I only use non voxelize, and surface sculpt only)

Is there work flow,

import high-resolution mesh to 3d coat>> sculpt (surface mode only)>> export  mesh non desolve, to blender, then keep same vertex order?   If you know work-flow, I really hope it....   

The Vector displacement map generator (blender add on) is beta, but it work really well... (it not lay cast bake, but circulate from verts position then convert as RGB, and generate png (16bit) .  I hoped to describe the work-flow (sculpt in 3d coat, then generate VDM for blender mesh (you can use sub-D modifier, or multiresolution modifier, with adaptive sub-D)

, but at current I can not recommend the add on for 3d coat (and blender) user .. ,, it is pity for me..

 

 

Edited by tokikake

Share this post


Link to post
Share on other sites

when triangulate mesh, (for sculpt),  3d coat seems change vertex order... 

Yes is how it works. 

Share this post


Link to post
Share on other sites

OK thanks

The pity thing (for me) was, even though I already triangurate quad  mesh (then 3d coat need not triangurate) in blender >>  export  to 3d coat sculpt room without voxelization >> export to  blender

3d coat still change vertex order. ^^;  (it never happen do same test with  retopo room and use same mesh)

(can I request, 3d coat may keep vertex order, al least when mesh is already triangurated  (so 3d coat need not to change mesh at all in sculpt room with surface mode ), import and export mesh by sculpt room,  keep same vertex order?  or will add such option?  

Because my purpose is generate VDM, so it not matter mesh was triangulated  when export. I can use same VDM for quad only version with keep UV..

Edited by tokikake

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×