Jump to content
3DCoat Forums

[Solved] Surface Book pen pressure bug


Recommended Posts

  • New Member

I did the requisite googling before posting this and couldn't find anything, so...


I'm currently using 3D Coat (4.5.19 and beta 4.5.35) on a recently-purchased Surface Book (i5/8gb RAM/dGPU) and have run into trouble with pen pressure. I can't get any of the 3D Coat brush settings to respond correctly to pressure, be it radius control or depth control or what have you. I was concerned that 3D Coat might not recognize whatever digitizer the MS Surface line is using, so I tried plugging in my old Wacom Bamboo and ran into the same problems. Everything comes out at the same radius and the same depth, no matter what kind of pressure is applied.  This seems unique to 3D Coat, as pen pressure in Photoshop works flawlessly.


Weirdly, I then went back to my other desktop computer and tried the Wacom Bamboo again, only to find that 3D Coat handled pen pressure flawlessly.


Is this a 3D Coat bug, or am I doing something wrong? Thanks!

  • Like 1
Link to comment
Share on other sites

  • 11 months later...
  • Member

Was there a solution? running 4.7 trail now - but pen pressure is still not working in 3D Coat - in other apps, it does. Do I need to buy some other pen (wacom) to have

it working?


I am on a surface book, i5 with dgpu



Edited by Karsten
Link to comment
Share on other sites

Please install optional WinTab driver for "Surface Book" (files "Wintab_x32_1.0.0.20.zip" or "Wintab_x64_1.0.0.20.zip"):
Also we have separate Pen pressure test which is the engine of "3D-Coat" tablet input. It shows does the pen send pressure information to the application:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...