Jump to content
3DCoat Forums

RenderMan render


Zombie
 Share

Recommended Posts

  • Reputable Contributor
9 hours ago, Taranta said:

I've installed the latest Renderman but even though 3DCoat detects it, nothing shows up in the render preview. Actually rendering it gives black screen / or crashes 3DCoat. Any idea?

I've had that happen when the scene was too heavy. Test it on a sample scene like the Human Primitive or Mannequin from the splash screen.

Link to comment
Share on other sites

  • 3 months later...
  • Member
On 7/4/2019 at 2:14 AM, Taranta said:

Still happens with a basic primitive, not showing anything in preview, crashing when I click "finalrender"

Also after installing latest drivers.

I have the same problem.
If you go to log then there he constantly tries to connect to port 4001. I opened it and closed it nothing helped

3123123.jpg

Link to comment
Share on other sites

Is RM Proserver installed ?

Installing the License Server on Windows

Double-click on the appropriate .msi file to invoke the installer, e.g. Pixar_License-LA_[version]_Win32.vc8-SSE2.msi. This must be done on the machine that you intend to use as your license server. The installer will take you through the installation process, step-by-step.

  • Important

The License Server installation requires that the Microsoft Visual C++ 2010 x64 runtime library be installed. The runtime library can be downloaded from Microsoft. The License Server will not install or run without this component. Download this ONLY if not currently present on your machine.

  • Note

Connections to the license server are made over port 9010. When running any of the installers, or setting up your site's .ini files, make sure that you are pointing at port 9010, not 7498.

By default, the license server is installed in C:\Program Files\Pixar\PixarLicense-LA-[version] and contains the following components and scripts:

* PixarLicenseServer.exe
* LicenseApp/
* pxmlshared.tcl
* queryAvailablePRMan.tcl
* queryPRMan.py
* queryUsersPRMan.tcl
* startPixarLicenseServer.sh
* stopPixarLicenseServer.tcl
* visualizeLicenseSharing.py
  • Note

    The Pixar License Server software only needs to be installed on the machine that you have designated as your license server.

Near the end of the installation the licensing application, LicenseApp.exe, will be invoked. It will ask you for an "Entitlement Serial Number" and your Support Forum login and password. Enter the information in the appropriate fields (if you use a proxy server, your proxy information should be added as host:port, e.g. foo.mydomain.com:8080 in the Advanced sction) and click on the Get License button.

The application will contact Pixar's servers and download your license to the License Server directory. Once that is finished, quit LicenseApp and the license server installer will run to completion.

Eventually, you will need to start the license server. This can be done via the Windows Services panel (Start-> Control Panel-> Administrative Tools->Services), or you can run the executable via the Command Prompt (the -help option will give you a rundown of the optional flags for running the license server, including -v:X for debug output and -log filename for logging).

 

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hi 

You follow this steps and still is not working ?

- Transfer pixar file.license" to C:\Program Files\Pixar. This file is located in the folder where you specified the RenderMan installation path

Link to comment
Share on other sites

  • 2 weeks later...
  • Member

I just downloaded the 4.9.17 Trial Version and wanted to try out the new renderman23 in 3dcoat. Now i saw in this thread that it works only with older Versions. I use Renderman for Houdini, and the Renderman Pro Server is up and running on my workstation. 3DCoat initialize it in the Render settings properly so far. But somehow, when I load some test objects and click on Render or Preview Render, nothing happens. 
IT window is not coming up and No CPU nor GPU activity. It just stalls until i kill the thread manually. 

Just for test purpose i removed the Renderman License, to see if some error comes up in 3d coat. Maybe some Patch problems. Results were 

if pressed preview  the IT came up, but nothing more. 
if pressed Render, 3dcoat start with the map exporting and when its finished, it breaks away without saying goodbye. No error messages. 

Also interesting, in the LocalQueue Manager from Renderman, nothing comes up, also no log message. Obviously the whole process hangs at 3dcoat, before the data could be passed to the Renderman server. 

The Variable RMANTREE is also properly patched as i checked

The User Preecher posted that it works with 4.9.05. Any idea what changed? 
 

Link to comment
Share on other sites

  • Member
On 12/25/2019 at 9:42 PM, preecher said:

yes i'm using it in 4.9.05.  that's the version i'm using until I see it is fixed.  thanks for posting your experience JanVollgod!

Your welcome. 

Did you test it with older versions of Rendeman? Maybe 22.5 or 22. 

I hope some Dev will look after this, what changed from 4.9.05 to 4.9.17 and prevent the Data Flow to Renderman Server.

Link to comment
Share on other sites

  • Member

yes I was using 22 and 22.5 in 3dcoat.  it was just the builds after 4.9.05 that it stopped?  I was starting to think I was only one with the problem.  I think some of the render options changed in 3dcoat after 4.9.05.  i'm sure he will get it going again soon!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Member
18 hours ago, preecher said:

hi,

I downloaded the 4.9.19 version and renderman23 still does not work.  it hangs up and IT does not open???

 

i'm still using 4.9.05 version as renderman 23 works with this version.  

thank you

Thank you for reporting back m8t, even it's sad that after so many releases nothing changed. Sadly my python skills are not enough to find out what is wrong in the process. Because it hangs before 3dcoat even start to export the maps. I checked the export folders, done some system env. Var. Tests, but don't achieved any solution so far. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...