Jump to content
3DCoat Forums
Sign in to follow this  
DanielWaterhorse

UV seam selection: 1 edge at a time?

Recommended Posts

Hello all.

I have a model I created in ZBrush, from which I made a "low poly" version (~60k faces) using ZRemesher followed by some manual editing in 3D Coat. I am using the latest stable version of 3D Coat, 4.7.24.

Now I am trying to make UV seams on the low-poly mesh in 3D Coat so that I can texture it. I have it in the retopo room as a retopo object. I am trying to use the UV Mark Seams tool with the 'edges' selection, but even with with number of segments set to '1', I can mark, at minimum, 3 edges at a time, which automatically follow along the edge loops.

Since this is my first time trying to make UV seams manually, perhaps this is intended for a reason I am unaware of. But there are points where I would like finer control if possible. Is this a bug, am I doing something wrong, or am I misunderstanding an aspect of creating seams that accounts for this 3 edge minimum selection?

Thanks for taking the time to read my questions :)

Share this post


Link to post
Share on other sites

Edge Loops will find contiguous edges. It may be that your model has few 'obvious' edge loops, but you can use the Path tool to make longer selections. A picture of your mesh would help.

Share this post


Link to post
Share on other sites

A little confused here.  Under the UV command is Mark Seams, it will only select one edge at a time. regardless of brush radius size.

Edge loops will do what it says, selecting loops till there is a break.  

Can you be more specific in your workflow.

seams.PNG

Share this post


Link to post
Share on other sites

I kind of figured it out? When segments is set to "1" it marks 3 edges at a time (shown in the screenshot), but if it's set to "0" it marks one edge at a time. However, the segments UI element won't decrement from 1 to 0 by dragging, so I didn't realize it could even be set to zero at all. You can set it manually however.

I also ran into another strange issue that I should perhaps make another thread for. I could not unmark seams at all, neither by clicking again with LMB as the tool tip says, or by using ctrl-LMB as the manual says. However, I opened the file in 4.7.06, where I could remove marks with ctrl-LMB. When I opened the file again in 4.7.24, it restored my ability to unmark seams this way. Not sure what to make of it.

weirdissue.png

Share this post


Link to post
Share on other sites

The tool tip for segments states that segments will be created on each side of the segment selected.

1 =3 total segments (edges) selected.

2=5 etc...

It is a little funny that a setting in the uv room also effects the selection of edges in the retopo room. Once you set the number of segments in the UV room you also now select more than one edge in the retopo room as well. You have to put the segment to (0) to get back the default behavior of only selecting one edge when using "Mark Seams"  in the retopo room.

Now if you put the number of  segments selected in the UV room back to the default "1" then close and reopened 3DC, you get back the default behavior of only selecting one edge in the Retopo room... 

The appears be a UI glitch and a bug... Segment selection should be in the retopo room as well so you would not have to leave the retopo room to set it.

I agree that "0" should be the default setting...

Not sure the reason you could not deselect...

3DC version: beta 4.7.26

 

Edited by digman

Share this post


Link to post
Share on other sites

Ah. I guess I never hovered over the segments UI element long enough to realize there is a tool tip for it. I should keep that in mind from now on. Then again, I was experiencing several bugs at once, so I was a bit exasperated. In fact, in addition to not being able to deselect UV seams, I also found that I was not able to paint in the paint room to an object that already had UVs, until just opened it in an older version of 3D Coat and reopened it in the newest version, just like the deselection problem. 3D Coat has amazing features but man is it finicky.

Share this post


Link to post
Share on other sites
7 hours ago, DanielWaterhorse said:

Ah. I guess I never hovered over the segments UI element long enough to realize there is a tool tip for it. I should keep that in mind from now on. Then again, I was experiencing several bugs at once, so I was a bit exasperated. In fact, in addition to not being able to deselect UV seams, I also found that I was not able to paint in the paint room to an object that already had UVs, until just opened it in an older version of 3D Coat and reopened it in the newest version, just like the deselection problem. 3D Coat has amazing features but man is it finicky.

The problems you are having on not being able to deselect uv seams and not being able to paint on an object that already has UVs, I have not experienced. Maybe at some point you can share the offending 3DC files for other to look at or look at the picture included in this post to see how to send the 3DC files directly to support at 3DC...

3DC version beta 4.7.26

Help_01.jpg

Edited by digman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×