Jump to content
3DCoat Forums
Sign in to follow this  
Karsten

[Solved] Surface book Pen Pressure (again) :(

Recommended Posts

hello,

I have to raise this topic once again... after installing the WinTab drivers, I did just a quickt test with the build brush - pen pressure worked great.

Aftrer a while, I returned to 3D Coat to do a complete project, from A to Z (sculpt, retopo, UV, texture) - but I noticed, that some brushes do not work (have zero effect)
and this is (among others) the smooth brush (as seperate brush or when pressing shift = the same). Smoothing does absolutly nothing on my model, I tested the same
3b.File on my desktops and smoothing works, as expected....

Also not doing anything: Fill (and "Planar" does not show a "Plane")

I plugged a mouse into my book and - smoothing still doesnt work (!) How can this be?
Is there some setting, I´ve overlooked? I am on a fresh 4.7.24 DX install...

 

Thanks!

 

Share this post


Link to post
Share on other sites

Please repeat this steps. Ty

On 4/11/2017 at 8:50 AM, SERGYI said:

Please install optional WinTab driver for "Surface Book" (files "Wintab_x32_1.0.0.20.zip" or "Wintab_x64_1.0.0.20.zip"):
https://www.microsoft.com/en-us/download/details.aspx?id=49497
Also we have separate Pen pressure test which is the engine of "3D-Coat" tablet input. It shows does the pen send pressure information to the application:
http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip

 

Share this post


Link to post
Share on other sites

hey Carlosan,

I did once agan installed the drivers and did a reboot - but still not working.
When I use the suggested Pen pressure Test tool, the Pen gets recognized as Left Tablet Button, pressure is around 300, when I just press it soft and up to 600
when pressing hard. It also works when I use right button on the pen and it also recognise the eraser...

Seems like it is working ok, I guess???

But in 3D Coat, it still does nothing with fill or smoothng brush

Edited by Karsten

Share this post


Link to post
Share on other sites

Ok, let me correct this - smoothing kind of works, but just veeeery subtile, no matter what brush settings or pressure I use.
Smoothing is set to 100% already, and even if I set the brush´s curve very high, still nearly no smoothing effect.

On desktop when using a mouse, smoothing works much more dramatic/strong

Edited by Karsten

Share this post


Link to post
Share on other sites

Hi !

Please send support question about this issue to Andrew Shpagin at

support@3dcoat.com

Ty.

Share this post


Link to post
Share on other sites

To separate low-level input from Surface Book's Pen and inner "3D-Coat" settings please use this test:
http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip
At any moment this test shows does "3D-Coat" receive low-level input with pressure from Surface Book's Pen. This application is the engine of "Tablet Pen" input used by "3D-Coat". The input is not affected by any "3D-Coat" settings and therefore the test shoes is the problem with pen caused by low-level input (i.e. by driver) or by inner "3D-Coat" settings. As you mentioned the pressure is receiving correctly: "When I use the suggested Pen pressure Test tool, the Pen gets recognized as Left Tablet Button, pressure is around 300, when I just press it soft and up to 600 when pressing hard."
Then at any moment you can rename/delete/backup (if you have created some scenes already) your user data folder "This PC > Documents > 3D-CoatV47" to see how any brush reacts on pressure using default inner "3D-Coat" settings on default models. This way will help to debug specific brush (because your custom settings will not affect on behavior).

  • Like 1

Share this post


Link to post
Share on other sites

hey Sergyi,

 

I downloaded the tester again and run it. It does not show "3d coat", but once again "Pen input (button). not sure, if I get this right?!
So you suggest to delete my " Documents > 3D-CoatV47" ???. how can I test the 3d brushes inside this tester?! I am a bit confused...

Share this post


Link to post
Share on other sites
On ‎4‎/‎23‎/‎2017 at 6:21 PM, Karsten said:

smooth brush... Smoothing does absolutly nothing on my model... I plugged a mouse into my book and - smoothing still doesnt work (!)

Because smoothing doesn't work even with mouse this is clear sign that this is not because of missing pressure information from Surface Book's Pen but because of some settings inside "3D-Coat". The most reliable and the quickest way to localize the problem is to rename (or backup and then delete) "3D-Coat" user data folder "This PC > Documents > 3D-CoatV47". That folder contains your already created scenes and all custom settings. Please remove/rename that folder (with previous backup if necessary) and then run "3D-Coat" and test the suspicious brushes on standard models with mouse and with Surface Books's Pen. Compare the behaviour with desktop results.
Regarding the separate application "Pressure Test". That application shows does the Surface Book's Pen send pressure information into the "3D-Coat" and what value does it send?! The maximum is 650 (hard pressure) and about 300 is medium (soft pressure). Between the WinTab driver and "3D-Coat" only that value is exchanged. The absence of that value inside the separate "Pressure Test" application means that the problem is with WinTab driver which should be (re)installed. The presence of that value means that the problem is inside inner "3D-Coat" transformations which can be reset to defaults by removing/renaming/backuping the mentioned above user data folder.

Share this post


Link to post
Share on other sites

Hello Sergyi

the pressure test is showing 300 (low pressure) and 600, when I press hard. just works, like before.
I renamed the 3DCoat folder in documents, like you suggested, started 3D coat an tested brushes, again.

Now, no brush is working - either with Pen, nor with mouse... either in voxel mode or in surface mode.

For model, I used the large sphere of the "standard scene" entry in splash-menu

Share this post


Link to post
Share on other sites

Ok - dont know, what it was - but after restarting, all brushes radius were set eeeery small !
As I increased radius, things start working again.

But still, smoothing brush seems not to react on pressure - it allways smoothes things out veeeery slighly :(

Share this post


Link to post
Share on other sites

So my 3D Coat trail is coming to it´s end soon, without having solved this issue - which is a sad thing.
I would really like to use 3D Coat as my go-to-sculpting app... but without a working smoothing brush... well, I think I will look around for other software.

 

Thanks for support, maybe I will check back later to see, if there will be a solution

Edited by Karsten

Share this post


Link to post
Share on other sites
On 5/3/2017 at 9:28 AM, Karsten said:

smoothing brush seems not to react on pressure - it allways smoothes things out veeeery slighly :(

Hello, Karsten! There is one thing that is surely guaranteed: your Surface Book's Pen correctly sends pressure information into "3D-Coat"! Because you complained only to "Smoothing" brush I suspect maybe you expect some other behaviour of "Smoothing" brush? Can you compare the behaviour of Surface Book's Pen with mouse? When I run "3D-Coat", select "Voxel Sculpting > Big sphere", then do big stroke with "Grow" brush and then select "Smooth" brush it really seems like it doesn't do too much changes on the model (from mouse and from Wacom tablet too). But if I do many small strokes (like grid) and then apply to them "Smooth" brush the result is very noticeable (from mouse and from Wacom tablet). Please see the attached screenshot.

Smooth.jpg

Share this post


Link to post
Share on other sites

Hello Sergyi,

I really would like to test it - but unfortunately my trial-time expired yesterday. I expected the smooth brush to kind of "undo(even out" even drastic changes, like smoothing them
out and make things look like before (this is the behavior in most other apps, I´ve tested so far). Smoothing-brush really "destroys" sculpt and does remove allmost
all sculpted stuff.

best regards

Share this post


Link to post
Share on other sites

Hi !
To extend trial period please contact support@3dcoat.com
Best Regards

Share this post


Link to post
Share on other sites
On 5/8/2017 at 9:05 AM, Karsten said:

I expected the smooth brush to kind of "undo(even out" even drastic changes, like smoothing them
out and make things look like before (this is the behavior in most other apps, I´ve tested so far). Smoothing-brush really "destroys" sculpt and does remove allmost
all sculpted stuff.

To make the effect like you have described in "3D-Coat" you have to:
run "3D-Coat" > select "Voxel Sculpting" > "Big sphere" > do big stroke with "Grow" brush > click "V" near label "VolumeX" to switch into surface mode > in upper comboboxes for "SHIFT" (or "CTRL-SHIFT") select "Anti Bump" (instead of "Smooth"). Now when you press SHIFT (or CTRL-SHIFT) the changes are very noticeable on big areas (see the attached screenshot).

Anti Bump.jpg

Share this post


Link to post
Share on other sites

hello,

 

sorry for not reporting back for a longer time - now I got my trail extended, I was able to test your suggestion - and it works!

So I think, the issue is/was, that in voxel-mode, there is not much smoothing going on or it does not work as strong as in surface mode.
Ok great, sp Pen Pressure works!

 

Best Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×