Jump to content
3D Coat Forums
Metin Seven

Single-click to add or subtract in Sphere tool

Recommended Posts

Hi,

The Sphere tool has become one of my favorite 3D Coat tools, but I've got a question:

Until recently, I could simply click once on a surface to add or subtract one sphere from the surface, using the Sphere tool. But since a few sessions I need to start dragging first to add or subtract a sphere. I've tried switching off and on the Draw From First Point  option and the Cubic Interpolation option, but to no effect. I also tried different stroke types, but it all doesn't work to get back the one-click result.

Did I maybe (de)activate some mode or option that might have caused this behaviour of the Sphere tool?

Thanks,

Metin

Share this post


Link to post
Share on other sites

Thanks, @Carlosan, I already tried that. I usually use the Constant Pressure stroke, and previously it worked fine, requiring only a single click to add or subtract a sphere. But somehow that behavior seems to have changed permanently.

Share this post


Link to post
Share on other sites

Just tested this and it seems to work fine on first click for me with the usual stroke types regardless of settings, but if for some reason you can't get it working as before you could always try using the Stamp/Stamp Drag Mode options.

3DCStamp.jpg.387302fe28d8ff6040d67c5de0c2b478.jpg

Stamp Drag mode would allow you to change the position of the sphere after clicking, whereas Stamp mode is locked to the initial click point.

There seems to be some odd behaviour with Stamp mode & the Sphere tool in that normally Stamp mode allows you to change the scale of the alpha you're applying, but with the Sphere tool it appears to be locked to the initial brush size/radius setting for the tool, but if you wanted the ability to change the radius of the sphere an alternative would be to use the Extrude tool and Stamp mode with the default spherical alpha and a depth setting of 100%.

3DCSphereAlpha.JPG.db5dfd599e8905887291ecae4f0c39bf.JPG

Share this post


Link to post
Share on other sites

Thanks, @Fluffy. I'll use the stamp mode for the time being, hoping that I can track down the cause of the Sphere tool's sudden behavior change.

Interestingly, the Carve tool does work with a single click. I'll try to find out what the settings / options differences are between the Carve tool and the Sphere tool.

Share this post


Link to post
Share on other sites

Found it! It was caused by the Rotate Along Stroke option. I guess that somehow got activated while using the Sphere tool.

ZBrush has a Reset Current Brush and Reset All Brushes option. That'd be great in 3D Coat as well, reverting all settings to the defaults.

  • Like 2

Share this post


Link to post
Share on other sites
21 minutes ago, Metin Seven said:

Found it! It was caused by the Rotate Along Stroke option.

Ahh, glad you got it figured out, will have to remember that for future reference, thanks! :)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×