Jump to content
3D Coat Forums
Sign in to follow this  
mediapod

GL version: Reference Mesh Textures & UV Issue

Recommended Posts

I'm working on a retopology project converting high res mesh and textured photogrammetry buildings into game assets.

I've previously used this workflow but I'm now having weird errors with it. Any help would be hugely appreciated as I'm on a tight deadline!

I'm importing Reference Models using the standard import options on the File menu which has worked fine previously. I'm trying with a variety of different mesh resolutions from 50k up to 2 million and different textures from 2k unto 8k

With the lower mesh res imports the UVs appear to be all messed up (see 50k Reference Model picture) but when performing retop on the model and baking it, the resulting textures are fine on the baked retop model - still messed up on the Reference Mesh though. Importing the 250k and above ones there is no texture on the mesh and baking doesn't have a texture. I can't find a way to add the missing texture to the Reference Mesh - tried the various texture imports but I'm guessing they're not related to the Reference Mesh.

I've also attached an image of what the same 50k model looks like in Cheetah 3D - also imports fine into Unity3D.

The meshes have all come from Zephyr. If I process them first in Cheetah they also loose their textures as obj and fbx.

Is there a specific process to take photogrammetry models into 3D Coat I'm missing? (These are not solid models).

50k Model in cheetah 3D.jpg

2 Million Reference Model.jpg

250k Reference Model.jpg

50k Reference Model.jpg

Share this post


Link to post
Share on other sites

Hello, please try this steps

1) Go to the Sculpt Room.

2) Select the Import Tool.

3) Turn on "Import without Voxelization".

4) Select your mesh with the file browser.

5) A preview of your mesh will be generated. If you can't see the mesh, most likely you will need to scale it up with the Transform Gizmo. As you scale it up you will see the "Estimated Poly Count" go up (shown in the middle of the Tool Options panel), but that number doesn't mean anything if you are importing without voxelization. Therefore in this case you can safely ignore the "Estimated Poly Count".

6) Once your mesh fits into the viewport nicely, then click on Apply and your mesh will finally be imported into 3D-Coat. The import preview however still remains, so you need to switch to a different tool to get rid of the preview.

import.JPG

keep scale.JPG

Share this post


Link to post
Share on other sites

Another option

New > Perform retopology > Import reference mesh

Then you could use (Paint Room) "Texture"-"Import"-"color/albedo maps" to adding texture to your reference meshes.

import.jpg

Share this post


Link to post
Share on other sites

Thanks Carlosan,

I tried both of those processes.
The first one brings to model in with what appears to be vertex colouring based on the texture but no detail and the other brings it in with the messed up UVs.

 

Screenshot 2019-07-12 at 11.04.59.jpg

Screenshot 2019-07-12 at 11.05.13.jpg

Screenshot 2019-07-12 at 11.09.08.jpg

Screenshot 2019-07-12 at 11.11.35.jpg

Share this post


Link to post
Share on other sites

Hi, sorry i am working on windows version. Cant find any issue.

Could you please try latest version 4.8.41 ?

Perform.jpg

reference.jpg

Share this post


Link to post
Share on other sites

Version 4.8.41SL

I was having the same messed up uv map that Mediapod was having using import reference mesh with texture. 

How to fix the problem. Vertically flip the image externally. Then the texture is imported correctly. 

This is not a bug but how some software saves images, You use to have to flip Zbrush images in some applications though I do not know now if that is still the case for Zbrush exported images.

Share this post


Link to post
Share on other sites

I see I did not look to close at your problem. My answer does not relate to you specific problem. 

You created the mask. Filled the mask with a texture but upon export the masked filled area is not exported in the final uv texture map. Is this correct. Can you share the 3DC file so I can look at it.

Share this post


Link to post
Share on other sites

Try using latest version please

osxicon.pngmacOS Mojave [4.8.41]: 

http://www.pilgway.com/~sergyi/3DCoat/3DCoat-4.8.41.dmg

Ensure to check "System Preferences > Security & Privacy > click the "lock" > select "App Store and identified developers" (when only "App Store" is selected error message is displayed "3DCoat" can't be opened because it was not downloaded from the App Store)

Share this post


Link to post
Share on other sites

Opps posted my last above post in the wrong thread.

Share this post


Link to post
Share on other sites

I tried the latest Beta - same problem.

Tried opening your file - opens with no textures and then importing one screws up the UVs again.

I'll give it a try on windows tomorrow.

Thanks very much for your help so far!

Screenshot 2019-07-16 at 00.16.28.jpg

Share this post


Link to post
Share on other sites
Hi!
 
Thanks a lot for pointing, fixed it, will do new build today or tomorrow.
 
Andrew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×