biscuitguy

bake
[Solved] couldn't bake normal map

10 posts in this topic

Hi there,

I'm trying to bake my sculpt model to low poly mesh by "Bake w/ Normal Map (Per-Pixel)" but baked maps has strong noises on any Materials.

this is sculpt mesh. (sorry for poor mesh, this is my best.)

df_cathedral_12.JPG

and this is baked mesh on Paint room. diffuse and normal map have strong noise.. (it should say dithering?)

df_cathedral_13.JPG

 

 

 

 

 

 

 

what happen on my 3d-coat?

I'm using ver4.7.26(GL)

Alienware 17 R2 w/windows8.1 64bit

 

thanks,

Share this post


Link to post
Share on other sites

Hi !

Show voxels in paint room is = off ?

c.jpg

Share this post


Link to post
Share on other sites

Hi, Carlosan.

ya, voxels is hide on Paint room.

I tried another file or simply voxel, but I got same result...

 

Share this post


Link to post
Share on other sites

The texture resolution is low ?

How is packed your UVmap ?

Bake normals with dithering is = ON ?

 

Bake normals with dithering.jpg

Share this post


Link to post
Share on other sites

look like resolution was not affect to noise. (but size is change)

and UV also not affect. (I tried copy and paste as maximum scale to new UV a piece of mesh)

Bake normals with dithering, I tried both, but seems like no effects on my mesh.

I tried export voxels and retopo meshes to new scene, but it happened again.

totally no idea. :(

 

Share this post


Link to post
Share on other sites

I had this problem also.  

To fix it you will have to adjust the normal intensity on your pbr sculpt shader.  For some reason the bake results are really strong compared to what you expect.


I think it has something to do with the way the shader resolution is tied to the density of of the sculpt layer.  

Anyways, if you turn down the bumpiness on your shader it should give you better results.  You can also try adjusting the texture scale to see if that helps.  Reducing 'bumpiness' value prior to baking should do the trick though.

Share this post


Link to post
Share on other sites

hi, gbball.

surely I changed scale voxel mesh. now I lend to colleague my laptop whose install 3d-coat, so I'll check shader after she is back.

Share this post


Link to post
Share on other sites

Posted (edited)

Sorry, to be more clear...you'll have to right click on the pbr shader you're using for the sculpt object and adjust the bumpiness setting on the shader...you don't need to change your sculpt resolution.  bumpiness.gif

 

 

 

Edited by gbball

Share this post


Link to post
Share on other sites

hi,

seems like this problem has solved by voxels scaleing up size to 1000%.

it means my sculpt voxels was too small. not 3d-Coat's problem. (ya, me also could sculpting and baking before.)

thanks gbball and Carlosan!

1 person likes this

Share this post


Link to post
Share on other sites

Glad to hear it worked out.  Scaling up the model should have the same effect as reducing the objects density, or adjusting the settings in the scale/bumpiness in the shader since it seems like the shader info is tied to the object density per layer.  I notice it because I change density on my sculpts a lot and it causes problems when I bake with certain shaders.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now