Jump to content
3D Coat Forums
Daniel Aubert

[Solved] Exported Normal Map Issue

Recommended Posts

Hello!

I made this model highpoly in Blender, exported to 3DCoat, retopologised it, unwrapped it, and painted on it. But when I exported the obj back to Blender it had one problem: normal map is wierd with the seams showing, like if each island were recieving different lighting. And the normal map is the only texture that had this problem; albedo and roughness are working just fine. This may be something I am doing wrong, cause I am new to 3DC, so I would be very glad if anyone could help.

Here are some screenshots:

a. The model working fine on 3DC, with normals working.

Screenshot_235.thumb.png.41fba04277b3976553f48d9f08e2b114.png

b. In Blender the normal is not good. And it is not related to the uv coordinates, because the seams are in the correct place, but each island is behaving differently to light.

Screenshot_236.thumb.png.34ac5449c7861a8337fd94cd83b7321a.png

c. Here you can see how the map is on the surface.

Screenshot_237.thumb.png.4ecbd870020ac74e07fb785da5c47ada.png

d. This is the normal map - world-space

Screenshot_238.thumb.png.c002aaeb31153b7d0c048412e682664d.png

e. This is the normal map - tangent-space (both have the same problem)

image.thumb.png.83a1488ff8cbbf1cefb2b127f31d10d3.png

Thanks in advance!!

Share this post


Link to post
Share on other sites

Hello 

Looks as Y channel inverted. 

Do you have Export Constructor actived ?

 

Export Constructor.jpg

  • Like 1

Share this post


Link to post
Share on other sites
On 12/15/2018 at 10:49 AM, Carlosan said:

Hello 

Looks as Y channel inverted. 

Do you have Export Constructor actived ?

 

Export Constructor.jpg

Did not work. Even tried changing the preset to unreal, but made no difference...

Share this post


Link to post
Share on other sites

Normal map

For a normal map you can separate the RGB color channels and invert just the red and the green channels. Like in the image below.
click image for full size nodes

  • Like 2

Share this post


Link to post
Share on other sites
On 12/16/2018 at 6:19 PM, Carlosan said:

Normal map

For a normal map you can separate the RGB color channels and invert just the red and the green channels. Like in the image below.
click image for full size nodes

Thanks for all the info! But unfortunately the problem remains. :/ It only flipped how the light was behaving, but you still can see the difference beetwen the uv islands. Like if each island had a different lighting position, dunno... so the seams appear like in the images above. Don't know what else to do... Thought this should be simple.

Share this post


Link to post
Share on other sites

Are you using latest version 4.8.28A  ? Some baking problems was fixed on that version.

- Try exporting any default mesh (Shift+M) to check any issue with your project.

- Use applink to get direct connection in between apps. 

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, Carlosan said:

Are you using latest version 4.8.28A  ? Some baking problems was fixed on that version.

- Try exporting any default mesh (Shift+M) to check any issue with your project.

- Use applink to get direct connection in between apps. 

image.png.b0d1945bc9871918a728288942893384.png

It is not 28A. I will try updating! It is the steam version. And will try these other options as well. Thanks a lot!!

Share this post


Link to post
Share on other sites

I will try to contact them, because I don't know how to update it from steam. It already has the option to update automatically, and since I purchased it a few weeks ago, I think maybe the steam version is outdated.

Share this post


Link to post
Share on other sites

Yes, steam version is outdated. 

- Hope this help:

 

  • Thanks 1

Share this post


Link to post
Share on other sites

source...

Blender expects normal maps in the OpenGL format. The difference between the two is that the green channel is inverted from one to the other, so in the end it doesn't matter what you use, if you know how to use it - you get the same result. 

Only DirectX applications use DX normal maps. And DirectX run only under Windows mainly due to license. For everything else you need to use OpenGL. For sure is good always check documentation.

On image below you can find simple way how to convert DX to OpenGL (or OpenGL to DX)

enter image description here

Share this post


Link to post
Share on other sites
On 12/19/2018 at 11:35 PM, Carlosan said:

Yes, steam version is outdated. 

- Hope this help:

 

 

On 12/18/2018 at 12:26 PM, InternetFriend said:

In blender make sure the image texture node going into the normal map is set to non-color data.

Hey! I updated to 4.8.28A and by setting non-color data on normal map it worked!! See this new model I am working on, it is working perfectly without those stupid seams!

 

Thanks a lot guys!!! 

 

Screenshot_245.png

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×