Jump to content
3DCoat Forums
CoatFly

3d-coat Export OBJ with wrong scale.

Recommended Posts

There's a problem, and it's not blender because it did now happen in other program to.

3D-Coat is exporting the Object as OBJ with a wrong scale.
In blender i need to scale it down from 1.0 to 0.01 to get the orginal scale back.
The otehr program is more problematic with scaling it down.

Why is 3D-coat inflating the object when you export it as OBJ ?
Not tried FBX because that seems a pain with 3D-Coat and blender.

And where can i set in 3D-coat the correct export setting ?
If i can tell 3D-Coat to expert with scale 0.01 things would work better.

 

Edited by CoatFly

Share this post


Link to post
Share on other sites

Imported from blender. with correct settings and scale. then painted in 3d-Coat and exported back to blender.

Edited by CoatFly

Share this post


Link to post
Share on other sites

Try using Blender applink

And B2.79 prerelease that include Principled Shader

 

Share this post


Link to post
Share on other sites
8 minutes ago, Shawn Driscoll said:

Using 3D-Coat's default settings for importing an OBJ file? Or are you configuring settings there?

Using default settings fort scale = 1.0. But , sorry. Am importing a FBX file.

Workflow is Blender -> export FBX -> 3D-Coat -> Export OBJ -> Blender import OBJ

Share this post


Link to post
Share on other sites

I go check the video's

But the best result is to export in unity default format for now.
And apply the textures on the orginal blend file, just ignoring OBJ files etc from 3d-coat. That i on ly use for painting.
If you do more then painting, it's a problem. But at least workout for now.

Now let's see if i can add soem PBR back in blender.

Share this post


Link to post
Share on other sites

You can use this plugin too

 

Share this post


Link to post
Share on other sites

3DC version beta 4.7.32

I do not have any scale problems when importing an obj file from Blender to 3DC and then exporting the same model obj file back to Blender. The scale remains the same. Off hand I do not remember having any export scale problems in prior versions.

Blender is set up for Metric and unit scale is 1.0

Export obj scale setting is set at 1.0 in Blender. 

3DC does not need any special setting when importing to the paint room or exporting. I leave "Apply Scale" in 3DC's export panel unchecked. 

The above works  on my end.

If I do any work in Blender for Unity. I export to 3DC the obj format. 

Next do my texturing and then export a FBX file for Unity from 3DC. I create a folder first for the file. Save the FBX and textures to that folder. Drag the folder into Unity. The scale has been correct so far plus all the PBR textures are correct as well. 

Side Note:  If I scale the model in object mode in Blender prior to exporting, I use "Ctrl--A"  to apply scale and rotation to make the transforming real... 

I generally do not export a 3DC fbx file back to Blender has it adds a lot of nodes overhead. Instead I export a obj file and then in Cycles use the node system to setup my PBR materials.

I have several PBR shaders for Blender, ATM testing the new Principled PBR Shader included in some test builds of Blender.

 

 

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, digman said:

3DC does not need any special setting when importing to the paint room or exporting. I leave "Apply Scale" in 3DC's export panel unchecked.

There's a problem. in my expoter menu there's no "Apply Scale" option at all. Unless it's named different, that would be confusing.
I don't see it in the export window ! It's btw not for unity platform. But it's the most compatible format for now.

https://pasteboard.co/1oE1uQGoG.png

 

Share this post


Link to post
Share on other sites

Apply Scale only is visible if use export constructor is = off

 

ApplyScale.jpg

Share this post


Link to post
Share on other sites

Thanks, interesting new settings.

I tried it, in my case it's betetr to enable scale and set it to 0.01. Then it's correct imported in blender.
So i can choice between adjust it in bledner by scale it back to 0.01 or in 3d-coat.

Thanks. Something new found.

Share this post


Link to post
Share on other sites

You started on a new fresh project ?

It may be that the original scene scale was wrong in the beginning ?

 

SceneScale.jpg

Share this post


Link to post
Share on other sites

@CoatFly. Not sure what is causing your scale problems as I have none between Blender and 3DCoat.

Yeah, I forgot to mention to deselect "Export Constructor".

Edited by digman

Share this post


Link to post
Share on other sites

It looks way too complex to export an object after selecting an app format. I just say OBJ, and give me my texture maps is all (in PNG), when exporting. When I import the OBJ into something else, the texture maps get applied as well. Once in awhile, I end up with texture maps I don't really need. Or the app didn't know where to apply them to. Just takes a few clicks to bring those texture maps in for their channels.

The main thing is OBJ. 3D-Coat's OBJ import/export is solid. But if you're doing any rigging, or using something like GoZ, never mind all that I said.

Edited by Shawn Driscoll

Share this post


Link to post
Share on other sites

I have done it the whole OBJ way. i just checked it.

Blender -> export OB -> 3d-coat -> export as obj with apply scale disabled -> bledner import.
seems to keep the correct scale when i import it in blender.

In other words, i need to change the workflow a bit and stay complet with OBJ format between bledner and 3d-coat.

  • Like 1

Share this post


Link to post
Share on other sites

I'm not seeing any export options when I want to export an object. I can choose .obj or .fbx and all that pops up is the Reduction Tool. I'm on version 4.8 on Windows 10

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×