Jump to content
3DCoat Forums

SERGYI

3DCoat Developer
  • Posts

    306
  • Joined

  • Last visited

Everything posted by SERGYI

  1. The latest "3D-Coat" now optionally supports "Tablet PC" instead of "WinTab". Please download it from here: http://3dcoat.com/forum/index.php?/topic/21433-3d-coat-48-beta-testing-thread/ Enable "Tablet PC" inside "Edit > Preferences > Tablet Library > TabletPC".
  2. Please download the latest "3D-Coat" with "Tablet PC" support: http://3dcoat.com/forum/index.php?/topic/21433-3d-coat-48-beta-testing-thread/ Enable it inside "Edit > Preferences > Tablet Library > TabletPC" (please see the attached screenshot).
  3. Please download this standalone test application: http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip This application is the engine of "Tablet Pen" input used by "3D-Coat". Using key [1] and [2] switch between two tablet libraries: "WinTab" and "Tablet PC" (selected library name is shown in the low left corner in yellow). Currently "3D-Coat" uses "WinTab" which will work only if you will install Wacom "WinTab" driver. Please report what do you see when using "Tablet PC" library which should work without additional Wacom "WinTab" driver. Pressing with pen should show "Left Tablet Button" with "Pressure = xxx" (on moderate touch about 300, on hard touch around 600). Please report me directly on my e-mail "support DOT linux AT 3dcoat DOT com".
  4. Hello, Shu! I have checked rotation with mouse on old "3D-Coat 4.5.02" on my MacBook Pro. Works as expected (no lag). Therefore please follow these steps: 1. Try to rename your user data folder "Finder > Go > Home > 3D-CoatV45" into something like "---3D-CoatV45" and run "3D-Coat 4.5.02" to see how navigation works using default "3D-Coat" settings. Then you can manually copy your scenes into newly generated user data folder. 2. At any moment you can safely update "3D-Coat" by renaming your existing "3D-Coat" installation and after that installing new one. For example, rename folder "Finder > Applications/3D-CoatV4-5" into something like "3D-CoatV4-5 (4.5.02)". Then download and install the latest "4.8.04" from here: http://3dcoat.com/forum/index.php?/topic/21433-3d-coat-48-beta-testing-thread/ Note that your existing "4.5.02" uses user data folder "Finder > HOME > 3D-CoatV45" (which besides your scenes also contains your camera settings). But the latest "4.8.04" will use user data folder "3D-CoatV48" (therefore you will need to copy your scenes into it from "3D-CoatV45"). Please report me directly on my e-mail "support DOT linux AT 3dcoat DOT com".
  5. I have built separate "3Dconnexion" navigator test. Please download and try this test: http://www.3d-coat.com/~sergyi/Tests/3D-Coat-3Dconnexion-Test.zip This is the engine of "3Dconnexion" input from "3D-Coat". It will show how "3Dconnexion" device effects on the FPS (plugged and unplugged). Please look at FPS. Please try both executables (DX - DirectX, and GL - OpenGL). Do you see any slowdown? For example, on my system under DX gives more than one thousand FPS and GL gives almost one thousand FPS (with plugged and unplugged "3Dconnexion SpaceNavigator", during navigation and without navigation). Also I have compiled two special executable files of "3D-Coat 4.8.04" for Windows: http://www.3d-coat.com/~sergyi/Executables/3D-Coat-4.8.04-NoSleepExecutables.zip Overwrite existing executable files "3D-CoatDX64C.exe" and "3D-CoatGL64C.exe" (or rename them before extracting the archive). Using these executable files FPS should never be low (even if you do not move the mouse or tablet pen, please pay attention to this detail). Run them and select Voxel Sculpting > small sphere. On my system DX give almost 300 FPS (with plugged and unplugged "3Dconnexion SpaceNavigator", during navigation and without navigation). Please contact me directly "support DOT linux AT 3dcoat DOT com".
  6. You should define environment variable "COAT_FILES_PATH" with full path to your custom documents folder. Please read more here: http://pilgway.com/~sergyi/Docs/CustomDocumentsFolder.pdf
  7. Copy file "floating.dat" from folder "This PC > Documents > 3D-CoatV47" into folder "This PC > Documents > 3D-CoatV48" under Windows (or from folder "HOME/3D-CoatV47" into folder "HOME/3D-CoatV48" under Linux). To automatically register future "3D-Coat" major updates define environment variable COAT_FSERVER with the content of file "floating.dat" (which is plain text file which contains IP:PORT of your local license server "FServer"). See section "FServer and 3D-Coat client" in this PDF http://pilgway.com/~sergyi/LinuxDocs/FServer.pdf
  8. 1. Download "3D-Coat 4.7.37" from here: http://3dcoat.com/forum/index.php?/topic/19525-3d-coat-47-beta-testing-thread/ 2. In Terminal go into "Downloads" folder: $ cd ~/Downloads 3. Check extended attributes of downloaded disk image with "3D-Coat 4.7.37". $ ls -l@ 3D-CoatV4-7-37.dmg Among them should be "com.apple.quarantine". 4. Delete quarantine attribute: $ xattr -d com.apple.quarantine 3D-CoatV4-7-37.dmg 5. Check that attribute "com.apple.quarantine" has gone: $ ls -l@ 3D-CoatV4-7-37.dmg 6. Remove previous folder "/Applications/3D-CoatV4-7". Open in "Finder" the disk image with "3D-Coat 4.7.37" on which you have removed "com.apple.quarantine" attribute and as usual drag & drop it into "Applications" icon.
  9. The build 4.7.34 for Linux will be uploaded in the nearest days.
  10. The build "4.7.32" for macOS has been updated (please download it again). All smart materials from library "Various_01" are working now.
  11. "3D-Coat" crashes because macOS isolates "3D-Coat" executable from its data - typical problem under macOS Sierra. To solve it please do the following: 1. Remove folder "/Applications/3D-CoatV4-7". 2. Make sure that you have checked "System Preferences > Security & Privacy > Allow apps downloaded from: App Store and identified developers" before downloading disk image with "3D-Coat" on your Mac. 3. Download "3D-Coat 4.7.32" for macOS from here and drag & drop it onto "Applications" alias as usually: http://3dcoat.com/forum/index.php?/topic/19525-3d-coat-47-beta-testing-thread/ In case these 3 steps will not solve the problem then please do these additional steps: 4. In Terminal go into "Downloads" folder: $ cd ~/Downloads 5. Check extended attributes of downloaded disk image with "3D-Coat 4.7.32". $ ls -l@ 3D-CoatV4-7-32.dmg Among them should be "com.apple.quarantine". 6. Delete quarantine attribute: $ xattr -d com.apple.quarantine 3D-CoatV4-7-32.dmg 7. Check that attribute "com.apple.quarantine" has gone: $ ls -l@ 3D-CoatV4-7-32.dmg 8. Remove previous folder "/Applications/3D-CoatV4-7". Open in "Finder" this disk image with "3D-Coat 4.7.32" on which you have removed "com.apple.quarantine" attribute and as usual drag & drop it into "Applications" icon.
  12. Thanks for the report! I have compared Sketch Tool from "3D-Coat 4.7.32" for Windows with "3D-Coat 4.7.32" for macOS. The problem with invisible initial cube and geometry changes has been resolved. The camera behaves identically between Windows and macOS builds. The build "4.7.32" for macOS has been updated (please download it again).
  13. Currently working on Linux build. By the way, will it be ok if the new build will require latest Linux Ubuntu (particularly 16 and above)? What Linux distros do you have? Please report me directly on my e-mail "support DOT linux AT 3dcoat DOT com".
  14. Please download the latest build 4.7.31 for macOS. All shaders are now working.
  15. You are right about shaders. Will look into them. Regarding "Render Man": you should define environment variable "RMANTREE" with location of "RenderMan Server". For example, to define environment variable with path to "RenderMan Server" under macOS Sierra do the following: 1. Run Launchpad > Script Editor > New Document and enter commands do shell script "launchctl setenv RMANTREE /Applications/Pixar/RenderManProServer-21.4/" 2. File > Save... > Save As: Environment Variables (name it as you wish) > Where: HOME > File Format: Application 3. System Preferences > Users & Groups > Login Items > + > add file HOME/Environment Variables 4. Restart your Mac.
  16. The user reported that after disconnecting HDMI cable from graphics adapter and leaving only DVI cable to monitor "3D-Coat" worked using DirectX.
  17. The error itself "Couldn't create Direct3D device interface." means that there is no proprietary graphics driver in the system (http://support.amd.com/en-us/download). But because you have stated that it is installed try 32-bit and 64-bit versions of "3D-Coat" from here (http://3dcoat.com/forum/index.php?/topic/19525-3d-coat-47-beta-testing-thread/). Which of them works using DirectX? Also please try to download and run this test package (http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip). Does executable file "3D-Coat-Pressure-Test (DX).exe" work or only "3D-Coat-Pressure-Test (GL).exe" runs? (these executable files have the same graphics initialization code as in "3D-Coat" but it will be easier to debug using them) Please report the results on my e-mail "support DOT linux AT 3dcoat DOT com".
  18. To make the effect like you have described in "3D-Coat" you have to: run "3D-Coat" > select "Voxel Sculpting" > "Big sphere" > do big stroke with "Grow" brush > click "V" near label "VolumeX" to switch into surface mode > in upper comboboxes for "SHIFT" (or "CTRL-SHIFT") select "Anti Bump" (instead of "Smooth"). Now when you press SHIFT (or CTRL-SHIFT) the changes are very noticeable on big areas (see the attached screenshot).
  19. Hello, Karsten! There is one thing that is surely guaranteed: your Surface Book's Pen correctly sends pressure information into "3D-Coat"! Because you complained only to "Smoothing" brush I suspect maybe you expect some other behaviour of "Smoothing" brush? Can you compare the behaviour of Surface Book's Pen with mouse? When I run "3D-Coat", select "Voxel Sculpting > Big sphere", then do big stroke with "Grow" brush and then select "Smooth" brush it really seems like it doesn't do too much changes on the model (from mouse and from Wacom tablet too). But if I do many small strokes (like grid) and then apply to them "Smooth" brush the result is very noticeable (from mouse and from Wacom tablet). Please see the attached screenshot.
  20. Because smoothing doesn't work even with mouse this is clear sign that this is not because of missing pressure information from Surface Book's Pen but because of some settings inside "3D-Coat". The most reliable and the quickest way to localize the problem is to rename (or backup and then delete) "3D-Coat" user data folder "This PC > Documents > 3D-CoatV47". That folder contains your already created scenes and all custom settings. Please remove/rename that folder (with previous backup if necessary) and then run "3D-Coat" and test the suspicious brushes on standard models with mouse and with Surface Books's Pen. Compare the behaviour with desktop results. Regarding the separate application "Pressure Test". That application shows does the Surface Book's Pen send pressure information into the "3D-Coat" and what value does it send?! The maximum is 650 (hard pressure) and about 300 is medium (soft pressure). Between the WinTab driver and "3D-Coat" only that value is exchanged. The absence of that value inside the separate "Pressure Test" application means that the problem is with WinTab driver which should be (re)installed. The presence of that value means that the problem is inside inner "3D-Coat" transformations which can be reset to defaults by removing/renaming/backuping the mentioned above user data folder.
  21. To separate low-level input from Surface Book's Pen and inner "3D-Coat" settings please use this test: http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip At any moment this test shows does "3D-Coat" receive low-level input with pressure from Surface Book's Pen. This application is the engine of "Tablet Pen" input used by "3D-Coat". The input is not affected by any "3D-Coat" settings and therefore the test shoes is the problem with pen caused by low-level input (i.e. by driver) or by inner "3D-Coat" settings. As you mentioned the pressure is receiving correctly: "When I use the suggested Pen pressure Test tool, the Pen gets recognized as Left Tablet Button, pressure is around 300, when I just press it soft and up to 600 when pressing hard." Then at any moment you can rename/delete/backup (if you have created some scenes already) your user data folder "This PC > Documents > 3D-CoatV47" to see how any brush reacts on pressure using default inner "3D-Coat" settings on default models. This way will help to debug specific brush (because your custom settings will not affect on behavior).
  22. Please install optional WinTab driver for "Surface Book" (files "Wintab_x32_1.0.0.20.zip" or "Wintab_x64_1.0.0.20.zip"): https://www.microsoft.com/en-us/download/details.aspx?id=49497 Also we have separate Pen pressure test which is the engine of "3D-Coat" tablet input. It shows does the pen send pressure information to the application: http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip
  23. Please install optional WinTab driver for "Surface Book" (files "Wintab_x32_1.0.0.20.zip" or "Wintab_x64_1.0.0.20.zip"): https://www.microsoft.com/en-us/download/details.aspx?id=49497 Also we have separate Pen pressure test which is the engine of "3D-Coat" tablet input. It shows does the pen send pressure information to the application: http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip
  24. Please install optional WinTab driver for "Surface Book" (files "Wintab_x32_1.0.0.20.zip" or "Wintab_x64_1.0.0.20.zip"): https://www.microsoft.com/en-us/download/details.aspx?id=49497 Also we have separate Pen pressure test which is the engine of "3D-Coat" tablet input. It shows does the pen send pressure information to the application: http://www.3d-coat.com/~sergyi/Tests/3D-Coat-Pressure-Test.zip
×
×
  • Create New...