Jump to content
3DCoat Forums
SeekerOfWisdom

Painting across seams is not smooth?

Recommended Posts

When painting on a smaller scale, there does not appear to be smooth painting going over my seams. They are getting in the way and its like impossible to paint over them.

 

Notice the visible seam in the following pic when trying to paint over it: 

 

 

qcznlWk.png

 

 

775H2Nx.png

 

 

 

Also why is the quality so jagged? The same happens to my textures even when using 4k maps, also I set the project UV set to 4k too.

 

Using per pixel painting on a low poly mesh, tried different uv's and brushes, texture size is 4k and looks perfect in photoshop

Share this post


Link to post
Share on other sites

Hi !

Are you using the version 4.5.20 ?

Share this post


Link to post
Share on other sites

Hi !

Are you using the version 4.5.20 ?

 

I am using the 4.5.16 trial (Planning on buying full version if I can get this worked out!) 

This stuff shouldn't be happening right? Should I try to download 4.5.20 somehow? Thanks!

Share this post


Link to post
Share on other sites

Sure its just a simple pants model I retopo'd, tried making different types of uv's in 3d coat and both maya, issue still persists.

Something odd though is when painting in mudbox it paints over the seam smoothly, and displays fine in maya, BUT
inside unreal engine the seam becomes visible with the same display problem as 3dcoat. So I guess 3dc is more true to what unreal is,

Either way what could be the problem? Are my uv's not proper even though I tried many different ways?

 

Here is the model - 

https://www.dropbox.com/s/kqk96vo6uuxzikz/pants1.obj?dl=0

Share this post


Link to post
Share on other sites

I will check the model out but it might be tomorrow before I can get back here to post... Thanks for uploading the model...

Share this post


Link to post
Share on other sites

It's an accuracy issue with the padding algorithm 3DC uses thats been around for a very long time. It can easily be seen on any of the default meshes by painting a thin strip of paint over a seam with texture filtering turned off.

Edited by PolyHertz

Share this post


Link to post
Share on other sites

I can reply the same result pushing the zoom in to the display limit

post-10142-0-76322700-1446599049_thumb.j

 

post-10142-0-90604200-1446599048_thumb.j

 

My preferences padding is 64

Share this post


Link to post
Share on other sites

Thanks for taking a look! A few questions-

 

Where can I find this padding preferences? 

 

What about the jaggedness of the lines and how pixelated they look when painting that small, is this normal? Or does it rely on the mesh topology / resolution? 

 

And a question about uv seams in general- Is it not really possible to completely hide a seam? Painting over it will still be a bit notice-able in a game engine like unreal if you look close to the texture? So even with this method, the only other way to go about it still is to place the seam cuts in hidden places?

As someone new to understanding UV's, this seems hard to do sometimes when you want to avoid stretching

 

I've started to examine game models and although some games have seams easily spotted everywhere, others I can sometimes not even find any seams!
Even on unclothed characters- Not on the inner leg, outer leg, inner arm, outer arm, back neck no where! How are they doing it?

Thanks very much for the help!

Edited by SeekerOfWisdom

Share this post


Link to post
Share on other sites

Edit > Preferences > General Tab > Padding Width

Share this post


Link to post
Share on other sites

I still seem to have this problem in 4.5.22.

 

TYSuIar.jpg

 

I placed a dot right on the symmetry line and unless I use symmetry I get an artefact even though the UV's are mirrored. Is there a setting / something I'm missing.

 

Cheers

 

Greg

Share this post


Link to post
Share on other sites

I still seem to have this problem in 4.5.22.

 

 

I placed a dot right on the symmetry line and unless I use symmetry I get an artefact even though the UV's are mirrored. Is there a setting / something I'm missing.

 

Cheers

 

Greg

From my testing it appears to be a mirroring UV island bug...  Like you I get artifacts unless I have symmetry enabled...

Baked from the retopo using using PPP without a normal map...

 

This is a different problem than the original post...

post-518-0-43509900-1447621667_thumb.jpg

Edited by digman

Share this post


Link to post
Share on other sites

Not sure about a bug report... I do not have time to make detail bug reports but I did post in the beta thread and uploaded a simple 3DC file for others to test...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×