Jump to content
3D Coat Forums
sshadows

Softimage AppLink

Recommended Posts

Hi, all!

This is my addons for Softimage 2011x64 and 2010(x32&x64).

How to use Vimeo

Another video about some fixes and features Vimeo.

Give your feedback, if you have it.

UPDATE v1.2!

Its time for a new versions.

1. Improve export.

2. I have added algorithm to optimization of UV.

UPDATE v1.3!

1. Fixed bug of optimization of UV

2. Added checkboxes "Skip Import Dialog" (allows to skip import dialog, default options will be used) and "Skip Export Dialog" (allows to skip export dialog. Previous settings will be used)

3. Added line "Drop mesh in 3D-Coat as a curve profile [curv]"

4. During a creating materials (importing) with normal map - inverted green channel, not red.

Video Tutorial "How To Install Xsiaddon":

HiRes video http://narod.ru/disk/29842803001/SoftimageTo3DCoat_Applink_HowTo.avi.html.

AppLink_3DCoat_75.zip

AppLink_3DCoat_2010.zip

AppLink_3DCoat_2011.zip

AppLink_3DCoat_2012x64.zip

AppLink_3DCoat_2015

  • Like 1

Share this post


Link to post
Share on other sites

Thank you.

How can I see, which AppLink version is currently installed in Softimage?

Plugin Manager -> RMB on plugin -> Properties.

post-3858-0-97450500-1306855327_thumb.gi

Share this post


Link to post
Share on other sites

It doesn't seem to work with 3D-Coat 4.00 Beta 5. Is there an update coming?

Right now it exports, launches 3D-Coat & then nothing happens.

Thanks,

Paul

Share this post


Link to post
Share on other sites

It doesn't seem to work with 3D-Coat 4.00 Beta 5. Is there an update coming?

Right now it exports, launches 3D-Coat & then nothing happens.

Thanks,

Paul

Actually it should work.

Don't forget to set the right 3D Coat "Exchange path" inside the softimage plugin. Additionally you can set the new path for the application too. Then 3D Coat will be opened automatically.

The default values are set to 3D Coat V3 in the last AppLink.

Best wishes

Chris

EDIT: The pathes seems to be set. The data is there too, and 3D Coat 4 will be opened. But nothing happens anyway.

Share this post


Link to post
Share on other sites

I am loosing some of my windows positions, when using the current app link in BETA 12. Is there something wrong?

Share this post


Link to post
Share on other sites

Hello,

thanks for the video!

Anyway, I have problems getting the model back from 3DC to Softimage. The menu item "File > Open in original app" is greyed out. When I click it, I get the warning "You are using the non-commercial version...".

Since this is nonsense because first I am a registered user, and second, I can export when I start modeling in 3DCoat, I guess that there might be another problem, with the applink maybe?

Any tips?

Thanks,

Eugen

 

Edit:

Ok, I figured that it works with "Per-pixel painting", but not with "Micro-Vertex painting".

Not too intuitive, the whole thing.

Edited by Tupaia

Share this post


Link to post
Share on other sites

Hello,

thanks for the video!

Anyway, I have problems getting the model back from 3DC to Softimage. The menu item "File > Open in original app" is greyed out. When I click it, I get the warning "You are using the non-commercial version...".

Since this is nonsense because first I am a registered user, and second, I can export when I start modeling in 3DCoat, I guess that there might be another problem, with the applink maybe?

Any tips?

Thanks,

Eugen

 

Edit:

Ok, I figured that it works with "Per-pixel painting", but not with "Micro-Vertex painting".

Not too intuitive, the whole thing.

Try to click any page and the get back. It is probably refresh problem.

Share this post


Link to post
Share on other sites

Are there going to be any updates to this AppLink?

 

I'm having a problem where no matter how many times I change it, the Exchange Path and 3D-Coat Location always revert to V3 instead of V4.

 

Thanks,

 

Paul

Share this post


Link to post
Share on other sites

"I'm having a problem where no matter how many times I change it, the Exchange Path and 3D-Coat Location always revert to V3 instead of V4."

this problem has a solution?

Share this post


Link to post
Share on other sites

No. Unfortunately there were no plugin updates since the release of v4. Correct me please, if I am wrong.

Share this post


Link to post
Share on other sites

 

"I'm having a problem where no matter how many times I change it, the Exchange Path and 3D-Coat Location always revert to V3 instead of V4."

this problem has a solution?

 

Hi! Explain me more about issue. Recorded video or seq images how to repeat your steps..

Share this post


Link to post
Share on other sites

New update is out.

 

1. Addons for XSI 2014 and 2015.

2. Improved autocomplete PPG on raised. Now avalable folders for 3DCoat V3 and V4.

3. Exported object saved by path "XSI_PROJECT\\SCENE_NAME\\OBJECT_NAME".

 

Enjoy.

  • Like 1

Share this post


Link to post
Share on other sites

Who have a problem with download and install xsiaddon, I repacked addons. Now you need download 7z-file, unzipping and install.

  • Like 1

Share this post


Link to post
Share on other sites

I'm still using XSI! ^_^

Cos it's an amasing tool. 

Softimage and XSI are a beautiful couple and supply each other so well.

Xsi does modeling and animation and 3D coat makes UVs sculpting and textures. That's amasingworkflow. Thanks for Applink developers for making these pieces of software that are in love closer.

My question is that Applink exports model inside 3D coat well but when push button "import from 3D Coat" it says "Import file not found". How to deal with this?

XSI 2015 SP2 3D Coat 4.8.23

Edited by Talik

Share this post


Link to post
Share on other sites

Don't forget to set the right 3D Coat "Exchange path" inside the softimage plugin. Additionally you can set the new path for the application too. Then 3D Coat will be opened automatically. 

https://github.com/sshumihin/3DCoat_Applinks/tree/master/Applink_SoftimageXSI

Share this post


Link to post
Share on other sites

Thanks for quick reply.

Since I use "Open in original App" inside 3D Coat it imports geometry but no materials. Textres are not connected to material and are not imported via Applink. How to make this happen?

As I use "Open in original App" inside 3D Coat" there is no mental ray preset to export textures. I use 3ds max Arch&Design.

Do I need to assign mental ray material first before importing from 3D Coat?

Edited by Talik

Share this post


Link to post
Share on other sites

You need to create mentalray constructor settings.

Remember mentalray EOL was november 2017.

And mentalray is NON-PBR. 3DCoat is PBR based, so there is no compatibility between apps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×