Jump to content
3DCoat Forums
Sign in to follow this  
3DNut

3D-Coat Applink for Blender Workflow Help Needed.

Recommended Posts

I have the 3D-Coat Applink Add-on installed in Blender. What I can't figure out is what is the next step after I have my model selected and I am in the Properties Editor>Scene Panel>3D-Coat Applink? I can press "Transfer" all day long but 3D-Coat doesn't open. If I have 3D-Coat open and I press "Transfer" then nothing happens either. If I am supposed to import something into 3D-Coat manually then where is the folder that the 3D-Coat Applink Transfer button is saving to, for me to do that? I have watched the following recommended video on the Add-ons documentation page.

 

 

However, the video seems to be missing this critical information. Can anyone help me out and give me a workflow on how to use this to get and object from Blender to 3D-Coat and back again with minimal hassle using the 3D-Caot Applink in Blender.

 

Thanks in advance for your help,

Bryson

Share this post


Link to post
Share on other sites

That answers the question about what my applink options are, but that doesn't really answer my specific question. I am asking about how to actually use the Official version. If I can't get anywhere with that then I will have to try Simple3DCoat applink. Thanks for trying to help.

Edited by 3DNut

Share this post


Link to post
Share on other sites

I don't know what is going on. I disabled the official 3D-Coat Applink Addon because I can't get it to work and I have spent quite a bit of research time online trying to get my question answered. I downloaded, installed and enabled Simple 3D-Coat Applink, set the exchange folder, saved user settings and that one doesn't even show up in the Scene panel.

 

Are there any Blender / 3D-Coat users on this forum that actually have experience with either of these Applinks working? Can anyone confirm that they are working with Blender 2.74 and 3D-Coat 4.5? I don't know why this is so hard.

 

 

..Update...I am on the Simple 3D-Coat Applink thread and it appears that the settings were moved from the Scene Panel to the Tool Shelf. Once I get this all figured out I am going to make a tutorial so that no one else has to go to this much effort to get these things working. I would still like to know if the Official version works though, which was the intent of this thread.

Edited by 3DNut

Share this post


Link to post
Share on other sites

I cant confirm it.

I use Blender 2.71 with the Applink (0.3.2) and it works without problems as far as i see.

Share this post


Link to post
Share on other sites

Hi Bryson!

 

I assume that you are using v3.5 of 3d-coat. It moves program folder into new  I will update this into script. I you want test it right now here is rar file and unzip 

and replace the file from Blender->2.74->scripts->addons->io_coat3D with this one. I haven't look into the script for long time but I hope this helps to fix the problem you have. 

 

Greetings

 

coat.rar

Share this post


Link to post
Share on other sites

I've just tried this new version of the script. Os X 10.9.5 3DC 4.5 Blender 2.74.

 

The panel is showing in Blender OK but doesn't seem to talk to 3DC.

Share this post


Link to post
Share on other sites

I cant get it to work either 3dnut. I wonder if it has anything to do with the dx and gl versions of 3dcoat. Sure hope this gets figured out soon. I'm getting frustrated.

Mike

riverdog

Share this post


Link to post
Share on other sites

All applinks for 3D-Coat create a input.obj and import.txt withing your specified documents folder.

A number of applinks stopped working with the realease of 4.5 because the documents folder changed from 3D-CoatV4 to 3D-CoatV45. So check to make sure its pointing to the right folder, and if so that files are actually being created there.

 

That's assuming you're running Windows though. No idea where applinks send files on Mac or Linux.

Edited by PolyHertz

Share this post


Link to post
Share on other sites

Are you attempting to send a 3D-Coat object to Blender?  I have found that you have to send something from Blender to 3D-Coat first to get it to work.  It doesn't look like mifth has the time or maybe he abandoned the applink?   I don't use the applink anymore, just too many issues.  :(

Share this post


Link to post
Share on other sites

I am using it in Blender 2.76b  and 3dcoat ver 4.5.03  .   I am using the Simple 3D coat applink  ver 0.3.2  as stated above your  Exchange Folder: has to be  3d-coat V45\Exchange .  it is working fine both ways for me on win8 .1 machine.

Share this post


Link to post
Share on other sites

Double checked it to be sure.  I'm running version 0.3.2 of the simple 3D-Coat plugin, Blender version 2.76b, and 3D-Coat version 4.5.20.  The exchange directory is set correctly, but I can only transfer from Blender to 3D-Coat.  It doesn't matter in what order I start both apps.  Once I move an object from Blender to 3D-Coat I get the "open in original app" menu item, but not the other way.  I have no "File menu / Export to / Blender" menu option.  :(   If it works on Windows than it must be broken on Linux.   :wacko:

Share this post


Link to post
Share on other sites
Sign in to follow this  

×