Jump to content
3DCoat Forums
mifth

Blender Applink "Simple3DCoat" (Fork of the official)

Recommended Posts

Yes its there but shorter as in just Export type (DROPDOWN) list and 2 buttons Update and Transfer. All the rest that use to be there is gone as in / apply modifiers,texture path,export type, im thinking I need to set the exchange folder to 4.5.03a ? IN 3DCOAT there use to be a option when the app-link was set in the drop down list under file I think to send it over. As long as I know the app-link works with these 2 versions I will keep at it. Thanks for your time Carlosan 

Share this post


Link to post
Share on other sites

Yes its there but shorter as in just Export type (DROPDOWN) list and 2 buttons Update and Transfer. All the rest that use to be there is gone as in / apply modifiers,texture path,export type, im thinking I need to set the exchange folder to 4.5.03a ? IN 3DCOAT there use to be a option when the app-link was set in the drop down list under file I think to send it over. As long as I know the app-link works with these 2 versions I will keep at it. Thanks for your time Carlosan 

I think you enabled the official addon. You need to enable Simple3DCoat addon from here https://github.com/mifth/mifthtools/tree/master/blender/addons/io_simple_3dcoat

Share this post


Link to post
Share on other sites

do I have to sign up at github in order to copy the simple_coat.py   and yes I have the official add-on so I will uncheck it and do this one thanks mifth for your time helping.

Share this post


Link to post
Share on other sites

Using Blender 2.75A , 3DCOAT 4.5.07  Mesh for Auto retopology crashes 3DCoat.

Share this post


Link to post
Share on other sites

do I have to sign up at github in order to copy the simple_coat.py   and yes I have the official add-on so I will uncheck it and do this one thanks mifth for your time helping.

https://github.com/mifth/mifthtools - you can download zip archive at the right corner. See the big button.

Using Blender 2.75A , 3DCOAT 4.5.07  Mesh for Auto retopology crashes 3DCoat.

Possibly this is 3DCoat issue.

Share this post


Link to post
Share on other sites

It appears to be pulling up an older Retopology. There also is no option for Hardsurface Retopology. It is referencing and older 3Dcoat version.

Share this post


Link to post
Share on other sites

It appears to be pulling up an older Retopology. There also is no option for Hardsurface Retopology. It is referencing and older 3Dcoat version.

Should I remove something from the addon or fix it?

If yes, just describe it please more. :)

Share this post


Link to post
Share on other sites

ok I downloaded and unzipped mifthtools  thanks  now in blender I go to addons  from file and go to io_simple_3dcoat  there are 2  _init_.py and simple_coat.py  are both the same I tried both but no go for the add-on.thanks for your time on this.

Share this post


Link to post
Share on other sites

The app is using an older 3dcoat retopo. The newer 3dcoat has an option for hard surface retopo.

 

The retopo  either needs to be fixed or removed from the app.

Share this post


Link to post
Share on other sites

Is 3DC issue

 

the 3D-Coat applink addon call the old retopo routine, and crash 3DC too.

 

Some specifications change on 4.5

Share this post


Link to post
Share on other sites

@Ballistic_Tension you need to copy the entire forlder "simple_3dcoat". Not a separete py file.

 

@carlosan @Britain there was changed the specification? Just let me know when i need to remove something. :)

Share this post


Link to post
Share on other sites

@ mifth  There could be other painting imports ( per pixel painting for one) crashing 3dcoat also. Carlosan  would know more on the changes.

 

Real cool Miratool and mifthtool thanks for those!


umm per pixel painting started working.....

Share this post


Link to post
Share on other sites

Hey Britain the app link works for me in per pixel painting sometimes I need to hit the Export 2-3 times in blender to get it in 3dc side. I cant transfer any color info/material from blender over to 3DC it says its a UV set name.3DC into Blender works fine the 3 texture maps are named KD=color  KS=spec  and  Bump  . Can you get the color /mat  from blender over to 3dcoat or no? thanks.

Share this post


Link to post
Share on other sites

Yes the paint works need to refresh a few times.

Share this post


Link to post
Share on other sites

Hello, I'm working on a Mac and I'm having troubles with the exchange folder too. Instead of appearing in the addon section (user preferences) the line for input of exchance folder it appears in the properties pannel. And the moment I want to input the : EXCHANGE FOLDER it disappears.

Is there an other way around ?

Share this post


Link to post
Share on other sites

Hello, I'm working on a Mac and I'm having troubles with the exchange folder too. Instead of appearing in the addon section (user preferences) the line for input of exchance folder it appears in the properties pannel. And the moment I want to input the : EXCHANGE FOLDER it disappears.

Is there an other way around ?

Try to open a path with this button:

jjBzVGX.png

 

It must be absolute path.

Also, update blender.

Share this post


Link to post
Share on other sites

ok I tried the FBX fix but Im not sure its in blender is it the same version # 0.3.2  I still have the ui in tools and not in its own tab in blender.i try to export from blender it give me a Traceback (most recent call last)! up top. I tried twice. Also I still don't get any Color material from blender over to 3dc is that normal . when I use obj. from blender to 3dc per pixel paint. mmmmm    im going to try it one more time  mifth tools master  here I come...

Share this post


Link to post
Share on other sites

ok I just had to in Blender  uv unwrap and bake the textures then i pack image (png) then export as obj and I get my colors and its own layer over on 3dc side so I have part of my problem done.

Share this post


Link to post
Share on other sites

Hello, I am using windows 7 pro and I installed simple 3d coat from the link on the first page, I set an exchange folder in the 3d coat 4.5 folder in program files, I installed the addon while setting the exchange folder in the path, but when I press export object i get an error "access denied", please help^^

 

post-38882-0-20468400-1441478372_thumb.p

post-38882-0-20468400-1441478372_thumb.p

Edited by Arkanis Gath

Share this post


Link to post
Share on other sites

Hello, I am using windows 7 pro and I installed simple 3d coat from the link on the first page, I set an exchange folder in the 3d coat 4.5 folder in program files, I installed the addon while setting the exchange folder in the path, but when I press export object i get an error "access denied", please help^^

 

post-38882-0-20468400-1441478372_thumb.p

You should have the Exchange folder in User folder. Just check your User\Documents folders.

Share this post


Link to post
Share on other sites

ok I tried the FBX fix but Im not sure its in blender is it the same version # 0.3.2  I still have the ui in tools and not in its own tab in blender.i try to export from blender it give me a Traceback (most recent call last)! up top. I tried twice. Also I still don't get any Color material from blender over to 3dc is that normal . when I use obj. from blender to 3dc per pixel paint. mmmmm    im going to try it one more time  mifth tools master  here I come...

Could you give me full Traceback message?

Share this post


Link to post
Share on other sites

I get 2 one up top starts with a  !  c:\programfiles\BlenderFoundation\Blender\2.75\Scripts\addons\io_Simple_3Dcoat.py".Line147,in invoke [] bpy.ops.export_scene.fbx (check_exsiting=True,filepath=model export path,filter_glob=*.fbx,version='Bin7400',use_selection=globel_scale=1.0axis forward=Z axis up = Y Bake_space_transform=False,object types={MESH}-,U

 

AND at the same time in the middle of screen in black overlay    =1.0 axis_forward=Z axis_up=y,Bake_space_transform=false,object_types={MESH} use_mesh_modifiers=simple3dcoat,do apply modifiers,mesh_smooth_type.=Face,use_mesh_edges=false,use tspace=false,use_custom_properties=false,usearmature_de...

 

I load in the fix for fbx but its not in its own tab// UI as you say it should be meaning it seams as if it didn't load in  .thanks for your time .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×