Jump to content
3D Coat Forums
haikalle

Blender Applink

Recommended Posts

I have updated the applink script and you can test it out.  Builds after (Build Oct 29 2018 02:15:29) will inlcude updated script. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for testing.  There was some issues with 3dc->blender workflow and I have send the fixes into blender2.8 code. Build after Nov 8 2018 01:30:04 will include these fixes. 
Other thing I see from your screenshot is that you have exported .obj file. For now use only fbx file. I will add obj support at some point but in testing phase fbx support only. 
But thanks again for support and please let me know if there is other issues coming on your way.

Edited by haikalle

Share this post


Link to post
Share on other sites

Hello, I export metal material from 3d Coat to Blender, but in Blender it is displayed incorrectly as a dark surface, the picture looks very different metal in 3DCoat and as the same metal looks in Blender. You may be able to make a mapping match because it looks like a 3D Coat.

Screenshot_4.jpg

Screenshot_5.jpg

Share this post


Link to post
Share on other sites

Thanks for reporting this. It seams that 3d-coat creates too dark diffuse color. I'm not quite sure is this bug of my script or 3d-coat. I ask about Andrew's help and let you know when this issue is fixed.

Share this post


Link to post
Share on other sites

More then likely you just need to adjust how your script handles the map gamma (The Max applink materials all take gamma into account to avoid this issue).

Share this post


Link to post
Share on other sites

shot1.thumb.jpg.bb534a98954afcf782727ec5c765a0a7.jpgshot2.thumb.jpg.397983f1bb851fcf5583cecddc2a2ca5.jpg

There is something else than gamma. If I export color texture using default Export presets everything is okey, but if I change it into Blender/Cycles preset 3d-coat creates bad color texture.  Other thing that I would like to fix is that when
I change preset. I'm not able select default preset anymore. I like simple setup of default preset but to get it back I have to delete my 3d-coat folder from documents. 

Edited by haikalle

Share this post


Link to post
Share on other sites

Did some more testing and it seams that right diffuse map is created only if you have default preset. If you select another preset then diffuse map is wrong. Hope Andrew could take look at this.

Share this post


Link to post
Share on other sites

After exporting from 3 D Coat to Blender, the texture is no longer similar to metal, you need to rebuild the entire system of nodes and textures that are exported from 3 D Coat can only be used to customize the nodes in Blender to recreate the likeness of metal. If you take your advice, the texture is exported light but it still doesn't look like the visual point with the image in 3 D Coat. Perhaps the reason is different shaders, shaders in 3 D Coat and Blender are very different, also in the texture of the environment and mastering. Ideally, it would be if the export occurred with minimal changes in visual perception.

Share this post


Link to post
Share on other sites
4 hours ago, haikalle said:

Did some more testing and it seams that right diffuse map is created only if you have default preset. If you select another preset then diffuse map is wrong. Hope Andrew could take look at this.

Make sure to send him a message (support@3dcoat.com) about it, as he doesn't frequent this forum that much and may not see it.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Alex_Velger said:

After exporting from 3 D Coat to Blender, the texture is no longer similar to metal, you need to rebuild the entire system of nodes and textures that are exported from 3 D Coat can only be used to customize the nodes in Blender to recreate the likeness of metal. If you take your advice, the texture is exported light but it still doesn't look like the visual point with the image in 3 D Coat. Perhaps the reason is different shaders, shaders in 3 D Coat and Blender are very different, also in the texture of the environment and mastering. Ideally, it would be if the export occurred with minimal changes in visual perception.

Hi! I did some testing and I used default preset for now because there is issues if you use any other preset. But my tests I have done, the likeness is quite good in my mind.

testing1.thumb.jpg.de61bccfa613864f338a8cfa871665ec.jpg

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi, thanks for your plugin. Decided to use for testing a more complex model, and identified a few errors that appear periodically and I have the second day I can not understand why this is happening, many options have been tried. I'm sending you a file and screenshots.

Screenshot_9.thumb.jpg.597229c37f474524cd70b3d81124033b.jpg

Screenshot_10.jpg

Demo.blend

Screenshot_11.jpg

Screenshot_12.jpg

Screenshot_13.jpg

Share this post


Link to post
Share on other sites

Thanks for you both it's very useful feedback.

CristophLE: I will take a look what's happening...

Alex_Velger: First thing is that remember to check "Treat material as separate textures" . I will take a look your blend file right now and see if there is something else odd.

shot3.thumb.png.3e6bce927194d89ec2f08f84a5de7afe.png

Share this post


Link to post
Share on other sites
27 minutes ago, haikalle said:

Благодаря вам и это очень полезно обратной связи.

CristophLE: Я буду смотреть, что происходит ...

Alex_Velger: Первое, что не забудьте проверить «Treat материал в виде отдельных текстур». Я буду смотреть файл смешивания прямо сейчас и посмотреть, если есть что-то еще странно.

shot3.thumb.png.3e6bce927194d89ec2f08f84a5de7afe.png

 

Screenshot_3.jpg

Share this post


Link to post
Share on other sites

Alex: Could you please and download the rar file and reaplace io_coat3d folder from blender2.8/2.80/scripts/addons. This version should fixes the problems you have.

ChristophLE: There seams to be some kind of problem when applink tríes to read texture list from texture.txt. Could help me that you could show what is inside of your texture.txt
(founded Documents/3d-coat/Exchange folder) So after you have done "Open in Original App" show what you textures.txt looks like.

io_coat3D.rar

Edited by haikalle
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×