Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

Has anyone experienced PBR Material Preview showing preview that is completely different from the actual result?

post-12523-0-72474100-1425387219_thumb.j

Share this post


Link to post
Share on other sites

More in Cavity & More in Convex don't seem to use any 'Depth' that you paint into layers.  It only takes model and Normalmap[ext] into account when calculating these modes.

 

I think the same actually applies to Less on Concave, Less on Convex, More on Flat & More on Curved.

 

This bug essentially breaks my workflow for using these modes.

Share this post


Link to post
Share on other sites

sorry im asking this, the pic is cropped at right...

metalness value is at 100% right ?

Share this post


Link to post
Share on other sites

Has anyone experienced PBR Material Preview showing preview that is completely different from the actual result?

attachicon.gifpbr_material_preview_problem.jpg

Looks like it's not the PBR Material Preview's fault. It seems to show the desired result. But if I start brushing with More on Flat or More on Curved (or use them somewhere inside a PBR material), 3D-Coat completely ignores them. Painting with More on Flat is like painting with Always condition and painting with More on Curved doesn't produce any results.

 

Ghib, yeah I don't have a normal map.

Less on Concave, Less on Convex - both work OK. Maybe you meant More on Bump / Dent? They are the ones that require some form of height/normal information and in their case nothing shows up in the preview. This leads me to believe that if 3DC is capable of showing a preview of More on Flat/Curved, then it is capable of calculating them without any normal/displacement (probably based off a curvature map), which means that those two conditions are currently broken.

 

sorry im asking this, the pic is cropped at right...

metalness value is at 100% right ?

Metalness of the currently selected tool is set to 0%. Metalness of underlying layers is 100%. But what does metalness have to do with conditions?

 

---

100% reproducible. Take the default robot model for PPP, select More on Flat or More on Curved and start painting. You don't even need to select a PBR material.

Edited by ajz3d

Share this post


Link to post
Share on other sites

I could be wrong but More/Less in Cavity used to work on any normal map you brought in AS WELL as any Depth you have painted on any of the layers.   Has this been changed recently?

Share this post


Link to post
Share on other sites

But what does metalness have to do with conditions?

 

Nothing, left image preview have metalness, right image painted dont.

Just asking trying to follow your workflow

 

//edit

is this metalness ? post-10142-0-55384100-1425395565_thumb.j

Share this post


Link to post
Share on other sites

I could be wrong but More/Less in Cavity used to work on any normal map you brought in AS WELL as any Depth you have painted on any of the layers.   Has this been changed recently?

If More on Bumped and More on Dents is just renamed More/Less in Cavity, then I think little changed (if anything), because they do work with normals or height, be it painted, baked or imported. :good:

 

But what does metalness have to do with conditions?

 

Nothing, left image preview have metalness, right image painted dont.

Just asking trying to follow your workflow

But... both sides have the same metalness levels (0%). :) Anyway, talking about metalness reminded me of a minor bug with metalness in PBR preview that I need to report.

Share this post


Link to post
Share on other sites
//edit

is this metalness ? attachicon.gifM.jpg

Those grey dots? They're underlying metallic layers peeking through the red paint layer's edge scattering map, so yes - they are 100% metallic. Everything red has 0% metalness.

Share this post


Link to post
Share on other sites

I opened 3D-Coat just a couple of minutes ago only to realize that I lost all content from the metals PBR materials folder. It was replaced by content from paints folder. :blink:

Contents of metal folder is nowhere to be found in 3DC.

post-12523-0-35418300-1425425959_thumb.j

 

I'm unsure of what can I do to bring those materials back... I had some custom made stuff there.

Edited by ajz3d

Share this post


Link to post
Share on other sites

you added a new folder or renamed an old one ?

Share this post


Link to post
Share on other sites

you added a new folder or renamed an old one ?

None of the two. :(

Well, I added a folder (decals), but it was some time ago, not immediately before I lost all of the metal materials.

---

I just looked up the %USERPROFILE%/Documents/3D-CoatV4/patterns/metals directory.

If 3DC stores materials in pbrm files, then I believe I can kiss my custom materials goodbye, because the metals directory contains the same .pbrm files as paints dir. And I only have a settings backup that is two-weeks old. :(

post-12523-0-58414100-1425430406_thumb.p

---

I ended up restoring the folder from the backup. Managed to get back two of my materials. Better two than none, I guess. Not that I had hundreds of them. :)

 

Do a backup of your 3DC's settings directory on a regular basis, guys. Especially when Beta testing.

Edited by ajz3d

Share this post


Link to post
Share on other sites

I opened 3D-Coat just a couple of minutes ago only to realize that I lost all content from the metals PBR materials folder. It was replaced by content from paints folder. :blink:

Contents of metal folder is nowhere to be found in 3DC.

attachicon.giflost_metal_materials.jpg

 

I'm unsure of what can I do to bring those materials back... I had some custom made stuff there.

I had this happen one time as well. I do not know what causes it at this time. The only thing I did was renamed a folder that I had created from Legacy to Stamps. The next time I opened 3DC, the same thing happen to me. with metals being replaced by the paints folder. I am not saying this was the cause, maybe it could be in renaming user created folders but I really have no idea... Latest beta version 12A.

Edited by digman

Share this post


Link to post
Share on other sites

Does Mask Texture from the PBR Material Editor work? I linked up a grayscale image, but it doesn't have any effect on any of the channels.

Share this post


Link to post
Share on other sites

It should mask out that materials layers entirely. But there was a bug a few builds ago that had the channel names criss-crossed with the actual functions. Maybe that is happening again?

Share this post


Link to post
Share on other sites

just a quick question - how do you make material bump visible? I can see it on the small preview window but not in the viewport.

Finally had a time to boot windows and play with 3D Coat a tad - pbr and viewport improvements are so nice I finally got out of voxel room and tried some painting :) .

Share this post


Link to post
Share on other sites

It should mask out that materials layers entirely. But there was a bug a few builds ago that had the channel names criss-crossed with the actual functions. Maybe that is happening again?

It may be. I didn't experience the bug that you mention here, but it's likely that something similar is happening.

 

Thanks!

For now the workaround is to use both: material and a stencil at the same time, with transform options set to Transfer stencil & PBR mat. Both of them must be initially Reset in order for their alignment to be correct.

Share this post


Link to post
Share on other sites

Still getting seams all over my models. I did some trouble shooting. its real strange in that when i broke up the model (deleted parts just so it wasn't a complete finished asset ) the seams became far less visible.  Mantis report with images of my process and issues below.

 

http://3d-coat.com/mantis/view.php?id=1808

Share this post


Link to post
Share on other sites

BETA13

- Finished render room update, rendering using panorama lights supported!

- Undo lag on highpoly objects fixed

- Fixed problem of "parasite" background transparency inside semitransparant controls/guides in incremental render mode.

- Possibility to open Autosave directly from File menu.

- UV mapping currected, v-direction flipped

- Blur/sharpen panorama control in navi bar

- Color transformations will not be applied to normalmap layer in "Apply to al" mode.

- Crash related to vertex painting and undo fixed.

- Space panel size decreased even more.

- Problem of saving Vox Hide hidden data solved. How all may be restored after reopening the scene.

- Broken small-scale curves problem fixes

- ggx supported very well!

- Export of AO/curvature in unified export dialog

- Draw on plane option got additional constraints - XY,YZ and ZX planes.

  • Like 3

Share this post


Link to post
Share on other sites

I didn't test the beta yet but:

 

Blur/sharpen in navbar is a really nice idea. Countless time I had to detach the menu to get it multiple time (the menu closed when hit once) and I had to avoid moving the mouse too far away from menu or it would disappear again.

This is much more practical especialy since localized keyboards don't always work well with the shortcuts (default one doesn't work on azerty keyboard with alternate needed to call the character) for instance.

Share this post


Link to post
Share on other sites

BETA13

Thats awesome! But wait, month after month goes by and still no Mac/Linux versions?  :( We're starting to feel a little abandoned, just a teeny-weeny tiny little bit..

Share this post


Link to post
Share on other sites

- Paint Room

freeze tool

 

the mesh is freezed but no display freeze zone.

(sculpt > surface mode, freeze is ok)

Share this post


Link to post
Share on other sites

×