Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

Excuse me please if I am spamming, but:

 

PLEASE PLEASE PLEASE!!!

The pen size (radius) have NOT to have ANY influence on the PBR Material depth amount!

 

This is really a "no go" and workflow destroyer. When I set a depth in a PBR material, then I want to use this depth and not a factor of a pen radius...

 

Andrew are you so kind and explain me, why the pen radius has influence to the used depth information?

Why this two complete independent options are linked together?

 

I thought a pen radius is an "area" that define the paint influence. And the depth is the information for the used normalmap or sculpting depth of the pen tool I use...

 

I don't understand this.

 

The depth should not be a % value of a pen factor. Proposal: Use understandable values like 1 or 2 or whatever like in the pen tool for the depth value. And not a number like 100 % for the depth and you will have a lot of friends... I am not able to explain my students why a depth value is influenced by several(!) other values that all are linked in some way together.

 

We have two radius values. Nobody really understand this. A radius for the pen tool and a radius in the fill tool... and the pen tool radius influence the fill tool additionally, but sometimes only... completely confusing.

 

I am posting this, because I already had a lot of situations, where the pen radius influence made me crazy and I lost time to find why a PBR material was not filled like expected or why my pen depth was not the set material depth. By the way: The same for the texture projection: Reset it, when the user has clicked on a PBR slot (only then).

 

Thank you. And sorry again, but this two points kills my workflow at the moment and I am a bit frustrated...

There is LOCK icon on the top to keep absolute depth of carving independent on pen radius.

By default the depth is some % of pen radius, so changing pen radius leads to changing depth. LOCK solves this.

Share this post


Link to post
Share on other sites

Thank you for the hint.

I will prepare a proposal that could make the lock icon obsolete and make the system much more understandable for artists.

Share this post


Link to post
Share on other sites

My above post, just to be clear was not related to the depth lock icon which I already knew about.  

 

What Javis mentioned here is true:

"Only the depth controller on the top bar and the SMats own depth settings should ever control this." 

 
The problem resides in the below.

I found a difference in how the fill tool was calculating the depth compared to the regular brush which is set at the same depth and brush radius when using a smart material.

 

I did some testing because of Taros mentioning some problems with the fill tool...

Edited by digman

Share this post


Link to post
Share on other sites

create an individual thread for this topic

 

i suggest yes to be more clear and dont mix topics

 

ty !

Share this post


Link to post
Share on other sites

I've been investigating about linear workflow and whether 3d coat supports different color spaces settings inside the viewport (it seems it doesn't)

 

Now in the latest beta version (18.01.2016) a setting was added that applies gamma automatically to textures when exporting!

 

That made me wonder, maybe this is the solution already and the whole viewport color space settings aren't actually needed....

In other words, I ask myself whether there's a difference beween

 

* painting in the standard (probably sRGB) viewport - pretending it's the colors as rendered - and then linearizing when exporting (like is possible now)

 

and

 

* Having a gamma corrected viewport, gamma corrected color pickers, drawing linear textures directly.

 

Maybe this isn't necessary - the difference is just about imported textures - could it be true?

Share this post


Link to post
Share on other sites

Strange issue: when selecting a smart material with a tiled texture and filling the object using the rectangle lasso, the texture is applied extremely blurred. When painting using a brush, the texture is applied in the correct high resolution. After painting with the brush, using the ractangle lasso to apply the material works also in the correct resolution.

 

When restarting 3DCoat and re-opening the scene, the same problem occurs again (it does not when closing the scene and re-opening it without closing 3DCoat). Only after painting the selected smart material onto the object using a brush makes the rectangle lasso method work again.

 

Same problem appears with right-clicking the smart material -> Fill whole layer.

Edited by wilson66

Share this post


Link to post
Share on other sites

Do someone have an idea what this could be the reason for? I used a smart material.

Plugged the bumpmap/depth map into the depth channel of the smart material.

 

For me it looks like 3D-Coat reduce the colors or do something with the contrast. There must be a bug in the normalmap conversion from rgb images.

 

@Andrew: Have attached a screenshot and the bumpmap for testing.

post-955-0-41508600-1453380027_thumb.png

post-955-0-75794400-1453380180_thumb.jpg

Share this post


Link to post
Share on other sites

Do someone have an idea what this could be the reason for? I used a smart material.

Plugged the bumpmap/depth map into the depth channel of the smart material.

 

For me it looks like 3D-Coat reduce the colors or do something with the contrast. There must be a bug in the normalmap conversion from rgb images.

 

@Andrew: Have attached a screenshot and the bumpmap for testing.

I tested and works on my end... no stair casing...

version 4.5.28 non cuda 64 bit---GL

post-518-0-04140800-1453401926_thumb.jpg

Edited by digman

Share this post


Link to post
Share on other sites

I tested and works on my end... no stair casing...

version 4.5.28 non cuda 64 bit---GL

Is this the paint room and a normalmap? I am talking about the paint room and smart materials. Maybe I have used a too big depth value? But why this still happen? The greyscale image should deliver enough steps. Strange.

Share this post


Link to post
Share on other sites

Paint room for PPP, 

Created a simple smart material set depth to 100%

Top tool panel depth was set to 100% as well.

greyscale put into the depth channel of the smart material for creating the normal map.

Used the fill tool and handpainted as well.

No stair casing...

Adjusting the depth % in the layers panel also does not create staircasing.

 

Setting the depth precentage to 117% as shown in your picture produces the staircasing. 

" Maybe I have used a too big depth value? But why this still happen?"  That is a good question and one that Andrew would need to answer.

 

EDIT: Closed and reopened 3DC, I just tried again and this time at 117% depth produced no artifacts. I tested this twice each time closing 3DC, then creating a new scene each time. Maybe a random bug you found.

 

Close 3DC and reopen with a new scene. Use the default cube in PPP mode and see if there are no artifacts... If successful and no artifacts, then a random bug could be a possible...

Edited by digman

Share this post


Link to post
Share on other sites

There's some kind of bug with the pose tool where after deselecting the previously selected faces dissapear. Can anyone else confirm? It might be tied to the undo bug that's been floating around for ages?

Share this post


Link to post
Share on other sites

Paint room for PPP,

Created a simple smart material set depth to 100%

Top tool panel depth was set to 100% as well.

greyscale put into the depth channel of the smart material for creating the normal map.

Used the fill tool and handpainted as well.

No stair casing...

Adjusting the depth % in the layers panel also does not create staircasing.

Setting the depth precentage to 117% as shown in your picture produces the staircasing.

" Maybe I have used a too big depth value? But why this still happen?" That is a good question and one that Andrew would need to answer.

EDIT: Closed and reopened 3DC, I just tried again and this time at 117% depth produced no artifacts. I tested this twice each time closing 3DC, then creating a new scene each time. Maybe a random bug you found.

Close 3DC and reopen with a new scene. Use the default cube in PPP mode and see if there are no artifacts... If successful and no artifacts, then a random bug could be a possible...

What about your pen radius? I used one with the value of "1".

Thank you.

EDIT: Another answer could be my scene proportions. I am using an imported model. Maybe it was created very small in the 3D-Coat scene. My brush radius with the value of one is huge in compare to the model. The scene scale could be the reason.

Maybe we can talk about import scaling factors related to the used tools which could be set before importing a model? In a pop up window?

Of working with blender I know 3DCoats models are in blender 100 times bigger. So maybe blender models are 100 times smaller in 3DCoat. This could really be the reason. Check it later.

Share this post


Link to post
Share on other sites

@Taros... I used various brush radius... 1.00 as base so larger and smaller than that. There was no staircasing at any brush radius size. I forgot to add that information...

Edit:

Here is a 3DC file set to Blender's scale... at least for the sculpt room. You could test using this 3DC file.  the default 2 meter blender cube will import as a 2 meter cube into 3DC and export out the same. This is using the import without voxelization method. I mention this so you could test...

It would seem that the scale would carry over to the paint room as well but of course I have no solid accurate information on that.

Blender Scale Final.3b.zip

Edited by digman

Share this post


Link to post
Share on other sites

I will record a video what happen here as soon as I am back at homeoffice and have some time. Working for a client today.

 

Thank you digman

 

EDIT: By the way. I guess it was not the scene scale. The main reason is the very high depth value. The normalmaps are not normalized then and begin to be too high. Whatever. I will take a record.

Share this post


Link to post
Share on other sites

@Wilson: I guess you have changed the pen size in the meantime, after used the rectangle?

Or you have changed the projection scaling...

 

A lot of possibilities. Unfortunately...

 

But I am shure you have scaled the radius before used the pen and then used the rectangle again.

Share this post


Link to post
Share on other sites

Question: I was really shure there is an option in the UV room where I can just organise the uv islands WITHOUT scaling. Just arrange them beside each other. Or do I am wrong?!

Share this post


Link to post
Share on other sites

EDIT... removed my statements...

I thought PackUV by holding the down the ctrl key would not scale the uv-islands only reshuffle them. It can scale as well. I thought how it worked in the past there was with no scaling.

This is what I found now... You can hold down the ctrl key and reshuffle a few times without scaling, then on the next try it rescales the uv-islands

PackUV2, I know it re-scales but without rotation and this will not mess up your normal map.

 

Is this a bug? though my memory can fail me here, as I do not use these tools very often...

 

Sorry for all my edits...  :wacko:

Edited by digman

Share this post


Link to post
Share on other sites

@Wilson: I guess you have changed the pen size in the meantime, after used the rectangle?

Or you have changed the projection scaling...

 

A lot of possibilities. Unfortunately...

 

But I am shure you have scaled the radius before used the pen and then used the rectangle again.

Nothing was changed at all. Why would I post about this if I had done something obvious like changing the projection scaling?

Same problem happens on two different systems (and another artist I work with), so there is some kind of bug at work here.

Share this post


Link to post
Share on other sites

It looks like point hardness is not stored in .curves files.

Edited by ajz3d

Share this post


Link to post
Share on other sites

It looks like point hardness is not stored in .curves files.

Which room? Which tool have you used, please?

Share this post


Link to post
Share on other sites

Nothing was changed at all. Why would I post about this if I had done something obvious like changing the projection scaling?

Same problem happens on two different systems (and another artist I work with), so there is some kind of bug at work here.

No problems here... used camera projection, noise depth, rectangle and brush. All worked like expected with the default sphere in version 4.5.28.

Can you send me the smart material please? Would like to see what happen with yours.

 

And a step by step doc for reproduction please.

Share this post


Link to post
Share on other sites

×