Jump to content
3D Coat Forums
Andrew Shpagin

3DCoat 4.7 (BETA testing thread)

Recommended Posts

For latest collection only and in case you have any issues i reported to Andrew as well and we are looking on it.

 

-->

Something is not as preview versions of 3DC regarding  smart material package export.

Exported package is small in size and i had 2 complains saying that although settings in the materials are correct (they keep their values) and preview (small previews) are correct , some materials share the same texture.

 

Naming in all textures is the same , but i was making materials with the exact same way / naming of textures in previous collections with out any issues.

 

On my PC everything is working just fine

 

https://www.dropbox.com/s/z2389qkbzrf18dt/Previews.mp4?dl=0

 

I uploaded the textures on Gumroad so people can manually insert them in case they have this issue.

Edited by Michaelgdrs

Share this post


Link to post
Share on other sites

Version: 4.7.10

Zones of Control has a bug where you lose all your set zone of control spheres. I placed 30 zones of control twice and both times they disappear... I close 3DC, reopoen 3DC. Load the good file that had the zones of control and they are gone and any saved versions do not have them... 

Give us the ability to save a zone of control state just in case this happen, we can reload them as it is vital to a real production workflow. To place 30 or so zones of control spheres all over again is very time consuming.

Not quite a bug but if you placed zones of control, for example say 10... They are placed... You press ok and close the dialog box, then reopen and press cancel you lose all your placed zone of controls... This should not happen to the already placed zones of control. What is needed is a clear all box.  Right now we can do one at a time but that is time consuming. Cancel should just cancel the dialog box and not remove the placed zone of control spheres.

The above needs to be fixed asap as it is critical in a production setting.

 

Please fix the autopo soon, it really is not usable in it's present state for production work.. buggy, crashes, creates larger polygons where not needed and smaller ones where not needed. Painting density still does not work..  No need to go into specifics as all this has been reported in detail many times before.  

I know how to prepare the sculpt meshes for autopo to get a good result so I know that part of the work is covered correctly. 

If 3DC's autopo worked like "Instant meshes" but with density control both from the dialog box and painting, (already included) the 3DC tool would be fantastic... The guide strokes work as intended but the rest is still not ready for production work.

 

Edited by digman
  • Like 2

Share this post


Link to post
Share on other sites
19 minutes ago, Carlosan said:

Done. All the things I talked about fixed plus sorely needed for a long long time is uv settings per uv set / saving them not just a global one... The autopo really really working too... These would boost the production value of using 3DC in this area quite a bit... 

Share this post


Link to post
Share on other sites

4.7.11[beta]

- Primitives for retopo room. This is rather template than complete toolset. Only one primitive present there, list will be essentially extended in next update.

- Coat tool. This is non-destructive and precise version of VoxLayer. This is important step, it opens family of nondestructive tools in 3D-Coat.

- Imput decreased (the time between human's action and visual feedback on the screen).

- Enable VoXRay in surface tools, Backface culling will be turned off in VoXRay tool.

- Correct normals sampling usage in Live Clay based tools.

-  Fixed crash related to extrusion using "Initial vertex normals".

- Everywhere in primitives edit boxes replaced with sliders.

- Better quality for 3D lasso selection

- Undo for renaming layer

- All Raul's tools updated

- a lot if small stability fixes.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Andrew Shpagin said:

4.7.11[beta]

- Coat tool. This is non-destructive and precise version of VoxLayer. This is important step, it opens family of nondestructive tools in 3D-Coat.

Wow! Non-destructive sculpting tools in 3D-Coat! This will be huge! :wub:

I fiddled a bit with the coat tool and it is impressive!

 

Two small bugs:

- sliders in coat tool options are non-undoable.

- sometimes points become unselectable and I need to select some other VoxTree object and then the "coated" one again

 

Also, some questions:

1) Would it be difficult to make the tool respect symmetry?

2) The tool seems to be remeshing the geometry it creates whenever we move points of the selection curve. So anything that was sculpted on it before curve modification will be lost. Would it be possible, in a further development stage of this tool of course, to make it preserve anything that was sculpted on it?

  • Like 1

Share this post


Link to post
Share on other sites

I confirm what Artur just wrote.

It looks promising though

 

Primitives are so important for the retopo room , i am using my own for the base shapes and its literraly cuts the production labour hours 5 and 10 times down if used correctly.

 

Question for Coat tool. If this is the future Sculpt layers shoouldnt the Coat surface follow the surface thats under it???

Example 

 

a box , on top the Coat , we sculpt on Coat but when we sculpt on the box Coat surface is not following , it stays there.

 

Thank you Andrew so much for getting in the latest of Rauls retopo tools , i was so in need for those.

Thank you Team.

Edited by Michaelgdrs
  • Like 2

Share this post


Link to post
Share on other sites

What is VoXRay tool? Nothing happens when I apply it duplicates the existing geometry. Same is with the Coat tool. When I apply it to geometry it creates a layer with nothing in it.

Share this post


Link to post
Share on other sites
47 minutes ago, Vipera said:

What is VoXRay tool? Nothing happens when I apply it duplicates the existing geometry. Same is with the Coat tool. When I apply it to geometry it creates a layer with nothing in it.

 

  • Like 3

Share this post


Link to post
Share on other sites

Just in case anyone is trying to get the MacOS or Linux builds of 4.7.08 and are seeing it slowly download (or not at all); Right now those builds are not downloading correctly, or might take a very long time. I've notified the webmaster. Please bare with us. Thanks!

Share this post


Link to post
Share on other sites

 

On 29.9.2016 at 10:04 PM, AbnRanger said:

 

Feedback to developers:

It's a great addition which makes a lot of sense for Voxels. I don't think Vox Ray tool is a particularly descriptive term though.
Comparable tools in CAD software use names like (interactive) Clipping Plane, Section Plane / Tool. Maybe worth a thought?
The tooltip should point out that this is essentially an analysis tool which doesn't actually slice the model.
 

Share this post


Link to post
Share on other sites
40 minutes ago, BurrMan said:

Surface mode-angulator tooltip = "This tool allows to creator............."

 

typo

Thanks. For future reference, the thread below is for language/typos. :)

 

  • Like 1

Share this post


Link to post
Share on other sites

In Smart Material Editor if I replace texture and open curve editor for this texture preview window still shows the old texture until I start to tweak this texture. I think this bug needs to be fixed. I also would like to have option to turn on/off texture in smart material editor and drag and drop textures between slots.

  • Like 1

Share this post


Link to post
Share on other sites

I hope Andrew goes through the Smart Material Editor while he works on layer masks/layers. I've requested over and over and over and over and over and over and over and...you get the point, that he ADD BERCON MAPS (they are an open source library!). Sure, it may not be as easy as just dumping that code into 3D Coat, but what is the alternative? To do nothing? 3D Coat needs an extensive library of PROCEDURAL NOISE patterns...period. Procedural noise patterns to use in the Smart Materials Editor (just one noise type, currently), Fill tool and in the Noise tool, in the Sculpt Room. Even add them to Stencils. ZBrush has had an awesome Noise Generator for years, and it's one of the must have tools that keeps serious sculptors using ZBrush.

http://www.ylilammi.com/2013/09/berconmaps/

Procedural Noise Library can help take artists work in 3D Coat to another level, if Andrew will just add it....please.

  • Like 5

Share this post


Link to post
Share on other sites
21 hours ago, AbnRanger said:

I hope Andrew goes through the Smart Material Editor while he works on layer masks/layers. I've requested over and over and over and over and over and over and over and...you get the point, that he ADD BERCON MAPS (they are an open source library!). Sure, it may not be as easy as just dumping that code into 3D Coat, but what is the alternative? To do nothing? 3D Coat needs an extensive library of PROCEDURAL NOISE patterns...period. Procedural noise patterns to use in the Smart Materials Editor (just one noise type, currently), Fill tool and in the Noise tool, in the Sculpt Room. Even add them to Stencils. ZBrush has had an awesome Noise Generator for years, and it's one of the must have tools that keeps serious sculptors using ZBrush.

http://www.ylilammi.com/2013/09/berconmaps/

Procedural Noise Library can help take artists work in 3D Coat to another level, if Andrew will just add it....please.

This need to happen ASAP.

I need to create some noises on Fractal Noise inside After Effects, then do some sort of trick to turn it tileable, and then use it on 3D-Coat. Painting with Smart Materials would be really on par with Substance Painter with procedural noises.

Edited by dimitribastos
  • Like 1

Share this post


Link to post
Share on other sites

Does anyone have problems with AUTOPO on 4.7.11? Here, from a simple to complex object, when I do AUTOPO 3D-Coat does not respond anymore.

Share this post


Link to post
Share on other sites

Strange. I have a fairly good machine and 3D-Coat freezes like it's running on a low end computer. :(

Share this post


Link to post
Share on other sites

If model is not under NDA you can freely send it over and i can have a look if you want

Share this post


Link to post
Share on other sites
3 hours ago, dimitribastos said:

Does anyone have problems with AUTOPO on 4.7.11? Here, from a simple to complex object, when I do AUTOPO 3D-Coat does not respond anymore.

I have address problems with Autopo many, many times, In fact again in the last several weeks in this thread. Unless Andrew goes back and does a deep code work on Autopo it remains a tool you can not depend upon... I have pretty much given up on using it except for really simple objects and again I do know how to get a clean model for Autopo...

Edited by digman

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×