Jump to content
3DCoat Forums
Andrew Shpagin

V4.1 BETA (experimental 4.1.17D)

Recommended Posts

4.0.18

- Attempt to resolve "loosing pressure" issue on Wacom. It is Wacom's bug so I need to do different sort of "strange hacks" to avoid this.

- Retopo groups may be treated as Objects, not as Materials (as before, but you may switch to old style in preferences). It is much more logical, but this change requires careful check, it is potentially unsafe. To be honest it was far not easy to change.

- Stability of strokes shape on very curvy shapes improved - http://www.3d-coat.com/mantis/view.php?id=1440

- Steady Stroke AUTO OFF when press Shift key for quick smooth

  • Like 3

Share this post


Link to post
Share on other sites

Andrew, I gave it a short test on a complex model and... I can't stress it enough on how grateful I am that you fixed this!

This issue was, like Digman said - a real workflow killer.

Beautiful job, Andrew! :clapping:

 

This build is one of the best so far. :)

 

Well, there's one tiny thing that could use a fix. When retopo mesh is imported into retopo room, a room change is required to properly update the UV-sets list. But it's no biggie of course.

Edited by ajz3d

Share this post


Link to post
Share on other sites

So far so good. :) Only one bug (actually experienced this in previous builds, too) so far:

 

http://3d-coat.com/mantis/view.php?id=1451

Yep, there are many problems with popup windows. And this isn't the the only one with the colour palette. For example:

1. Undock the palette window.

2. Clear it and close it.

3. Open it again.

4. Add a colour swatch.

5. Right click the newly added colour swatch. The context menu will appear but it will be the "Load, save, small, etc." one instead of "Delete all, delete, insert, edit color". To make the latter appear, you need to change rooms to voxel room (switching to other rooms won't help) and back again to paint room.

6. Right click the colour swatch. Voila.

 

When I have some free time, I'll try to report all of them to Mantis.

Edited by ajz3d

Share this post


Link to post
Share on other sites

Did someothing happen with the Surface Pinch tool?  I seem to recall osme menttion of it and now it doesn't seem to be pinching, just acting like Draw.

Share this post


Link to post
Share on other sites

Did someothing happen with the Surface Pinch tool?  I seem to recall osme menttion of it and now it doesn't seem to be pinching, just acting like Draw.

works fine on my side in 17A/18...it just pinch,(no draw action)

Share this post


Link to post
Share on other sites

Yep, there are many problems with popup windows. And this isn't the the only one with the colour palette. For example:

1. Undock the palette window.

2. Clear it and close it.

3. Open it again.

4. Add a colour swatch.

5. Right click the newly added colour swatch. The context menu will appear but it will be the "Load, save, small, etc." one instead of "Delete all, delete, insert, edit color". To make the latter appear, you need to change rooms to voxel room (switching to other rooms won't help) and back again to paint room.

6. Right click the colour swatch. Voila.

 

When I have some free time, I'll try to report all of them to Mantis.

 

 

I can confirm that, thanks for outlining it. :)

 

 

 

I found another one to do with UV maps. Reported on Mantis.

Share this post


Link to post
Share on other sites

I dont get this....very strange.

Maybe Andrew accidentally pasted the code for the draw brush into the Pinch brush when working on it recently?  :blush: 

Share this post


Link to post
Share on other sites

Have you deleted the Options.xml file, Phil? Maybe restart 3D Coat, cause I sometimes get unexplainable problems like this, and either one of those steps fixes it somehow. Pinch might look like Draw until you press a bit harder on your stylus..

Share this post


Link to post
Share on other sites

philnolan3d -  I got the same thing, but I thought It was my error and I have changed the preset. To fix it go into 'strip palette' and disable it for draw brush. It reverted draw brush for me, maybe it will work for you.

Share this post


Link to post
Share on other sites

Is there any word one when we might be seeing 4.1? There's a possibility I'll be teaching some character creation classes very soon and if that happens I'll be incorporating 3DCoat (assuming approval is given) into the class for the painting side of things.

Share this post


Link to post
Share on other sites

The Pinch brush works correctly in my version of 4.0.18.

 

The above does not mean there is not a problem somewhere but I do not experience it... 

Share this post


Link to post
Share on other sites

Possibly you have Strength = 0

 

Ah so something did change with Pinch, there's a strength slider now.  It was at 0% by default, maybe the default should be higher. I brought it up to 100% and it's actin normally. thanks.

Share this post


Link to post
Share on other sites

Ah so something did change with Pinch, there's a strength slider now.  It was at 0% by default, maybe the default should be higher. I brought it up to 100% and it's actin normally. thanks.

Yes, depth  was added in version... 4.0.06

"Pinch improved a lot - now it applies displacement + more accurate + separate pressure curves for depth and pinch"

 

I think we already had strength...

Edited by digman

Share this post


Link to post
Share on other sites

Yeah thanks, I'm a little behind since all of my jobs lately were in LightWave and After Effects only.

Share this post


Link to post
Share on other sites

UV room is acting weird. Island highlighting doesnt work ( checkbox is checked )..unwrap doesnt seem to update anything. Is this confirmed?

Share this post


Link to post
Share on other sites

Questions to Andrew or anyone else:

 

1)How do I change panorama image from view preferences,if I choose another image in preference menu the panorama stays the same.

 

 

2)How does environmental display work? In which mode?

I tried voxel mode with various shaders,paint room ect...when selecting Environment display from view menu nothing change,also I tried loading different Environment sphere maps from preferences and nothing happens..,,

 

thanx

  • Like 1

Share this post


Link to post
Share on other sites

Andrew would it be hard to implement vertex paint in SF/LC brush....this way we could make matching sculpting/color/spec and do great brushes ?

Is it something planned at some point in future on roadmap?

Also it would be great if one day paintroom Fill tool would somehow add depth to SF mode mesh too.Same thing for Materials tool color/depth/spec could be painted directly in SF mode ....

  • Like 1

Share this post


Link to post
Share on other sites

Maybe wrong place,
Is it possible to make ergonomy better by navigate in numericals imputs (like position:xyz, Size: xyz, and others...)
 just with Tab key, instead of have to enter the field x, type number for x, press OK for x and repeat this for y and z.
Naviguate, validate xyz by Tab should be more friendly.
Thank's for all your good job by many years on this soft Andrew.

Share this post


Link to post
Share on other sites

In 17 and 17A, I keep getting a hard freeze (have to reboot, no cursor movement) when I go to the Render Room.  In 17, it was when I turned on "Real-Time Lighting," but in 17A, it's when I turn on wireframe and then try to turn the model.  Anyone else getting that?

 

This issue seems to be solved in 18.  Not sure why, but it works now.

 

However, it appears that symmetry while painting on the UV Texture editor doesn't work...can anyone else confirm for 18?

 

One other question...if deleting Options.xml fixes some issues that come up, why not have 3D Coat do this automatically each time it loads up...auto delete that file, re-establish that file in the process it normally does and then any other issues that pop up are strictly due to bugs?

Edited by alvordr

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×