3DCoat 2021/2 development thread


Recommended Posts

2 hours ago, Ctc_nick said:

Hello, and happy new year!

I have a serious Performance loss with the last version 84. Might have to do with the shader optmizations.

In an empty new Scene I get:

3DCoat.83: Paint Room: 270 FPS, Sculpt 177 FPS 

3DCoat.84: Paint Room:   30 FPS, Sculpt   15 FPS

on a Geforce 1070gtx.

:unknw:

 

please run coat, exit in minute or half, send me docs/3DCoat2021/log.txt

And move mouse constanlly during the process

Link to comment
Share on other sites

  • Member
1 hour ago, ThomasJohann said:

Tumble & sculpting voxels  , the cursor jumps off when the jerk happens.

Sounds a bit like the same. My axis cross and the grid flicker for a millisecond.

Link to comment
Share on other sites

  • Advanced Member

@SERGYIWill there be development for Wayland display server in linux? 3Dcoat will run using Wayland, but is unusable due to extremely low frame rates in the viewport.

Link to comment
Share on other sites

  • Member
14 hours ago, Andrew Shpagin said:

please run coat, exit in minute or half, send me docs/3DCoat2021/log.txt

And move mouse constanlly during the process

Hi.

The low Framerate from 84 is gone in version 85.

Thank you! :yes:

  • Like 1
Link to comment
Share on other sites

  • Member
Posted (edited)

Testing .85: 

-Encountered the most entertaining bug: I vox hid a part, objectified it, deleted hidden from the base. Switched to it. I was scaling the part using transform tools inner yellow cube.

I literally watched the left symmetry indicator move further left by itself breaking the symmetry. Object became non uniform. I right clicked and made it uniform. Although symmetry is still active none of the brushes work symmetrically. The rogue sym dot is nowhere to be seen again :D :D. I tried symcopy to fix, didnt work so I'm typing this :D

-edit: I hid a part of the rogue mesh and objectified it. sym still doesnt come back...Sym works for other parts I made from the same base though :D

-edit 2 : When I smooth using shift, Smooth adds a single brush stroke when the shift is released. For ex: I used vox clay on a vox obj. I started smoothing using shift key. When I'm done I release the shift and a stroke of vox clay is added unwantedly. This is not a new bug.

-edit 3: Performance feels better for now.

This software has a mind of its own :D

Edited by Koray
for more
Link to comment
Share on other sites

  • Member
Posted (edited)
1 hour ago, Andrew Shpagin said:

So, you press SHIFT, mouse down, move, mouse up, SHIFT up, and quad appears? In sphere tool? Or in all native voxel tools?

Since you asked, I tested further and ONLY the Vox Clay adds a square when:

- You select vox clay, add strokes, press shift start smoothing, unpress shift without releasing the mouse left click or pen pressure, then when you release the left click or lift the pen, only the Vox Clay adds a single stroke even if you try not to move the mouse or pen. 

Seems like the vox clay counts mouse release (or pen lift) as a stroke . No other brush that I've tried does that. 

When you release the mouse or pen while holding shift the stroke does not appear.

Edit: I used the sphere tool to draw the arrows to show you the squares.

Edited by Koray
Link to comment
Share on other sites

  • Member
20 hours ago, Elemeno said:

well 200 million triangles was my limit ... after that sculpting is 30 fps and a little slow... probably ok for stamping

Is that a single tool that is 200 million???

In my case I can go up to around 20 mil on a single tool, then the brushes start acting quite slow. Then I tried smooth all from the space menu and 3DC crashed.

( my pc: i9, 64 gig ram, 1080ti gpu ) 

Link to comment
Share on other sites

  • Member

I am on 85. There is a render room bug still. If you customize the shader and go to render room the changes are not present. Then when you go to the sculpt room back, the standard shader is on the sculpt, so the customized settings are gone. Is there a work around? I think this started with v84 or v83.

  • Thanks 1
Link to comment
Share on other sites

  • Member

I have come across an issue with the Autopo. When I use it with a symmetry on, I get duplicate vertices / hidden faces along the center edge loop. Here is how I can replicate the results.

  1. Create a new voxel project. I use a sphere.
  2. Turn on symmetry - I usually use 'X'
  3. Make an indent on either side of the line of symmetry (something like eye sockets)
  4. Use autopo on the shape - I use 2000 polys but other amounts work as well.

The shape will have strange geo (overlapping vertices / hidden faces) along the line of symmetry.

close_up_of_strange_geo.jpg

autopo_params.jpg

Symmetrical_shape.jpg

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member
On 1/4/2022 at 12:19 PM, Koray said:

Is that a single tool that is 200 million???

In my case I can go up to around 20 mil on a single tool, then the brushes start acting quite slow. Then I tried smooth all from the space menu and 3DC crashed.

( my pc: i9, 64 gig ram, 1080ti gpu ) 

i was jsut trying random brushes ... smooth is slow but every other tool i get like 30 fps so its ok while using stamp tool etc

detail.jpg

Link to comment
Share on other sites

  • Advanced Member

@Andrew Shpagin Good change with the default IBL.  Also glad to hear of Jama's involvement/consultation.

With the shader advancements your making, any chance of getting some kind of better looking post process effect on the cavity setting to make them look smoother?

Also, has the voxel smooth seen a performance enhancement?  I didn't notice anything, but just checking if it's been done.  Or maybe planned for.

Thanks!

Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 2021/2 development thread

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share