• Ελληνικά
  • Τεκμηρίωση 3DCoat
  • Chapters
    • Εισαγωγή στο 3DCoat
    • Ξεκινώντας
    • Διασύνδεση & Πλοήγηση
    • Εξαρτήματα Brush
    • Node System
    • GPU Texturing
    • Χώροι εργασίας Δωμάτια
    • Scripting & Core API
    • Ερωτήσεις και απαντήσεις
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Εκπαιδευτικά Φροντιστήρια
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Ελληνικά Ελληνικά
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
  • Τεκμηρίωση 3DCoat
  • Chapters
    • Εισαγωγή στο 3DCoat
    • Ξεκινώντας
    • Διασύνδεση & Πλοήγηση
    • Εξαρτήματα Brush
    • Node System
    • GPU Texturing
    • Χώροι εργασίας Δωμάτια
    • Scripting & Core API
    • Ερωτήσεις και απαντήσεις
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Εκπαιδευτικά Φροντιστήρια
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Ελληνικά Ελληνικά
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
    • Εναλλαγή πολλών γλωσσών
Expand All Collapse All
  • Εισαγωγή στο 3DCoat
  • Ξεκινώντας
    • System requirements
    • Why 3DCoat is Unique?
    • Ενεργοποίηση 3DCoat
    • Σφάλμα εκκίνησης
      • Startup error Mac
    • Color management
    • Upgrading permanent license
    • Linux Setup
      • Linux initial setup per-user installation
      • Linux initial setup for system
      • Tablet setup
      • To GTK3 from GTK2
      • Error libicuuc.so.70
    • Δομή φακέλων
      • Custom documents folder
    • Διαφορετικές μορφές «επίλυσης»
    • Tablet on Window
    • Import & Export
    • Applinks σε 3DCoat
      • Σύνδεσμος εφαρμογής Blender
        • Blender with the Applink in Linux
      • Blender 4.2/3/4/5 applink
      • Max Applink
      • Houdini applink
      • Lightwave uplink
  • Navigation
    • Άνοιγμα διαλόγου (Μενού γρήγορης έναρξης)
    • Πίνακας πλοήγησης
    • Κάμερα και Πλοήγηση
      • Customize Navigation as Blender
    • Left tool panel
    •  Activity Bar
    • Πλοήγηση με χρήση συσκευών 3DConnexion
      • How to compile Spacenavd on non Ubuntu distro
    • Quick Access Menu
    • Stylus doesn’t work in sculpting
    • Πλήκτρα συντόμευσης
  • Διασύνδεση & Πλοήγηση
    • Μενού Αρχείο
    • Επεξεργασία μενού
      • Bake Geometry Info
      • Calculate Occlusion
      • Calculate Curvature
      • Light Baking Tool
      • Προτιμήσεις
      • Cavity and Curvature maps
    • Προβολή μενού
    • Συμμετρία
    • Textures
    • Calculate
    • Μενού επιπέδων
    • Μενού παγώματος
    • Hide
    • Bake
    • Καμπύλες 2022
      • Μενού Curves
      • Curves Properties RMB
      • Γεμίστε με διχτυωτό στρώμα
      • Scale of imported curves
    • Μενού των Windows
      • Αναδυόμενοι πίνακες των Windows με καρτέλες
      • Ρυθμιστικά
    • Scripts
    • Addons
    • Capture
    • Μενού βοήθειας
    • Προσαρμογή
    • Τροποποίηση ή Δημιουργία νέου δωματίου
  • Εξαρτήματα Brush
    • Brush Top Bar
    • Βούρτσες γενικής χρήσης
      • Δημιουργήστε πινέλα και χαλκομανίες
      • Κατασκευή άλφα από την τρέχουσα γλυπτική
      • Δημιουργήστε ένα Brush από ένα τρισδιάστατο αντικείμενο
      • Create brushes based on Curves
      • Load photoshop .abr brushes
    • Εγκεφαλικά επεισόδια
      • Αναδυόμενο μενού Curves
    • Επιλογές Brush
    • Περιοριστής συνθηκών
    • Πάνελ λωρίδων
    • Στένσιλ Πάνελ
    • Έξυπνα Υλικά
      • Προσθέστε νέες εικόνες ή υλικά
      • Συνδέστε ένα έξυπνο υλικό σε ένα στρώμα
      • Import Quixel Megascans
    • Πώς να δημιουργήσετε προεπιλογές για το Brush
  • Node System
    • Node Editor
    • Node & Object Inspectors
    • Node Graph
    • NodeGraph Language (NGL)
    • GPU Nodes
      • Color
      • GeometryIn
      • In
      • Layer
      • Material
      • Math
      • Noise
      • Noise3D
      • Out
      • Pattern
      • Pattern3D
      • Shape
      • Texture
      • Tilable
      • UV
    • Filters
    • Masks
    • Materials
    • Modifiers
    • Volumes
  • Δωρεάν 3DCoatPrint
  • GPU Texturing
    • PBM Channels
    • Per-Pixel Painting
  • Χώροι εργασίας Δωμάτια
    • Painting
      • Painting υφής & τρόποι λειτουργίας
        • Painting Per-Pixel
        • Painting με μετατόπιση (Micro-Vertex)
        • Painting Ptex
        • Painting Επιφανειών (Πολυβαψίματος)
      • Εισαγωγή στην αίθουσα Painting
        • Initial CC subdivision
        • UV Set smoothing
        • Sharp (hard) edge
        • Κλείδωμα Κανονικά
        • Φόρτωση νέας διάταξης UV μετά από αλλαγές μοντέλου
        • DAZ Genesis models into 3DCoat
        • ID map
      • Μενού του Χώρου Εργασίας Painting
        • Edit menu
        • Μενού Υφές
          • Εργαλεία Baking υφής
        • Κρύβω
        • Μενού για το Bake Paint
        • Ο Επιλογέας Χρώματος
      • Surface Materials
      • Top Bar για τη Painting
      • Ο πίνακας στρωμάτων
        • Ο πίνακας ανάμειξης
        • Layer and Clipping Masks
      • Εργαλεία δωματίου Painting
      • Αδιαφάνεια – Διαφάνεια
      • Προσαρμόστε τον χώρο εργασίας
        • Tweak Toolset
        • Εξαγωγή από το Tweak Room
      • Πίνακας προεπισκόπησης μάσκας/υλικού
      • Εξαγωγή από το Painting Room
    • Χώρος εργασίας UV
      • UV Top Bar
      • UV Αριστερός πίνακας εργαλείων
      • Πίνακας προεπισκόπησης UV
      • Παράδειγμα ροής εργασίας UV
      • Εισαγωγή στο δωμάτιο UV
      • Εξαγωγή από το δωμάτιο UV
    • Ρετοπολογία
      • Εισαγωγή στο Retopo Room
      • Μενού Retopo Mesh και Bake Menu
        • Λειτουργία εικονικού καθρέφτη
      • Bake menu
        • Treat Poly Groups as Paint Objects
        • Baking guide
      • Εργαλείο Strokes στη Ρετοπολογία
      • Top Bar
        • Επιλέξτε γεωμετρία
      • Αριστερός πίνακας εργαλείων στην αίθουσα ρετοπολογίας
        • Συνολικός Σκοπός & Λειτουργία
        • Προσθήκη γεωμετρίας
        • Retopo Tweak Tools
        • Εργαλεία UV
        • Εντολές για αίθουσα ρετοπολογίας
      • AUTORETOPO
        • Autopo guide
      • Poly Groups
    • Γλυπτική
      • Sculpt Layer
      • Sculpt Tree
      • Επιλογές Sculpt Brush
      • Top Bar
      • Κινητήρας Brush
      • Υπομενού Γεωμετρία
      • Σμιλέψτε το μενού "Δεξί κλικ".
      • Shaders
      • Λειτουργία Voxel
        • Pure Voxel Sculpting
        • Πυκνότητα και Ανάλυση
        • Πήλινη μηχανή
        • Voxel Tools
        • Εργαλεία επιφάνειας σε Voxels
        • Εργαλεία προσαρμογής Voxel
        • Ογκομετρική Painting
        • Εργαλεία αντικειμένων Voxel
      • Επιφανειακή λειτουργία
        • Επιφανειακά εργαλεία
        • Προσαρμοσμένα εργαλεία επιφάνειας
        • Surface Layer
        • Εργαλεία ρύθμισης επιφάνειας
        • Επιφανειακή Painting
        • Ανάλυση πολλαπλών επιπέδων
          • Multires tools
          • Multires adjust
          • Multires commands
      • Σμιλεύει καμπύλες
        • Καμπύλες Spline
        • Splines model creation
      • Διανυσματική μετατόπιση
      • Εργαλεία μετασχηματισμού επιφάνειας
        • Voxel Transform Tools
        • Instancer
        • Move
        • Pose
        • Fit
        • Reproject
        • Surface Array
      • Voxel Primitives & Import Tools
        • Hollow Box
      • Ζωντανά booleans
      • Εντολές για το δωμάτιο Sculpt
      • Import στο Sculpt Room
      • Εξαγωγή από το Sculpt Room
    • Καθιστώ
      • Comparison of different roughness values
      • Λειτουργίες πίνακα απόδοσης
      • Περιστροφική πλάκα
      • Fakebake the lighting - non PBR-
    • Factures
      • Ροή εργασιών
    • Το πιο απλό
    • Πρίπλασμα
      • Mesh Menu
      • Αριστερός πίνακας εργαλείων στην αίθουσα μοντελοποίησης
        • Προσθήκη γεωμετρίας
          • Make Joints
          • Επιλεγμένο
        • Μικροδιόρθωση
        • Smart Hybrid
        • UV
          • Εντολές
        • Ολόκληρο πλέγμα
      • Παράδειγμα επιφάνειας σοφίτας από τον Fluffy
      • Blockout από τον Poeboi
      • Import Zbrush Polygroups for UV mapping
    • Kitbash - Γρήγορη δημιουργία τρισδιάστατων μοντέλων
      • Create kitbash
      • Left tool panel Kitbash
    • 3DPrint
    • Photogrammetry
      • How to install Reality Capture
      • Reality Capture doesn’t show up ?
    • Διχτυωτό στο δωμάτιο NURBS
    • Nodes
      • Texturing with nodes
      • Sculpt shaders Nodes Library
      • Open PBR
  • Scripting & Core API
    • Core API
    • Python API
    • Extensions and Addons

Cavity and Curvature maps

61 views 0

Written by Carlos
September 17, 2026

To bake a curvature map in 3DCoat, go to the Paint Room, open the Edit menu, and select Calculate Curvature.

Steps to Bake Curvature

  • Switch to the Paint Room after your mesh and normals are ready.
  • Hide the voxel display if needed by unchecking View > Show Voxel.
  • Go to the top menu and select Textures > Calculate Curvature (or Edit > Calculate Curvature depending on your version).
  • Choose your preferred curvature type in the pop-up panel (such as Local Curvature RGB or standard settings) and click OK to process the bake.
  • 3DCoat generates and applies the map to a background layer used by smart materials. You can turn the layer’s visibility on in your layer panel if you want to see the black-and-white or RGB breakdown visually.

Tips for Curvature Settings

  • RGB vs Black & White: Modern versions use RGB cavity/curvature by default to store concavity and convexity separately in different color channels.
  • Legacy Mode: If you prefer the old black-and-white style cavity map baker, you can switch it on by going to Edit > Preferences, navigating to the Tools section, and unchecking/changing the default cavity calculation settings.

How can i export only curvature and occlusion maps?

On Paint Room open the export Panel at File > Export > Objects & Textures

Create a new Export Constructor preset selecting only ExportAO and Export Curvature Map.


When i click on the Export Panel add texture and then i click RGB i cannot find any curvature name, only cavity. Is cavity same as curvature?

Yes and no.

Cavity Map focus on small details, while Curvature Map emphasize the overall shape of a surface, it map store the concave and convex edges of a mesh.

However ‘Cavity map’ is different than “Curvature map”. A Curvature map actually store the concave and convex edges of a mesh. Is also called Concavity, Convexity, Pits & Peaks, Worn Edge.

The convex (white) and the concave (Black) is Curvature map and the transition between peaks and crevices (gray values) of the model is Cavity map.

To produce a Cavity map that we could use as Curvature, we need more gray-scale values so that we can identify the convex (white), the concave (Black) and the transition between peaks and crevices (gray values) of the model.

– Cavity texture

Focuses on small details like crevices, grooves, and indentations (cavity maps are also known as crevice maps).
They are a more detailed version of ambient occlusion maps.
Cavity maps can be useful for improving dirt masks, enhancing colors, and adding highlights.

– Curvature texture

Focuses on the overall shape of a surface, showing where the surface curves inward or outward.
Curvature maps are also known as concavity, convexity, pits and peaks, or worn edge.
Curvature maps can be used to simulate edge wear, highlight details, and check for surface continuity.

Curvature can be both an RGB map encoding convexity/concavity in separate channels, or a gray scale map encoding convex edges as white and concave edges as black like in the image below.


I went ahead and exported cavity, it looks like a curvature map. Can i use that one as a curvature?

Select Cavity for Curvature. (the map generated is named Cavity at export).

This map is often (erroneously) called Cavity, but more accurately a Cavity map can also be a white map with concave edges encoded as black.

3DCoat does not have the option to export both maps at the same time, but you can generate them using the Generate Curvature map tool.


Utilize Normal maps during AO and Curvature baking

Other major new Improvement is the ability to utilize Normal maps during this baking process, so let’s go ahead and get started by hiding some of the layers.
Hold down the ALT key and select the visibility icon on one of these layers and the only one to leave intact is the one that has normal map information on it.

You need to have the Normal map visible so that 3DCoat can utilize it during this baking process.

So now let’s go ahead and go to the Edit menu and choose Calculate Occlusion and Curvature maps.


Pay attention that curvature consists of two components

First is local curvature that allows to detect small details, scratches.
Second is long-range curvature that flows smoothly and allows to detect large details.

If you need Gray Maps set intensity for both types: curvature or cavity.

  • Turn intensity up create a cavity map. (curvature intensity 400, long range curvature 10).
  • Turn intensity down create a curvature map. (curvature intensity 8, long range curvature 100).

Another workflow is to use Local Curvature RGB for Cavity map…

And Local Curvature for gray Curvature map

Following this steps you can get this result:


RGB Cavity map

Starting from 3DCoat 2021.53 the RGB Cavity map was introduced as the default calculation method in Texturing.

You can active RGB Cavity “Curvature” on Edit > Preferences > Tools.

On Cavity map RGB each channel contains different information, like convexity in red and concavity in green for instance.


Cavity Area Width:

This option requires the RGB cavity pre-calculated using the Textures->Calculate curvature, Local Curvature RGB.

When you first run the Curvature using RGB Cavity, the Light Baking Panel comes up.
Not change the settings Local Curvature RGB (you can change some later) and run the Curvature Calculation.

In the Smart Material Editor this option appears in the Editor when RGB Cavity is selected as default. You may vary the width of the area of the cavity influence, make the cavity narrow or wide.

* Before that, you need to remove the regular cavity layer if it already exists.

Adjusting Cavity Area Width and Overall Cavity Modulator can give you some nice effects like several layers of old paint on top of each other. As is show on this video:

The curvature layer is required to use cavity/curvature as a condition for materials or conditional painting.

If you work with Conditions painting by layer, on the upper right side you can adjust degree & contrast


Remember that Conditions painting only work on freeze for sculpt surface mode or Surface Paint on vertex on Paint Room.

But the standard sculpting brushes do not respect conditions, only work on Freeze mask to restrict where surface sculpting tools will be applied to the surface of the model.


Just a fast simple example:

Base layer
1st layer = Old Copper
2nd layer = Blue paint
3rd layer = Red paint.

Adjust each smart material differently using Adjusting Cavity Area Width and Overall Cavity Modulator.

It is really not one smart material but 3 separate Smart materials on separate layers.
Can create it using any default Smart Materials.

Follow this steps:

Open the Smart Material editor and the real time preview window, placing it over the model.
This is the most important because you get the real time view of the smart material and how it will be applied.
Do not go by as seen on the Smart Material Editor’s ball if you want real time feedback in this case.
Start Adjusting the Cavity Modulator and Cavity Area Width till you get the effect you want.
The picture above is the blue paint settings, it was the blue metal but looks like blue paint. It was the second layer in the stack.


This other example show how to further increase the variation of your applied Smart Material.

Assign Cube Mapping as Preferred mapping.
On Material/Stencil Control Panel, select Settings.

On this panel you can change the rotation of the cube map on the XYZ axis (per axis) and the expansion per axis as well as is shown in picture below.

You can preview in real time as the texture moves over the surface.

Last picture shown how to further increase variation using a layer blend mode. On this example is used the Overlay blend mode on the top layer.

You can adjust the strength of the blend mode by using the Opacity adjustment.

The new RGB cavity curvature calculation and Cavity Area Width plus Cavity Modulator is great.

Lots to explore here.

Have fun exploring!

Was this helpful?

Yes  No
Related Articles
  • Noise3D
  • Noise
  • Bake Geometry Info
  • Make Joints
  • Texturing with nodes
  • Hollow Box
Previously
Προτιμήσεις
Up Next
Προβολή μενού
AI:
Hi! How can I help you?
Attention: This is a beta version of AI chat. Some answers may be wrong. See full version of AI chat