• Português
  • Documentação 3DCoat
  • Chapters
    • Introdução ao 3DCoat
    • Começando
    • Interface e Navegação
    • Componentes do Brush
    • Node System
    • GPU Texturing
    • Espaços de Trabalho Salas
    • API de Scripting e Core API
    • Perguntas e Respostas
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Tutoriais de treinamento
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Português Português
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
  • Documentação 3DCoat
  • Chapters
    • Introdução ao 3DCoat
    • Começando
    • Interface e Navegação
    • Componentes do Brush
    • Node System
    • GPU Texturing
    • Espaços de Trabalho Salas
    • API de Scripting e Core API
    • Perguntas e Respostas
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Tutoriais de treinamento
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Português Português
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
    • Alternador multilíngue
Expand All Collapse All
  • Introdução ao 3DCoat
  • Começando
    • System requirements
    • Why 3DCoat is Unique?
    • Ativando 3DCoat
    • erro de inicialização
      • Startup error Mac
    • Color management
    • Upgrading permanent license
    • Linux Setup
      • Linux initial setup per-user installation
      • Linux initial setup for system
      • Tablet setup
      • To GTK3 from GTK2
      • Error libicuuc.so.70
    • Estrutura de Pastas
      • Custom documents folder
    • Diferentes formas de “resolução”
    • Tablet on Window
    • Import e Export
    • Applinks em 3DCoat
      • Link do aplicativo Blender
        • Blender with the Applink in Linux
      • Blender 4.2/3/4/5 applink
      • Max Applink
      • Houdini applink
      • Lightwave uplink
  • Navigation
    • Diálogo de abertura (Menu de início rápido)
    • Painel de navegação
    • Câmera e navegação
      • Customize Navigation as Blender
    • Left tool panel
    •  Activity Bar
    • Navegação usando dispositivos 3DConnexion
      • How to compile Spacenavd on non Ubuntu distro
    • Quick Access Menu
    • Stylus doesn’t work in sculpting
    • Teclas de atalho
  • Interface e Navegação
    • Menu de arquivo
    • Editar menu
      • Bake Geometry Info
      • Calculate Occlusion
      • Calculate Curvature
      • Light Baking Tool
      • Preferências
      • Cavity and Curvature maps
    • Ver Menu
    • Simetria
    • Textures
    • Calculate
    • Menu de Camadas
    • Menu Congelar
    • Hide
    • Bake
    • Curvas 2022
      • Menu de Curvas
      • Curves Properties RMB
      • Preencher com camada de malha
      • Scale of imported curves
    • Menu do Windows
      • Painéis pop-up do Windows com guias
      • Controles deslizantes
    • Scripts
    • Addons
    • Capture
    • menu de ajuda
    • Costumização
    • Modifique ou crie uma nova sala
  • Componentes do Brush
    • Brush Barra Superior
    • Pincéis de uso geral
      • Crie pincéis e decalques
      • Fazendo alfa a partir da escultura atual
      • Crie um Brush a partir de um objeto 3D
      • Create brushes based on Curves
      • Load photoshop .abr brushes
    • Strokes
      • Menu pop-up Curvas
    • Opções de Brush
    • Limitador de Condições
    • Painel de tiras
    • Painel de estênceis
    • Materiais Inteligentes
      • Adicione novas imagens ou materiais
      • Anexe um material inteligente a uma camada
      • Import Quixel Megascans
    • Como criar predefinições para Brush
  • Node System
    • Node Editor
    • Node & Object Inspectors
    • Node Graph
    • NodeGraph Language (NGL)
    • GPU Nodes
      • Color
      • GeometryIn
      • In
      • Layer
      • Material
      • Math
      • Noise
      • Noise3D
      • Out
      • Pattern
      • Pattern3D
      • Shape
      • Texture
      • Tilable
      • UV
    • Filters
    • Masks
    • Materials
    • Modifiers
    • Volumes
  • 3DCoatPrint gratuita
  • GPU Texturing
    • PBM Channels
    • Per-Pixel Painting
  • Espaços de Trabalho Salas
    • Painting
      • Painting de texturas e modos
        • Painting por Per-Pixel
        • Painting de Deslocamento (Micro-Vértice)
        • Painting Ptex
        • Painting de Superfície (Polipintura)
      • Importando para a sala de Painting
        • Initial CC subdivision
        • UV Set smoothing
        • Sharp (hard) edge
        • Bloquear normais
        • Carregar novo layout UV após alterações no modelo
        • DAZ Genesis models into 3DCoat
        • ID map
      • Menus da área de trabalho de Painting
        • Edit menu
        • Menu de Texturas
          • Ferramentas de Baking de textura
        • Esconder
        • Menu para o Bake Paint
        • O seletor de cores
      • Surface Materials
      • Barra superior para a Painting
      • O Painel de Camadas
        • O Painel de Mistura
        • Layer and Clipping Masks
      • Ferramentas da sala de Painting
      • Opacidade - Transparência
      • Ajustar espaço de trabalho
        • Ajuste o conjunto de ferramentas
        • Exportando da Tweak Room
      • Painel de visualização de máscara/material
      • Exportando da sala de Painting
    • espaço de trabalho UV
      • Barra Superior UV
      • Painel de ferramentas UV Esquerda
      • Painel de visualização UV
      • exemplo de fluxo de trabalho UV
      • Importando para a sala UV
      • Exportando da Sala UV
    • Retopologia
      • Importando para a sala Retopo
      • Menu Retopo Mesh e Menu Bake
        • Modo Espelho Virtual
      • Bake menu
        • Treat Poly Groups as Paint Objects
        • Baking guide
      • Ferramenta Strokes em Retopologia
      • Barra superior
        • Selecione a geometria
      • Painel de ferramentas esquerdo na sala de Retopologia
        • Objetivo geral e função
        • Adicionar geometria
        • Ferramentas de ajuste de Retopo
        • Ferramentas UV
        • Comandos para sala de Retopologia
      • AUTORETOPO
        • Autopo guide
      • Grupos poli
    • Esculpir
      • Sculpt Layer
      • esculpir árvore
      • Opções de Brush de escultura
      • Top Bar
      • Motor de Brush
      • Submenu Geometria
      • Esculpir o menu “Clique com o botão direito”
      • Shaders
      • modo Voxel
        • Escultura Pura de Voxel
        • Densidade e resolução
        • Máquina de Barro
        • Ferramentas Voxel
        • Ferramentas de superfície em Voxels
        • Ferramentas de ajuste de Voxel
        • Painting Volumétrica
        • Ferramentas de Objetos Voxel
      • Modo de superfície
        • Ferramentas de superfície
        • Ferramentas personalizadas de superfície
        • Surface Layer
        • Ferramentas de ajuste de superfície
        • Painting de superfície
        • Resolução multinível
          • Multires tools
          • Multires adjust
          • Multires commands
      • Esculpir curvas
        • Curvas Spline
        • Splines model creation
      • Deslocamento do Vetor
      • Ferramentas de transformação de superfície
        • Ferramentas de Transformação Voxel
        • Instancer
        • Move
        • Pose
        • Fit
        • Reproject
        • Surface Array
      • Primitivos Voxel e Ferramentas de Import
        • Hollow Box
      • Booleanos ativos
      • Comandos para a sala Sculpt
      • Import para Sala de Escultura
      • Exportando da sala de esculpir
    • Renderizar
      • Comparison of different roughness values
      • Funções do painel de renderização
      • toca discos
      • Fakebake a iluminação -não PBR-
    • Factures
      • fluxo de trabalho
    • mais simples
    • Modelagem
      • Mesh Menu
      • Painel de ferramentas esquerdo na sala de modelagem
        • Adicionar geometria
          • Make Joints
          • Selecionado
        • Puxão
        • Smart Hybrid
        • UV
          • Comandos
        • Malha inteira
      • Exemplo de superfície de loft por Fluffy
      • Bloqueio por Poeboi
      • Import Zbrush Polygroups for UV mapping
    • Kitbash - Criação Rápida de Modelos 3D
      • Create kitbash
      • Left tool panel Kitbash
    • 3DPrint
    • Photogrammetry
      • How to install Reality Capture
      • Reality Capture doesn’t show up ?
    • Malha para sala NURBS
    • Nodes
      • Texturing with nodes
      • Biblioteca de nós de shaders de esculpir
      • Open PBR
  • API de Scripting e Core API
    • Core API
    • API do Python
    • Extensions and Addons

Cavity and Curvature maps

61 views 0

Written by Carlos
September 17, 2026

To bake a curvature map in 3DCoat, go to the Paint Room, open the Edit menu, and select Calculate Curvature.

Steps to Bake Curvature

  • Switch to the Paint Room after your mesh and normals are ready.
  • Hide the voxel display if needed by unchecking View > Show Voxel.
  • Go to the top menu and select Textures > Calculate Curvature (or Edit > Calculate Curvature depending on your version).
  • Choose your preferred curvature type in the pop-up panel (such as Local Curvature RGB or standard settings) and click OK to process the bake.
  • 3DCoat generates and applies the map to a background layer used by smart materials. You can turn the layer’s visibility on in your layer panel if you want to see the black-and-white or RGB breakdown visually.

Tips for Curvature Settings

  • RGB vs Black & White: Modern versions use RGB cavity/curvature by default to store concavity and convexity separately in different color channels.
  • Legacy Mode: If you prefer the old black-and-white style cavity map baker, you can switch it on by going to Edit > Preferences, navigating to the Tools section, and unchecking/changing the default cavity calculation settings.

How can i export only curvature and occlusion maps?

On Paint Room open the export Panel at File > Export > Objects & Textures

Create a new Export Constructor preset selecting only ExportAO and Export Curvature Map.


When i click on the Export Panel add texture and then i click RGB i cannot find any curvature name, only cavity. Is cavity same as curvature?

Yes and no.

Cavity Map focus on small details, while Curvature Map emphasize the overall shape of a surface, it map store the concave and convex edges of a mesh.

However ‘Cavity map’ is different than “Curvature map”. A Curvature map actually store the concave and convex edges of a mesh. Is also called Concavity, Convexity, Pits & Peaks, Worn Edge.

The convex (white) and the concave (Black) is Curvature map and the transition between peaks and crevices (gray values) of the model is Cavity map.

To produce a Cavity map that we could use as Curvature, we need more gray-scale values so that we can identify the convex (white), the concave (Black) and the transition between peaks and crevices (gray values) of the model.

– Cavity texture

Focuses on small details like crevices, grooves, and indentations (cavity maps are also known as crevice maps).
They are a more detailed version of ambient occlusion maps.
Cavity maps can be useful for improving dirt masks, enhancing colors, and adding highlights.

– Curvature texture

Focuses on the overall shape of a surface, showing where the surface curves inward or outward.
Curvature maps are also known as concavity, convexity, pits and peaks, or worn edge.
Curvature maps can be used to simulate edge wear, highlight details, and check for surface continuity.

Curvature can be both an RGB map encoding convexity/concavity in separate channels, or a gray scale map encoding convex edges as white and concave edges as black like in the image below.


I went ahead and exported cavity, it looks like a curvature map. Can i use that one as a curvature?

Select Cavity for Curvature. (the map generated is named Cavity at export).

This map is often (erroneously) called Cavity, but more accurately a Cavity map can also be a white map with concave edges encoded as black.

3DCoat does not have the option to export both maps at the same time, but you can generate them using the Generate Curvature map tool.


Utilize Normal maps during AO and Curvature baking

Other major new Improvement is the ability to utilize Normal maps during this baking process, so let’s go ahead and get started by hiding some of the layers.
Hold down the ALT key and select the visibility icon on one of these layers and the only one to leave intact is the one that has normal map information on it.

You need to have the Normal map visible so that 3DCoat can utilize it during this baking process.

So now let’s go ahead and go to the Edit menu and choose Calculate Occlusion and Curvature maps.


Pay attention that curvature consists of two components

First is local curvature that allows to detect small details, scratches.
Second is long-range curvature that flows smoothly and allows to detect large details.

If you need Gray Maps set intensity for both types: curvature or cavity.

  • Turn intensity up create a cavity map. (curvature intensity 400, long range curvature 10).
  • Turn intensity down create a curvature map. (curvature intensity 8, long range curvature 100).

Another workflow is to use Local Curvature RGB for Cavity map…

And Local Curvature for gray Curvature map

Following this steps you can get this result:


RGB Cavity map

Starting from 3DCoat 2021.53 the RGB Cavity map was introduced as the default calculation method in Texturing.

You can active RGB Cavity “Curvature” on Edit > Preferences > Tools.

On Cavity map RGB each channel contains different information, like convexity in red and concavity in green for instance.


Cavity Area Width:

This option requires the RGB cavity pre-calculated using the Textures->Calculate curvature, Local Curvature RGB.

When you first run the Curvature using RGB Cavity, the Light Baking Panel comes up.
Not change the settings Local Curvature RGB (you can change some later) and run the Curvature Calculation.

In the Smart Material Editor this option appears in the Editor when RGB Cavity is selected as default. You may vary the width of the area of the cavity influence, make the cavity narrow or wide.

* Before that, you need to remove the regular cavity layer if it already exists.

Adjusting Cavity Area Width and Overall Cavity Modulator can give you some nice effects like several layers of old paint on top of each other. As is show on this video:

The curvature layer is required to use cavity/curvature as a condition for materials or conditional painting.

If you work with Conditions painting by layer, on the upper right side you can adjust degree & contrast


Remember that Conditions painting only work on freeze for sculpt surface mode or Surface Paint on vertex on Paint Room.

But the standard sculpting brushes do not respect conditions, only work on Freeze mask to restrict where surface sculpting tools will be applied to the surface of the model.


Just a fast simple example:

Base layer
1st layer = Old Copper
2nd layer = Blue paint
3rd layer = Red paint.

Adjust each smart material differently using Adjusting Cavity Area Width and Overall Cavity Modulator.

It is really not one smart material but 3 separate Smart materials on separate layers.
Can create it using any default Smart Materials.

Follow this steps:

Open the Smart Material editor and the real time preview window, placing it over the model.
This is the most important because you get the real time view of the smart material and how it will be applied.
Do not go by as seen on the Smart Material Editor’s ball if you want real time feedback in this case.
Start Adjusting the Cavity Modulator and Cavity Area Width till you get the effect you want.
The picture above is the blue paint settings, it was the blue metal but looks like blue paint. It was the second layer in the stack.


This other example show how to further increase the variation of your applied Smart Material.

Assign Cube Mapping as Preferred mapping.
On Material/Stencil Control Panel, select Settings.

On this panel you can change the rotation of the cube map on the XYZ axis (per axis) and the expansion per axis as well as is shown in picture below.

You can preview in real time as the texture moves over the surface.

Last picture shown how to further increase variation using a layer blend mode. On this example is used the Overlay blend mode on the top layer.

You can adjust the strength of the blend mode by using the Opacity adjustment.

The new RGB cavity curvature calculation and Cavity Area Width plus Cavity Modulator is great.

Lots to explore here.

Have fun exploring!

Was this helpful?

Yes  No
Related Articles
  • Noise3D
  • Noise
  • Bake Geometry Info
  • Make Joints
  • Texturing with nodes
  • Hollow Box
Previously
Preferências
Up Next
Ver Menu
AI:
Hi! How can I help you?
Attention: This is a beta version of AI chat. Some answers may be wrong. See full version of AI chat