• Latviešu valoda
  • 3DCoat dokumentācija
  • Chapters
    • Ievads 3DCoat
    • Darba sākšana
    • Interfeiss un navigācija
    • Brush sastāvdaļas
    • Node System
    • GPU Texturing
    • Darba telpas Istabas
    • Scripting un Core API
    • Jautājumi/Atbildes
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Apmācības pamācības
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Latviešu valoda Latviešu valoda
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
  • 3DCoat dokumentācija
  • Chapters
    • Ievads 3DCoat
    • Darba sākšana
    • Interfeiss un navigācija
    • Brush sastāvdaļas
    • Node System
    • GPU Texturing
    • Darba telpas Istabas
    • Scripting un Core API
    • Jautājumi/Atbildes
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Apmācības pamācības
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Latviešu valoda Latviešu valoda
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
    • Daudzvalodu pārslēdzējs
Expand All Collapse All
  • Ievads 3DCoat
  • Darba sākšana
    • System requirements
    • Why 3DCoat is Unique?
    • 3DCoat aktivizēšana
    • Startēšanas kļūda
      • Startup error Mac
    • Color management
    • Upgrading permanent license
    • Linux Setup
      • Linux initial setup per-user installation
      • Linux initial setup for system
      • Tablet setup
      • To GTK3 from GTK2
      • Error libicuuc.so.70
    • Mapju struktūra
      • Custom documents folder
    • Dažādas “izšķirtspējas” formas
    • Tablet on Window
    • Import un Export
    • Applinks 3DCoat
      • Blender lietotnes saite
        • Blender with the Applink in Linux
      • Blender 4.2/3/4/5 applink
      • Max Applink
      • Houdini applink
      • Lightwave uplink
  • Navigation
    • Atvēršanas dialoglodziņš (ātrā sākuma izvēlne)
    • Navigācijas panelis
    • Kamera un navigācija
      • Customize Navigation as Blender
    • Left tool panel
    •  Activity Bar
    • Navigācija, izmantojot 3DConnexion ierīces
      • How to compile Spacenavd on non Ubuntu distro
    • Quick Access Menu
    • Stylus doesn’t work in sculpting
    • Karstie taustiņi
  • Interfeiss un navigācija
    • Failu izvēlne
    • Rediģēt izvēlni
      • Bake Geometry Info
      • Calculate Occlusion
      • Calculate Curvature
      • Light Baking Tool
      • Preferences
    • Skatīšanas izvēlne
    • Simetrija
    • Textures
    • Calculate
    • Slāņu izvēlne
    • Iesaldēšanas izvēlne
    • Hide
    • Bake
    • Līknes 2022
      • Izvēlne Līknes
      • Curves Properties RMB
      • Piepildiet ar sieta slāni
      • Scale of imported curves
    • Windows izvēlne
      • Windows uznirstošie paneļi ar cilnēm
      • Slīdņi
    • Scripts
    • Addons
    • Capture
    • Palīdzības izvēlne
    • Pielāgošana
    • Mainiet vai izveidojiet jaunu telpu
  • Brush sastāvdaļas
    • Brush Top Bar
    • Birstes vispārējai lietošanai
      • Izveidojiet otas un uzlīmes
      • Alfa veidošana no pašreizējās skulptūras
      • Izveidojiet Brush no 3D objekta
      • Create brushes based on Curves
      • Load photoshop .abr brushes
    • Insulti
      • Līknes uznirstošā izvēlne
    • Brush iespējas
    • Nosacījumu ierobežotājs
    • Sloksnes panelis
    • Trafaretu panelis
    • Gudri materiāli
      • Pievienojiet jaunus attēlus vai materiālus
      • Pievienojiet viedo materiālu slānim
      • Import Quixel Megascans
    • Kā izveidot Brush sākotnējos iestatījumus
  • Node System
    • Node Editor
    • Node & Object Inspectors
    • Node Graph
    • NodeGraph Language (NGL)
    • GPU Nodes
      • Color
      • GeometryIn
      • In
      • Layer
      • Material
      • Math
      • Noise
      • Noise3D
      • Out
      • Pattern
      • Pattern3D
      • Shape
      • Texture
      • Tilable
      • UV
    • Filters
    • Masks
    • Materials
    • Modifiers
    • Volumes
  • Bezmaksas 3DCoatPrint
  • GPU Texturing
    • PBM Channels
    • Per-Pixel Painting
  • Darba telpas Istabas
    • Painting
      • Tekstūru Painting un režīmi
        • Painting uz Per-Pixel
        • Nobīdes Painting (mikrovirsotne)
        • Ptex Painting
        • Virsmas Painting (polikrāsošana)
      • Importēšana Painting telpā
        • Initial CC subdivision
        • UV Set smoothing
        • Sharp (hard) edge
        • Bloķēt Normals
        • Ielādēt jaunu UV izkārtojumu pēc modeļa izmaiņām
        • DAZ Genesis models into 3DCoat
        • ID map
      • Painting darbvietas izvēlnes
        • Edit menu
        • Tekstūru izvēlne
          • Tekstūras Baking rīki
        • Slēpt
        • Bake Paint ēdienkarte
        • Krāsu atlasītājs
      • Surface Materials
      • Painting augšējā josla
      • Slāņu panelis
        • Sajaukšanas panelis
        • Layer and Clipping Masks
      • Painting telpas rīki
      • Necaurredzamība — caurspīdīgums
      • Pielāgojiet darbvietu
        • Tweak Toolset
        • Eksportēšana no Tweak Room
      • Masku/materiālu priekšskatījuma panelis
      • Eksportēšana no Painting telpas
    • UV darbvieta
      • UV augšējā josla
      • UV Kreisais instrumentu panelis
      • UV priekšskatījuma panelis
      • UV darbplūsmas piemērs
      • Importēšana UV telpā
      • Eksportēšana no UV telpas
    • Retopoloģija
      • Importēšana Retopo istabā
      • Retopo Mesh Menu un Bake Menu
        • Virtuālais spoguļa režīms
      • Bake menu
        • Treat Poly Groups as Paint Objects
        • Baking guide
      • Strokes rīks retopoloģijā
      • Augšējā josla
        • Izvēlieties ģeometriju
      • Kreisais rīku panelis Retopoloģijas telpā
        • Kopējais mērķis un funkcija
        • Pievienojiet ģeometriju
        • Retopo Tweak Tools
        • UV instrumenti
        • Komandas retopoloģijas telpai
      • AUTORETOPO
        • Autopo guide
      • Poli grupas
    • Skulpt
      • Sculpt Layer
      • Veidot koku
      • Sculpt Brush iespējas
      • Top Bar
      • Brush dzinējs
      • Ģeometrijas apakšizvēlne
      • Veidojiet izvēlni “Ar peles labo pogu noklikšķiniet”.
      • Ēnotāji
      • Voxel režīms
        • Pure Voxel Sculpting
        • Blīvums un izšķirtspēja
        • Māla dzinējs
        • Voxel Tools
        • Virsmas rīki Voxels
        • Voxel Adjustment Tools
        • Volumetriskā Painting
        • Voxel Objects Tools
      • Virsmas režīms
        • Virsmas instrumenti
        • Virsmas pielāgoti rīki
        • Surface Layer
        • Virsmas regulēšanas instrumenti
        • Virsmu Painting
        • Daudzlīmeņu izšķirtspēja
          • Multires tools
          • Multires adjust
          • Multires commands
      • Skulptūras līknes
        • Spline līknes
        • Splines model creation
      • Vektoru nobīde
      • Virsmas transformācijas rīki
        • Voxel Transform Tools
        • Instancer
        • Move
        • Pose
        • Fit
        • Reproject
        • Surface Array
      • Voxel primitīvas un Import rīki
        • Hollow Box
      • Dzīvi Būla skaitļi
      • Komandas Sculpt telpai
      • Import uz Sculpt Room
      • Eksportēšana no Skulptūru telpas
    • Renderēt
      • Comparison of different roughness values
      • Renderēšanas paneļa funkcijas
      • Skaņas atskaņotājs
      • Fakebake apgaismojums — bez PBR—
    • Factures
      • Darbplūsma
    • Vienkāršākais
    • Modelēšana
      • Mesh Menu
      • Kreisais instrumentu panelis modelēšanas telpā
        • Pievienojiet ģeometriju
          • Make Joints
          • Atlasīts
        • Kniebiens
        • Smart Hybrid
        • UV
          • Komandas
        • Viss tīkls
      • Bēniņu virsmas piemērs no Fluffy
      • Poeboi bloķēšana
      • Import Zbrush Polygroups for UV mapping
    • Kitbash — ātra 3D modeļu izveide
      • Create kitbash
      • Left tool panel Kitbash
    • 3DPrint
    • Photogrammetry
      • How to install Reality Capture
      • Reality Capture doesn’t show up ?
    • Tīkls uz NURBS istabu
    • Nodes
      • Texturing with nodes
      • Sculpt shaders Nodes Library
      • Open PBR
  • Scripting un Core API
    • Core API
    • Python API
    • Extensions and Addons

UV Set smoothing

2191 views 0

Written by Carlos
December 5, 2023

When you import a “model for pixel painting ” with 3DCoat, the setting window for import opens.
Among them, there is an item called “Smooth UV set”.

image.png

It is cut off in the image above, but when you try to select this item, the following warning will be displayed.

image.png

So if you select “Not subdivided” in the “Initial subdivision (number of polygons)” of the item above 2, you can choose “No smoothing” here.

Do you “subdivide” this?
Is it assumed that the CG model you are trying to import into 3D-COAT uses a subdivision surface (SDS)?.
And if you paste UV texture in SDS model, you will use “Smoothing interpolation of UV” function.

See also this article for “Initial subdivision (Number of polygons)“.
See also this article about “Smoothing Interpolation of UVs”

“Smoothing UV set” is asking what kind of “UV smoothing interpolation” is performed in the rendering software that uses it after creating a texture with 3DCoat.
So, before importing to 3DCoat, it is necessary to check the distortion using a checker map texture in the rendering software, and create an optimal interpolation method. You must decide what to do.

This is a correspondence option in between softwares.
there is a similar function in other software, so it would be good to check in advance.


In the case of Lightwave, the setting location is the item “Interpolation” of the texture name you are using in the “Texture” open in the “Vertex map” panel.

Select “Subdivision Surface” in the “Advanced Settings” in the “Modeler” field and open the “Subdivision Surface” Modeler in the “Modeler” field.UV smooth”


In the case of Blender, select “UV Smooth” in “Detailed Settings” with the ” Subdivision Surface ” modifier applied from the modifier item:


None / No Smoothing: UVs remain unchanged. UVs are not smoothed, boundaries are keep sharp.
Keep Corners / Smooth but keep corners: UV islands are smoothed, but their boundary (limits) remain unchanged.
Keep Corners, Junctions: UVs are smoothed, corners on discontinuous boundary and junctions of three or more regions are kept sharp.
Keep Corners, Junctions, Concave: UVs are smoothed, corners on discontinuous boundary, junctions of three or more regions and darts and concave corners are kept sharp.
Keep Boundaries / Smooth, Keep Edges: UVs are smoothed, boundaries (UV limits) are kept sharp.
All / Full UV Set Smoothing: UVs and their boundaries (UV limits) are smoothed.


Import for PPP using Uv Set Smoothing options

  • The initial subdivision (number of polygons) is “2604” (second from the top, equivalent to CC division level 2).
  • Smooth UV Set is “Preserve Corners and Smooth”
image.png

Then, the model of the mesh to which the SDS was applied is displayed first.
If you check the item “Low Resolution model” from the “View” menu, the model of the mesh before the model is replaced and the SDS is applied is displayed.If you do not have an account, you will be prompted to log in to your account.

image.png

This function is assigned “6” on the character key side as the default shortcut, and the model is replaced every time you press it.

It is just like pressing the tab key in Lightwave.

3DCoat seems to treat the former as “medium resolution mesh” and the latter as “low resolution mesh”.
This is indicated in the settings when exporting the model.

image.png

Painting is done with a medium resolution mesh displayed.

The export will be the flow of selecting the low resolution mesh.


What is UV set smoothing doing?

It is speculation that I saw the processing result to the last.The vertex moves along with the subdivision of the SDS and the texture is distorted, but when it is distorted in the opposite direction to the distortion at the import stage and SDS is applied, the distortion will not occur.I think that it is such a theory that it is corrected.


UV Stitching problem between 3DCoat and Blender

If you have an UV Stitching problem between 3DCoat and Blender, I mean, if in 3DCoat texture looks correctly, but when exporting to Blender, Textures looks stitched or distorted, the solution is to Triangulate the faces of the model before importing it from Blender to 3DCoat.

You can triangulate the whole model inside Blender selecting all faces and pressing CTRL + T or you can triangulate it in the import panel inside 3DCoat checking “Triangulate” option.
Also you can triangulate the model after you have done your texturing work, when you bring the model again into Blender from 3DCoat you can do CTRL + T inside Blender, and the Textures will look fine, as seen inside 3DCoat.

It seems that 3DCoat internally triangulates Blender´s Model, so that if you do (6) to look Low Poly Mesh inside 3DCoat it will appear the model before it is subdivided or triangulate inside 3DCoat so the UV Stitching will appear, but it looks fine when the Mid Poly Mesh is seen because it shows the triangulated model

So it seems that paint work in 3DCoat need tris, and to look it correctly inside Blender you also need Tris.

I hope this saves you lots of headaches as I had suffered with this Issue.

Tags:UV set smoothing

Was this helpful?

Yes  No
Related Articles
  • Noise3D
  • Noise
  • Bake Geometry Info
  • Make Joints
  • Texturing with nodes
  • Hollow Box
Previously
Initial CC subdivision
Up Next
Sharp (hard) edge
AI:
Hi! How can I help you?
Attention: This is a beta version of AI chat. Some answers may be wrong. See full version of AI chat