• Română
  • Documentația 3DCoat
  • Chapters
    • Introducere în 3DCoat
    • Noțiuni de bază
    • Interfață și navigare
    • Componentele Brush
    • Node System
    • GPU Texturing
    • Spații de lucru Camere
    • Scripting și Core API
    • Întrebări și răspunsuri
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Tutoriale de instruire
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Română Română
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
  • Documentația 3DCoat
  • Chapters
    • Introducere în 3DCoat
    • Noțiuni de bază
    • Interfață și navigare
    • Componentele Brush
    • Node System
    • GPU Texturing
    • Spații de lucru Camere
    • Scripting și Core API
    • Întrebări și răspunsuri
    • Licensing
  • Learn
    • Getting Started
    • Painting
    • Sculpt
    • Modeling
    • Retopology
    • UV
    • Smart Materials
    • Nodes
    • Photogrammetry
    • Render
    • Print
    • Learning
    • Tutoriale de instruire
  • Blog
    • 2026 Key Features and Improvements
    • Texturing with nodes
    • Shader Nodes VS. a Material Nodes
    • Multiple UV Tiles/UDIMs to one single UV set ?
    • I want to create geometry only with displacement to be manufactured with a CNC machine
    • Creating 3D Character Using 3DCoat
    • DAZ Genesis models into 3DCoat
    • Cavity and Curvature maps
    • Types of normal maps
    • Texture painting pipeline
    • Load new UV layout After Model Changes
    • Import Zbrush Polygroups for UV mapping
  • Products
    • 3DCoat
    • 3DCoatTextura
    • 3DCoatPrint
    • PBRLibrary
  • Store
  • Pilgway
  • Română Română
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
    • Comutator în mai multe limbi
Expand All Collapse All
  • Introducere în 3DCoat
  • Noțiuni de bază
    • System requirements
    • Why 3DCoat is Unique?
    • Activarea 3DCoat
    • Eroare de pornire
      • Startup error Mac
    • Color management
    • Upgrading permanent license
    • Linux Setup
      • Linux initial setup per-user installation
      • Linux initial setup for system
      • Tablet setup
      • To GTK3 from GTK2
      • Error libicuuc.so.70
    • Structura folderelor
      • Custom documents folder
    • Diferite forme de „rezoluție”
    • Tablet on Window
    • Import & Export
    • Applinks în 3DCoat
      • Legătura aplicației Blender
        • Blender with the Applink in Linux
      • Blender 4.2/3/4/5 applink
      • Max Applink
      • Houdini applink
      • Lightwave uplink
  • Navigation
    • Deschiderea casetei de dialog (meniu pornire rapidă)
    • Panoul de navigare
    • Cameră și navigație
      • Customize Navigation as Blender
    • Left tool panel
    •  Activity Bar
    • Navigare folosind dispozitive 3DConnexion
      • How to compile Spacenavd on non Ubuntu distro
    • Quick Access Menu
    • Stylus doesn’t work in sculpting
    • Taste rapide
  • Interfață și navigare
    • Meniul Fișier
    • Meniu Editare
      • Bake Geometry Info
      • Calculate Occlusion
      • Calculate Curvature
      • Light Baking Tool
      • Preferințe
    • Meniu Vizualizare
    • Simetrie
    • Textures
    • Calculate
    • Meniul Straturi
    • Înghețați meniul
    • Hide
    • Bake
    • Curbe 2022
      • Meniul Curbe
      • Curves Properties RMB
      • Umpleți cu strat de plasă
      • Scale of imported curves
    • Meniul Windows
      • Panouri pop-up Windows cu file
      • Glisoare
    • Scripts
    • Addons
    • Capture
    • Meniul de ajutor
    • Personalizare
    • Modificați sau creați o cameră nouă
  • Componentele Brush
    • Brush Top Bar
    • Perii de uz general
      • Creați pensule și decalcomanii
      • Realizarea alfa din sculptura curentă
      • Creați o Brush dintr-un obiect 3D
      • Create brushes based on Curves
      • Load photoshop .abr brushes
    • Accident vascular cerebral
      • Meniu pop-up Curves
    • Opțiuni de Brush
    • Limitator de condiții
    • Panoul de benzi
    • Panoul Șabloane
    • Materiale inteligente
      • Adăugați imagini sau materiale noi
      • Atașați un material Smart la un strat
      • Import Quixel Megascans
    • Cum se creează presetări pentru Brush
  • Node System
    • Node Editor
    • Node & Object Inspectors
    • Node Graph
    • NodeGraph Language (NGL)
    • GPU Nodes
      • Color
      • GeometryIn
      • In
      • Layer
      • Material
      • Math
      • Noise
      • Noise3D
      • Out
      • Pattern
      • Pattern3D
      • Shape
      • Texture
      • Tilable
      • UV
    • Filters
    • Masks
    • Materials
    • Modifiers
    • Volumes
  • 3DCoatPrint gratuit
  • GPU Texturing
    • PBM Channels
    • Per-Pixel Painting
  • Spații de lucru Camere
    • Painting
      • Painting cu textură și moduri
        • Painting Per-Pixel
        • Painting cu deplasare (Micro-Vertex)
        • Painting Ptex
        • Painting de suprafață (polipictura)
      • Import în camera de Painting
        • Initial CC subdivision
        • UV Set smoothing
        • Sharp (hard) edge
        • Blocați Normals
        • Încărcați un nou aspect UV după modificările modelului
        • DAZ Genesis models into 3DCoat
        • ID map
      • Meniurile spațiului de lucru pentru Painting
        • Edit menu
        • Meniul Texturi
          • Instrumente de Baking a texturii
        • Ascunde
        • Meniu pentru Bake Paint
        • Selectorul de culori
      • Surface Materials
      • Bara de sus pentru Painting
      • Panoul Straturi
        • Panoul de amestecare
        • Layer and Clipping Masks
      • Instrumente pentru camera de Painting
      • Opacitate - Transparență
      • Modificați spațiul de lucru
        • Tweak Toolset
        • Se exportă din Camera Tweak
      • Panoul de previzualizare Mască/Material
      • Export din camera de Painting
    • Spațiu de lucru UV
      • UV Top Bar
      • Panoul de instrumente UV stânga
      • Panoul de previzualizare UV
      • Exemplu de flux de lucru UV
      • Importul în camera UV
      • Export din camera UV
    • Retopologie
      • Import în camera Retopo
      • Meniul Retopo Mesh și Meniul Coace
        • Modul oglindă virtuală
      • Bake menu
        • Treat Poly Groups as Paint Objects
        • Baking guide
      • Instrumentul Strokes în Retopologie
      • In capul barului
        • Selectați geometria
      • Panoul de instrumente din stânga în camera Retopologie
        • Scopul și funcția generală
        • Adăugați geometrie
        • Retopo Tweak Tools
        • Instrumente UV
        • Comenzi pentru camera de retopologie
      • AUTORETOPO
        • Autopo guide
      • Poli Grupuri
    • Sculptează
      • Sculpt Layer
      • Sculpt Arborele
      • Opțiuni de Sculpt Brush
      • Top Bar
      • Motor cu Brush
      • Submeniu Geometrie
      • Sculptați meniul „clic dreapta”.
      • Shaders
      • Modul Voxel
        • Pure Voxel Sculpting
        • Densitate și rezoluție
        • Motor de lut
        • Instrumente Voxel
        • Instrumente de suprafață pe Voxels
        • Instrumente de ajustare Voxel
        • Painting volumetrică
        • Instrumente pentru obiecte Voxel
      • Modul de suprafață
        • Instrumente de suprafață
        • Instrumente personalizate pentru suprafață
        • Surface Layer
        • Instrumente de reglare a suprafeței
        • Painting de suprafață
        • Rezoluție pe mai multe niveluri
          • Multires tools
          • Multires adjust
          • Multires commands
      • Sculptează curbele
        • Curbe spline
        • Splines model creation
      • Deplasare vectorială
      • Instrumente de transformare a suprafeței
        • Instrumente de transformare Voxel
        • Instancer
        • Move
        • Pose
        • Fit
        • Reproject
        • Surface Array
      • Voxel Primitives și instrumente de Import
        • Hollow Box
      • Booleeni vii
      • Comenzi pentru camera Sculpt
      • Import în Sculpt Room
      • Se exportă din Camera Sculpt
    • Face
      • Comparison of different roughness values
      • Funcțiile panoului de randare
      • Placă turnantă
      • Fakebake the lighting -non PBR-
    • Factures
      • Fluxul de lucru
    • Cel mai simplu
    • Modelare
      • Mesh Menu
      • Panoul de instrumente din stânga în camera de modelare
        • Adăugați geometrie
          • Make Joints
          • Selectat
        • Ajustare fina
        • Smart Hybrid
        • UV
          • Comenzi
        • Întreaga plasă
      • Exemplu de suprafață de mansardă de Fluffy
      • Blockout de Poeboi
      • Import Zbrush Polygroups for UV mapping
    • Kitbash - Creare rapidă de modele 3D
      • Create kitbash
      • Left tool panel Kitbash
    • 3DPrint
    • Photogrammetry
      • How to install Reality Capture
      • Reality Capture doesn’t show up ?
    • Mesh în camera NURBS
    • Nodes
      • Texturing with nodes
      • Sculpt shaders Nodes Library
      • Open PBR
  • Scripting și Core API
    • Core API
    • API-ul Python
    • Extensions and Addons

PBM Channels

2258 views 3

Written by Volodymyr Makovetskyi
May 13, 2026

The 3DCoat render system supports an advanced physically based material (PBR/PBM) model. It includes not only standard channels but also specialized effects to create the most realistic surfaces possible.

Below is a detailed description of each channel and its impact on the material’s appearance, based on the internal shader architecture.


1. Base Channels

  • AlbedoColor (Albedo / Base Color)
    The main color of the surface. For dielectrics (non-metals), this is their own color. For metals, it’s their reflection color.
  • Opacity
    Determines how opaque a pixel is. Usually used for “CutOut” transparency (leaves, meshes), hiding geometry where the value is low.
  • Emissive
    Adds self-illumination to the material. The surface will be bright even in complete darkness and can cast light on neighboring objects (via global illumination).
  • TSNormal (Tangent Space Normal)
    A normal map that defines fine surface relief without altering the geometry itself.
  • AmbientOcclusion
    Micro-shadowing in recesses. Darkens areas that are hard for diffuse light to reach, emphasizing the volume of the relief.
  • Mask
    A general technical channel that can be used for layer blending logic or creating custom effects.

2. Specular & Metalness

  • Metalness
    Determines whether a material is a metal.
    0 (Dielectric): Reflects only 4% of light at a direct angle (depends on IOR), albedo acts as the surface color.
    1 (Metal): Albedo becomes the reflection color (e.g., yellow gold), and the diffuse color disappears.
  • Roughness / Gloss
    Gloss = 1.0 - Roughness. Determines the “polish” of the surface. High Gloss gives sharp, mirror-like reflections, while high Roughness blurs reflections, making the surface matte.
  • IOR (Index of Refraction)
    Determines the strength of the base reflection (F0) for non-metals. For example, water has an IOR ~1.33, glass ~1.5. Affects how strongly a surface reflects light when viewed at a direct angle.
    For refractive materials, IOR affects the refractive power of the Fresnel, and for opaque materials, only the Fresnel
    To enable control of this value via a brush, the internal parameter accepts values ​​ranging from 0 to 1; however, it is applied as a value three times greater—meaning 0 corresponds to 1, 0.333 corresponds to 1, and 1 corresponds to 3. Nevertheless, individual nodes within the node editor will accept the actual physical IOR value.

  • ReflectionColor
    Additional color control for reflection. Usually, reflection for non-metals is colorless, but this channel allows you to forcefully change its tint (e.g., for stylized materials).
  • SpecularEdgePower
    Controls the Fresnel effect (how strongly a material reflects light when viewed at a grazing angle). Allows you to enhance or weaken highlights on the edges of an object.
  • FlatSpecular
    Allows you to “flatten” reflections, ignoring fine irregularities from the normal map. Useful for stylization or avoiding “noisy” highlights on complex details.


3. Refraction / Glass

  • Refraction
    Unlike Opacity (which simply “cuts” a hole), this is physical material transparency (like glass or water). Light passes through the surface and refracts. The higher the value, the more transparent the material.
  • RefractionBlur
    Frosted glass. Blurs the background visible through a transparent object. Often linked to regular Roughness but allows controlling background blur separately.
  • RefractionMetalness
    0 = refraction, 0.5 = dielectric, 1.0 = metalness
  • RefractionChromatic (Chromatic Aberration)
    Separates refracted light into a spectrum (like a prism), creating colored halos on the edges of thick glass.


4. SubSurface Scattering (SSS & Volume)

Used for translucent materials (skin, wax, milk, plastic, jade).

  • SubSurface / Volume
    Determines how deep light penetrates into the material. This makes shadows softer and translucent edges brighter.
  • SubSurfaceColor
    The color of the light that scatters beneath the surface. For example, for human skin, AlbedoColor would be flesh-toned, while SubSurfaceColor would be red (due to blood under the skin).

    SubSurface Color also affects the refraction color.


5. Special Surface Effects

  • Anisotropy
    Stretches the specular highlight in a specific direction. Characteristic of brushed metal (pots), hair, or silk.
  • Iridescence
    Thin film interference effect. Creates rainbow shifting colors depending on the viewing angle (like on soap bubbles, insect wings, or spilled gasoline).
  • EffectNormal
    A color channel (vector direction) that defines the direction for stretching the anisotropic highlight and the direction for the iridescence gradient.
  • ClearCoat
    Creates an additional transparent glossy layer on top of the existing material (like car paint or varnished wood). This layer has its own reflection, independent of the base material.
  • ClearCoatGloss
    Determines how smooth the clear coat layer is.

6. Fabrics, micro-protrusions and Fuzz

These channels are designed to simulate materials with complex microstructures on the surface (fabrics, dust).

  • Sheen
    Creates a soft highlight on the edges of an object. Characteristic of velvet, peach, suede. This is light reflecting from micro-fibers at grazing angles.
  • SheenColor
    Tints the fabric highlight a specific color.
  • Microprotrusions (Fuzz / Dust)
    Simulates the presence of microscopic particles (or dust) on the surface that scatter light differently than the main surface. Can make the material “dusty”.
  • MicroprotrusionsGloss
    Controls how sharply these micro-fibers reflect light.
  • MicroprotrusionsColor
    The color of the dust or fuzz resting on the material.

In 3DCoat, FWSNormal is a specific technical property used in node-based materials within the GPUPPP (GPU Per-Pixel Painting) mode.
It specifically functions as a combination map that defines the direction of fur and organic fibers when simulating complex, layered textures.


How it Works
The node-based system utilizes FWSNormal alongside two other crucial parameters to create realistic, dynamic fur surfaces:

  • SoftDisplacement: Shifts the mesh vertices outwards to give the fur physical volume and height without ruining the underlying shading models.
  • Sheen: Simulates the way light scatters softly across the micro-fibers or tiny hairs.
  • FWSNormal: Acts as the directional map, telling the system exactly which way the fur or hair flows across the 3D surface.

How to Use It
To make sure properties like FWSNormal and SoftDisplacement function correctly during texturing, you need to ensure specific viewport settings are active:

  • Navigate to the View Menu.
  • Turn on “Show Displacement Mesh”.
  • Ensure Tessellation is enabled and configured properly so the software has enough geometry to calculate the physical shift.

Was this helpful?

3 Yes  No
Related Articles
  • Noise3D
  • Noise
  • Bake Geometry Info
  • Make Joints
  • Texturing with nodes
  • Hollow Box
Previously
GPU Texturing
Up Next
Per-Pixel Painting
AI:
Hi! How can I help you?
Attention: This is a beta version of AI chat. Some answers may be wrong. See full version of AI chat